Listy tabel przestawnych — informacje

Lista tabeli przestawnej to interakcyjna tabela służąca do dynamicznego analizowania danych za pomocą przeglądarki sieci Web. Można używać listy tabeli przestawnej do przeglądania i organizowania danych z list lub baz danych, wyszukiwania informacji lub szczegółów oraz tworzenia spersonalizowanych podsumowań i raportów. Istnieje również możliwość dodawania, usuwania i edycji danych szczegółowych wyświetlonych na liście tabeli przestawnej.

Na poniższej ilustracji przedstawiono prostą listę tabeli przestawnej, na której wyświetlane są podsumowane dane.

Przykład listy tabeli przestawnej

Podczas tworzenia listy tabeli przestawnej wybiera się z zewnętrznej bazy danych lub innego źródła dane, które mają być udostępnione użytkownikom na stronie sieci Web. Dane te stają się danymi źródłowymi listy tabeli przestawnej. Następnie można ustanowić wstępną prezentację lub widok danych, takie jak pokazane powyżej podsumowanie, które analizuje dane na jeden z wielu możliwych sposobów. Czynności te wykonuje się w programie do projektowania, takim jak Microsoft Excel lub Microsoft Access.

Po udostępnieniu listy tabeli przestawnej na stronie sieci Web przez jej opublikowanie, użytkownicy posiadający składniki Microsoft Office Web Components oraz przeglądarkę obsługującą listy tabel przestawnych — na przykład Microsoft Internet Explorer w wersji 4.01 lub nowszej — również mogą analizować dane. W przeglądarce lub innym dynamicznym środowisku użytkownicy mogą wyświetlać różne pola i zmieniać widok początkowy stosownie do swoich potrzeb. W zależności od programu użytego do projektowania i zastosowanych metod, można udostępnić listę tabeli przestawnej w programach innych niż przeglądarki.

Kiedy używać listy tabeli przestawnej

Składniki Microsoft Office Web Components zawierają zestaw narzędzi, którego można użyć, aby umieścić na stronach sieci Web interakcyjne listy tabel przestawnych, arkusze kalkulacyjne i wykresy. Każdy składnik posiada określone funkcje i możliwości, które wskazują jego konkretne zastosowanie.

Lista tabeli przestawnej przydaje się, jeśli trzeba umieścić informacje z bazy danych — takie jak rekordy programu Microsoft Access lub SQL Server bądź dane OLAP z bazy danych Microsoft SQL Server OLAP Services — w postaci interakcyjnej, przeznaczonej do współpracy z użytkownikami i do analizowania w przeglądarce sieci Web lub w innym środowisku dynamicznym. Można również zezwolić użytkownikom na dodawanie, edycję lub usuwanie danych szczegółowych.

Oto przykłady dobrego zastosowania list tabel przestawnych:

  • Udostępnienie bazy danych sprzedaży użytkownikom, którzy chcą porównywać wielkość sprzedaży w przypadku różnych produktów i regionów.
  • Publikowanie danych o kursach akcji na giełdzie, pochodzących z bazy danych, która jest często aktualizowana, aby użytkownicy mogli przeglądać i porównywać ceny akcji, które ich interesują.
  • Utworzenie katalogu produktów, w którym klient może znaleźć żądane artykuły i przejrzeć informacje dotyczące ceny, dostępności i kosztów dostarczenia.

Jeśli użytkownicy będą przeglądać dane bez aktywnej współpracy z nimi, to prostszym rozwiązaniem będzie nieinterakcyjna tabela wyświetlająca dane statyczne. Aby uzyskać informacje o innych sposobach udostępniania danych na stronie sieci Web, zobacz pomoc programu do projektowania stron sieci Web.

Tworzenie raportu podsumowującego

Poniższa seria przykładów pokazuje, jak osoba pracująca z programem do projektowania lub użytkownik podczas pracy z przeglądarką mogą przekształcić zestaw rekordów bazy danych w raport podsumowujący. W najprostszym formularzu, jaki można utworzyć, lista tabeli przestawnej wyświetla rekordy danych źródłowych w siatce z nazwami pól w górnej części. Poniższy przykład zawiera pola o nazwach Sport, Kwartał i Sprzedaż.

Przykład listy tabeli przestawnej z wszystkimi polami szczegółów

1 Obszary upuszczania

2 Pola szczegółów

Można utworzyć podsumowanie, przenosząc pola do innych obszarów i sortując pola, aby uzyskać logiczną organizację. Na przykład lista tabeli przestawnej pokazana poniżej jest oparta na poprzednim przykładzie i pokazuje, jak utworzyć podsumowanie, przenosząc pole Sport do obszaru wierszy, aby zorganizować dane ze względu na rodzaj sportu, a następnie sortując pole Kwartał, aby ustawić wielkość sprzedaży w porządku chronologicznym.

Przykład listy tabeli przestawnej z polem wiersza

1 Pole wiersza

2 Elementy

Aby porównać wielkość sprzedaży dla każdego rodzaju sportu w każdym kwartale, można przenieść pole Kwartał do obszaru kolumn, tak jak to zostało pokazane na poniższej ilustracji.

Przykład listy tabeli przestawnej polami wierszy i kolumn

1 Pole kolumny

2 Elementy

Aby przeglądać i porównywać całkowite wielkości sprzedaży zamiast szczegółowych wielkości sprzedaży, można dodać pole sumy o nazwie Suma sprzedaży, a następnie ukryć dane szczegółowe dla pól Sport i Kwartał. Pole sumy zawiera wartości podsumowane za pomocą listy tabeli przestawnej. W poniższym przykładzie komórka w prawym dolnym rogu pokazuje całkowitą wielkość sprzedaży dla tenisa w czwartym kwartale — czyli sumę wielkości sprzedaży ze wszystkich wierszy danych źródłowych, które zawierają zapis Tenis w miejscu rodzaju sportu oraz Kw4 w miejscu kwartału.

Przykład listy tabeli przestawnej z danymi podsumowania

1 Pole sumy

Aby utworzyć raport podsumowujący przedstawiony na początku tego tematu, należy wyświetlić sumy końcowe dla pól Sport i Kwartał.

Aby dalej analizować dane, można filtrować pola w celu odszukania określonych danych. Można, na przykład, wyświetlić jedynie dane dotyczące sprzedaży związanej z tenisem w trzecim kwartale. Można także dodać inne obliczenia do listy. Można, na przykład, wyświetlić największe wielkości sprzedaży dla każdego rodzaju sportu.

Projektowanie i publikowanie listy tabeli przestawnej

Ogólnych informacji na temat projektowania strony sieci Web należy szukać w pomocy programu używanego do tworzenia stron lub witryn sieci Web. Do tworzenia stron sieci Web zawierających listy tabel przestawnych można używać programów Microsoft Access (dostępny w pakiecie Microsoft Office Professional i Premium) oraz Microsoft FrontPage (dostępny w pakiecie Premium).

Przed rozpoczęciem

Przed rozpoczęciem projektowania listy tabeli przestawnej należy rozważyć, czy użytkownicy będą interakcyjnie pracować z danymi, czy też będą je tylko przeglądać.

  • Planując opublikowanie listy tabeli przestawnej na stronie sieci Web, trzeba pamiętać, że jej interakcyjność jest uzależniona od rodzaju używanej przeglądarki. Jeśli użytkownicy prawdopodobnie będą chcieli interakcyjnie pracować z listą tabeli przestawnej, należy upewnić się, że posiadają oni jedną z przeglądarek, które w pełni obsługują listy tabel przestawnych.
  • Osoba projektująca listę tabeli przestawnej przeznaczoną do użytku w programie innym niż przeglądarka sieci Web powinna dowiedzieć się, jakie możliwości listy tabeli przestawnej są w tym programie dostępne.

Listy tabel przestawnych są projektowane pod kątem interakcyjnej prezentacji list i informacji z baz danych. Zależnie od oczekiwanych wyników, właściwe może się okazać użycie innego składnika Microsoft Office Web Component lub dołączenie odmiennych formantów wraz z listą tabeli przestawnej.

Program do projektowania to program używany do tworzenia list tabel przestawnych. Różne programy do projektowania zapewniają różne możliwości.

Krok 1: Przygotowanie danych źródłowych

Dane źródłowe to informacje, które mają być wyświetlone i analizowane na liście tabeli przestawnej. W zależności od używanego programu do projektowania i typu danych źródłowych, które trzeba wyświetlić, konieczne może być skonfigurowanie źródła danych lub utworzenie kwerendy przed dołączeniem danych do listy tabeli przestawnej. Źródło danych to zbiór informacji potrzebnych do połączenia listy tabeli przestawnej z danymi w bazie danych, a kwerenda to sposób określenia, które informacje pobrać z bazy danych. Aby uzyskać informacje i instrukcje dotyczące dostępu do danych źródłowych z programu do projektowania, zobacz Pomoc tego programu.

Podczas publikowania raportu tabeli przestawnej programu Microsoft Excel na stronie sieci Web, program Excel wykonuje część pracy związanej z projektowaniem. Niektóre elementy raportów tabel przestawnych zmieniają się podczas zapisywania raportu jako listy tabeli przestawnej na stronie sieci Web. Czasami trzeba zmodyfikować niektóre elementy, takie jak obliczenia niestandardowe, aby wyświetlić żądane wyniki.

Krok 2: Utworzenie lub otwarcie listy tabeli przestawnej

Określone kroki umożliwiające utworzenie listy tabeli przestawnej różnią się w zależności od programu do projektowania. Aby uzyskać dokładne informacje, zobacz Pomoc programu do projektowania.

Chcąc zmodyfikować istniejącą listę tabeli przestawnej, na przykład taką, która powstała z zapisanego raportu tabeli przestawnej lub została skopiowana z innej strony sieci Web, można otworzyć plik zawierający listę tabeli przestawnej w programie do projektowania, a następnie uaktywnić formant przez wykonanie instrukcji danego programu (zazwyczaj jest to kliknięcie lub dwukrotne kliknięcie listy tabeli przestawnej). Aby uzyskać szczegółowe informacje, zobacz Pomoc programu do projektowania.

Podczas tworzenia nowej listy tabeli przestawnej zwykle określa się początkowy obszar na stronie sieci Web zajmowany przez listę w odniesieniu do innych elementów strony. Po dołączeniu danych źródłowych (zobacz krok 3 procesu) można przydzielić im odpowiednią ilość miejsca, a następnie umieścić listę tabeli przestawnej w najlepszym położeniu (zobacz krok 4 procesu).

Po utworzeniu lub zaznaczeniu listy tabeli przestawnej w programie do projektowania można pracować z listą tabeli przestawnej i kontynuować projektowanie, używając paska narzędzi i okna dialogowego Polecenia i opcje listy tabeli przestawnej.

Krok 3: Dołączenie danych źródłowych do listy tabeli przestawnej

W przypadku istniejącej listy tabeli przestawnej możliwe jest, że przypisano już dane źródłowe do danego formantu i są one przechowywane razem z nim. W przypadku nowej listy tabeli przestawnej należy ustanowić połączenie z danymi źródłowymi przygotowanymi w programie do projektowania.

Krok 4: Przydzielanie miejsca na listę tabeli przestawnej

W ramach listy tabeli przestawnej można ustawić stałą wysokość i szerokość albo zezwolić na rozwijanie listy do maksymalnego ustawionego rozmiaru, z uwzględnieniem w razie potrzeby pasków przewijania. Ustawienia te określają zarówno rozmiar listy tabeli przestawnej w przeglądarce, jak i rozmiar obszaru, na którym pracuje się podczas projektowania prezentacji danych w programie do projektowania. Później, jeśli potrzebna jest inna ilość miejsca na listę tabeli przestawnej lub przeglądarka wymaga innych ustawień niż te, z których korzysta się w programie do projektowania, można wprowadzić odpowiednie zmiany.

Krok 5: Zaprojektowanie układu danych

Następnym krokiem, po utworzeniu listy tabeli przestawnej i dodaniu do niej danych źródłowych, jest określenie sposobu zaprezentowania danych przy pierwszym otwarciu strony sieci Web przez użytkownika.

  • Dopasowanie prezentacji do potrzeb przyszłych użytkowników. Trzeba wziąć pod uwagę prawdopodobny sposób korzystania z danych. Na przykład jeśli każdy użytkownik będzie zaznajomiony z listami tabel przestawnych i będzie chciał tworzyć własne układy danych i podsumowania, to można wyświetlić tylko niektóre pola danych źródłowych. Jeśli jednak użytkownicy będą potrzebowali konkretnego typu podsumowań lub widoku danych albo oczekiwali, że osoba projektująca stronę całkowicie opracuje jej układ, albo z danych będą korzystać osoby o zróżnicowanych umiejętnościach, to należy samodzielnie ułożyć, zorganizować i sformatować dane.

    Należy pamiętać, że w przypadku niektórych przeglądarek, takich jak Microsoft Internet Explorer w wersji 3.x, użytkownicy nie mogą przeglądać danych ani korzystać z nich interakcyjnie. Aby pracować z danymi w sposób interakcyjny, użytkownicy muszą posiadać przeglądarkę obsługującą listy tabel przestawnych.

  • Skonfigurowanie wyglądu początkowego. Aby wyświetlić dane na liście tabeli przestawnej, trzeba dodać pola z danych źródłowych do obszarów upuszczania dla różnych typów pól. Należy rozważyć sposób podsumowywania danych podczas tworzenia i wyświetlania sum.

  • Zorganizowanie danych. Po dodaniu pól i sum można na kilka sposobów rozmieścić wyświetlane wyniki. Można sortować dane, aby zmienić kolejność elementów danych w polu. Chcąc wyświetlić podzbiór danych, można filtrować pola, aby wyświetlać tylko elementy danych zgodne z żądanymi wartościami; można także wyświetlać lub ukrywać szczegóły dla określonych pól lub elementów danych.

  • Formatowanie danych. Opcje formatowania dotyczą ustawienia czcionki i kolorów tła, zmiany wyświetlania formatu liczb, wyrównywania tekstu wewnątrz komórek, zmiany szerokości kolumn oraz wyświetlania lub ukrywania wskaźników rozwijania (pola Pole Plus lub Pole Minus) obok elementów. Można również dodać i sformatować tytuł listy tabeli przestawnej.

Krok 6: Ustawienie ograniczeń dostępu w przeglądarce

Nawet w przeglądarce, która w pełni obsługuje listy tabel przestawnych, takiej jak Microsoft Internet Explorer 5, użytkownicy nie mają dostępu do niektórych poleceń i funkcji, które są używane w programie do projektowania. Aby uniemożliwić użytkownikom dokonywanie zmian lub sprawić, że część danych źródłowych będzie niedostępna, można ustawić więcej ograniczeń.

Krok 7: Dodawanie innych formantów, automatyzacji lub pomocy

Wykonaj co najmniej jedną z następujących czynności:

  • Dołącz wykres. Można użyć innego składnika Microsoft Office Web Component — składnika Wykres — aby wyświetlić osobny wykres dla danych z listy tabeli przestawnej. W przeglądarce wykres jest automatycznie aktualizowany, kiedy użytkownik wprowadza zmiany w danych na liście tabeli przestawnej. Na przykład jeśli lista tabeli przestawnej zawiera dane dotyczące zmian kursu akcji w czasie, do strony sieci Web można dołączyć wykres, który będzie graficznie przedstawiał zmiany ceny. Po zaznaczeniu przez użytkownika innych akcji w celu przeglądania ich na liście tabeli przestawnej, wykres będzie automatycznie zaktualizowany, aby pokazywać ceny zaznaczonych akcji.

  • Napisz skrypty. Skrypty sieci Web lub inne programy udostępniają wiele funkcji i możliwości list tabel przestawnych i umożliwiają kontrolę nad nimi. Doświadczenie w pisaniu skryptów dla stron sieci Web za pomocą języka takiego jak Visual Basic Scripting Edition (VBScript) lub JavaScript pozwala na dodanie do strony sieci Web skryptów, które zautomatyzują niektóre zadania w przeglądarce. Można, na przykład, napisać skrypt, aby automatycznie wyświetlać listę tabeli przestawnej w postaci jednego z najbardziej użytecznych układów, a następnie dodać do strony sieci Web przyciski służące do wybierania poszczególnych układów. Można również umożliwić użytkownikom uruchamianie skryptów z paska narzędzi i menu skrótów.

    Program do projektowania może zawierać narzędzia do pisania skryptów. Na przykład programy pakietu Microsoft Office zawierają edytor Microsoft Script Editor. Aby uzyskać informacje na temat pisania skryptów, zobacz Pomoc programu do projektowania. Aby uzyskać informacje na temat dostępu do funkcji list tabel przestawnych za pomocą skryptów, zobacz pomoc dotyczącą programowania list tabel przestawnych.

  • Dostarcz pomoc. Użytkownicy mogą w przeglądarce korzystać z oddzielnej pomocy, o ile nie ograniczono do niej dostępu, w ramach listy tabeli przestawnej, która wyjaśnia, jak używać poszczególnych funkcji. Można uzupełnić tę pomoc, podając na stronie sieci Web określone instrukcje i informacje dotyczące używania danej listy tabeli przestawnej. Na przykład można podać informację, z której bazy danych pochodzą dane źródłowe i do kogo zwracać się z prośbą o hasło, jeśli jest ono wymagane.

Krok 8: Testowanie i opublikowanie

Przed udostępnieniem listy tabeli przestawnej użytkownikom zalecane jest przetestowanie jej w przeglądarce sieci Web. Użytkownicy, którzy chcą interakcyjnie korzystać z danych, powinni zainstalować program Microsoft Internet Explorer w wersji 4.01 lub nowszej. Jeśli użytkownicy posiadają różne wersje przeglądarek, to należy przetestować listę tabeli przestawnej pod kątem każdej z nich, aby mieć pewność, że każda osoba będzie w stanie wykonać przewidywane zadania i czynności. W przypadku dostarczania pomocy na stronie sieci Web, należy upewnić się, że pomoc odpowiednio działa i wygląda.

Jeśli lista tabeli przestawnej i strona sieci Web nie są zadowalające, to można wrócić do programu do projektowania i wprowadzić zmiany. Oprócz zmiany ustawień wprowadzonych na etapie projektowania układu danych i dostosowywania listy tabeli przestawnej, można również zmodyfikować cały układ lub usunąć niepotrzebne pola.

Po uzyskaniu w pełni satysfakcjonujących wyników, należy udostępnić stronę sieci Web użytkownikom. Aby uzyskać informacje dotyczące publikowania stron sieci Web, zobacz Pomoc programu do projektowania lub skonsultuj się ze swoim webmasterem.


Przeglądarki obsługujące listy tabel przestawnych

Aby pracować z interakcyjnymi listami tabel przestawnych w przeglądarce Microsoft Internet Explorer w wersji 4.01 lub nowszej, użytkownik musi zainstalować składniki Microsoft Office Web Components oraz posiadać odpowiednią licencję Microsoft Office XP. Użytkownicy, którzy nie mają licencji Office XP, mogą zainstalować wspomniane składniki i przeglądać je na stronie sieci Web, ale nie mogą interakcyjnie z nimi pracować. Dowiedz się więcej na temat instalacji i licencjonowania składników.

Poniżej przedstawiono poziomy obsługi w przeglądarce, przy założeniu że użytkownik ma składniki Office Web Components oraz licencję Office XP.

Program Microsoft Internet Explorer 5 i nowszy

Użytkownik może korzystać ze wszystkich funkcji listy tabeli przestawnej dostępnych z poziomu przeglądarki. Zmiany wprowadzone przez użytkownika, takie jak formatowanie i zmiana układu, są zachowywane po opuszczeniu listy i powrocie do niej podczas tej samej sesji pracy z przeglądarką.

Program Microsoft Internet Explorer w wersjach 4.01, 4.1x i 4.2x

Użytkownik może korzystać ze wszystkich funkcji listy tabeli przestawnej dostępnych z poziomu przeglądarki. Zmiany wprowadzone przez użytkownika są zachowywane po opuszczeniu listy i powrocie do niej podczas tej samej sesji pracy z przeglądarką. Aby przeglądać listę tabeli przestawnej na stronach dostępu do danych utworzonych w programie Microsoft Access, należy zainstalować program Internet Explorer 5.

Inne przeglądarki

We wcześniejszych wersjach programu Microsoft Internet Explorer oraz w innych przeglądarkach użytkownicy nie mogą wyświetlać list tabel przestawnych. Lista tabeli przestawnej pojawia się w postaci obrysu pola lub nie pojawia się wcale na stronie sieci Web.


Składniki Microsoft Office Web Components — informacje

Składniki Microsoft Office Web Components to zestaw formantów ActiveX instalowanych razem z pakietem Microsoft Office XP. Zainstalowanie tych składników umożliwia interakcyjne korzystanie z arkusza kalkulacyjnego, listy tabeli przestawnej lub wykresu na stronach sieci Web wyświetlanych za pomocą przeglądarki Microsoft Internet Explorer w wersji 4.01 lub późniejszej. Aby korzystać ze składników Microsoft Office Web Components na stronie dostępu do danych w programie Microsoft Access, należy zainstalować program Internet Explorer w wersji 5 lub nowszej.

Jeśli składniki nie są zainstalowane na komputerze użytkownika, ale ma on licencję wielostanowiskową Office XP zezwalającą na rozpowszechnianie w sieci intranet, to można tak skonfigurować składniki Office Web Components, aby inni użytkownicy byli monitowani o ich pobranie z firmowej sieci intranet. Dzięki temu mogą oni używać strony dostępu do danych bez konieczności instalowania aplikacji Office XP na swoich komputerach.

Aby uzyskać informacje dotyczące sposobu konfigurowania składników Office Web Components, zobacz zestaw Microsoft Office XP Resource Kit.


Instalowanie, licencjonowanie i rozpowszechnianie składników Office Web Components

Gdy zaprojektujesz stronę sieci Web za pomocą składników Office Web Components, każdy użytkownik posiadający licencję pakietu Office XP będzie mógł interaktywnie pracować ze składnikami w przeglądarce, ale do zadeklarowanego przez projektanta poziomu interaktywności. To znaczy, że użytkownik z odpowiednią licencją może zmieniać dane w arkuszu kalkulacyjnym, zmieniać formatowanie, przeciągać pola na wykresie lub liście tabeli przestawnej i tak dalej, jeśli opcje te nie zostaną zastrzeżone podczas projektowania. Użytkownicy posiadający licencję pakietu Office XP mogą także tworzyć, projektować i modyfikować składniki w środowisku projektowania, takim jak programy Microsoft FrontPage lub Microsoft Access.

Użytkownicy nie posiadający licencji pakietu Office XP mogą wyświetlić składniki i zawarte w nich dane, mogą też wydrukować widok składników, ale nie mogą interaktywnie pracować ze składnikami ani operować nimi w środowisku projektowania. To znaczy, że gdy rozpowszechniana jest strona sieci Web wykorzystująca składniki, wówczas użytkownicy mający licencje pakietu Office XP, będą mieli dostęp do wszystkich funkcji, a użytkownicy bez licencji będą mogli jedynie wyświetlać dane i informacje, o ile są one podane.

Instalowanie składników Microsoft Office Web Components

Składniki Microsoft Office Web Components są instalowane wraz z pakietem Microsoft Office XP i aplikacjami pakietu Microsoft Office lub mogą być zainstalowane oddzielnie z punktu instalacyjnego udostępnianego przez projektanta strony sieci Web.

Gdy rozpowszechniana jest strona sieci Web wykorzystująca składniki, wówczas użytkownicy, którzy nie mają zainstalowanych składników będą monitowani o zainstalowanie składników, o ile projektant strony sieci Web odpowiednio skonfiguruje składniki. Projektant strony sieci Web musi także udostępnić punkt instalacyjny składników i wskaźnik do tej lokalizacji na stronie instalacyjnej składników. Aby uzyskać więcej informacji, zapoznaj się z zestawem Microsoft Office XP Resource Kit.

Po zainstalowaniu składników Microsoft Office Web Components użytkownicy, którzy mają dostęp do licencji pakietu Office XP będą mogli pracować interaktywnie ze składnikami i dokonywać w nich zmian. Użytkownicy bez licencji będą mogli wyświetlać i drukować składniki i zawarte w nich dane, ale nie będą mogli pracować interaktywnie ani dokonywać zmian.

Szczegółowe informacje o licencjonowaniu i funkcjach

Pakiet Microsoft Office XP zainstalowany na komputerze Użytkownicy dysponują wszystkimi funkcjami i mogą interaktywnie pracować ze składnikami, włącznie z funkcjami czasu uruchomienia i czasu projektowania.

Aplikacja pakietu Microsoft Office XP zainstalowana na komputerze Użytkownicy mogą pracować interaktywnie ze składnikiem w trybie projektowania jedynie w tej aplikacji (a nie w przeglądarce ani w innych aplikacjach).

Licencja pakietu Microsoft Office XP w trybie dostępu z lokalizacji (użytkownik nie ma zainstalowanego na swoim komputerze pakietu Office XP, ale organizacja lub przedsiębiorstwo mają umowę licencyjną w trybie dostępu z lokalizacji) Użytkownicy dysponują wszystkimi funkcjami i mogą pracować interaktywnie ze składnikami, włącznie z funkcjami czasu uruchomienia i czasu projektowania. Projektant strony sieci Web musi natomiast podać lokalizację, z której można pobrać składniki oraz musi odwołać się do licencji w trybie dostępu z lokalizacji w pliku pakietu licencji (lpk), który jest skojarzony z co najmniej jedną stroną sieci Web. Do utworzenia odpowiedniego pliku licencji stron służy narzędzie License Package Authoring Tool. Więcej informacje można znaleźć w witrynie MSDN Online.

Brak pakietu Microsoft Office XP, aplikacji pakietu Microsoft Office XP lub licencji w trybie dostępu z lokalizacji Użytkownicy mogą wyświetlać i drukować składniki w trybie tylko do przeglądania, ale nie mogą pracować interaktywnie ze składnikami ani używać funkcji projektowania.


Tryb tylko do wyświetlania składników Office Web Components — informacje

Jeśli na komputerze użytkownika nie zainstalowano licencji pakietu Microsoft Office XP i nie jest ona dostępna za pośrednictwem jednej z aplikacji Microsoft Office XP, to istnieje możliwość wyświetlenia składników Microsoft Office Web Component — Arkusza kalkulacyjnego, Wykresu lub Tabeli przestawnej — na stronie sieci Web, ale nie można z nich korzystać w sposób interakcyjny.

Aby uzyskać taką możliwość i korzystać z wszystkich funkcji wyświetlanego składnika, należy zainstalować pakiet Microsoft Office XP lub uzyskać dostęp do licencji Office XP. Jeśli użytkownik pracuje w środowisku grupowym lub w firmie, może zwrócić się o pomoc do administratora sieci.

W trybie tylko do wyświetlenia można:

  • wyświetlać dane;
  • drukować;
  • zaznaczać i przewijać;
  • używać hiperłączy;
  • zmieniać rozmiar komponentu;
  • zaznaczać arkusze w składniku Arkusz kalkulacyjny;
  • rozwijać i zwijać elementy na liście tabeli przestawnej;
  • odświeżać dane na liście tabeli przestawnej;
  • używać poleceń Informacje, Pomoc i Odśwież; nie obejmuje to tematów pomocy, które dotyczą czynności wykonywanych w sposób interakcyjny (takich jak formatowanie komórek, przeciąganie pól, sortowanie, filtrowanie itd.).

Wszystkie inne polecenia — z wyjątkiem poleceń Informacje, Pomoc i Odśwież — w trybie tylko do wyświetlenia są niedostępne.


Uzyskiwanie pomocy — informacje

Część zawartości tego tematu może nie dotyczyć niektórych języków.

Uzyskiwanie pomocy w innych programach do projektowania

Podczas pracy w programie do projektowania można uzyskać pomoc w następujący sposób:

  • Pomoc programu do projektowania Aby uzyskać informacje o poleceniach i funkcjach dostępnych w programie do projektowania, których można użyć do pracy z listami tabel przestawnych, zobacz Pomoc stosowanego programu. Na przykład w programie Microsoft FrontPage należy kliknąć Asystenta pakietu Office lub przycisk Microsoft FrontPage — Pomoc [image].

    Program Microsoft Excel zawiera zarówno pomoc ogólną, dotyczącą zapisywania danych programu Excel przeznaczonych do wykorzystania na stronach sieci Web, jak i specyficzne informacje na temat zapisywania list tabel przestawnych, które mają być zastosowane na stronach sieci Web. Aby uzyskać dostęp do pomocy tego typu w programie Excel, należy kliknąć Asystenta pakietu Office lub przycisk Microsoft Excel — Pomoc [image].

  • Pomoc w czasie projektowania listy tabeli przestawnej Jeżeli w innych programach do projektowania dostępne jest okno dialogowe Polecenia i opcje, to dostępne są również wyświetlane tematy Pomocy. Na liście tabeli przestawnej utworzonej lub uaktywnionej w programie do projektowania należy kliknąć przycisk Pomoc [image] w oknie dialogowym Polecenia i opcje lub przycisk Pomoc na pasku narzędzi listy tabeli przestawnej.

Uzyskiwanie pomocy przy pisaniu skryptów i programów dla list tabel przestawnych

Aby zautomatyzować listy tabel przestawnych, można użyć skryptów i programów lub umieścić listy tabel przestawnych w programie innym niż przeglądarka sieci Web, na przykład w programie napisanym w środowisku programowania Microsoft Visual Basic.

Pisanie skryptów

Programy pakietu Microsoft Office zawierają edytor Microsoft Script Editor, który ułatwia pisanie skryptów. Na przykład podczas pracy z danymi na stronie dostępu programu Microsoft Access można użyć programu Microsoft Script Editor w widoku Projekt, aby dostosować listę tabeli przestawnej. Aby uzyskać informacje na temat uruchamiania programu Script Editor, zobacz Pomoc programu do projektowania pakietu Office. W programie Script Editor można wyświetlić dodatkową pomoc dotyczącą używania jego funkcji i pisania skryptów.

Pomoc modelu obiektowego

Aby uzyskać pomoc w projektowaniu programu lub skryptu przeznaczonego do pracy z listą tabeli przestawnej, można użyć opisu języka Visual Basic dla składników Microsoft Office Web Components, aby wyświetlić informacje dotyczące modelu obiektów, właściwości i metod odpowiednich dla list tabel przestawnych. Pomoc dotycząca modelu obiektowego jest instalowana podczas instalacji składników Microsoft Office Web Components, w skład których wchodzą listy tabel przestawnych. W zależności od używanego programu do projektowania, można uzyskać tę pomoc, stosując jeden z następujących sposobów:

  • Pomoc w programie Microsoft Visual Basic W środowiskach Visual Basic lub Visual Basic for Applications (VBA) można utworzyć odwołanie do biblioteki składników Microsoft Office Web Components. Można także uzyskać pomoc w przeglądarce obiektów lub po zaznaczeniu słowa kluczowego i naciśnięciu klawisza F1. Aby uzyskać informacje dotyczące tworzenia odwołań i używania Pomocy modelu obiektów, zobacz Pomoc w programie Visual Basic lub VBA.
  • Pomoc w innych środowiskach W przypadku korzystania z innego środowiska projektowania, należy zlokalizować plik pomocy Owcvba10.chm i kliknąć go dwukrotnie.

Uzyskiwanie pomocy podczas korzystania z listy tabeli przestawnej w przeglądarce

W przeglądarce użytkownik ma dostęp do pomocy w ramach listy tabeli przestawnej. Jest ona dostępna w czasie wykonywania i opisuje, jak korzystać z funkcji i możliwości list tabel przestawnych w przeglądarce.

Użytkownicy posiadający program Microsoft Internet Explorer w wersji 4.01 lub nowszej oraz składnik Microsoft Office Web Components automatycznie uzyskują dostęp do pomocy dotyczącej list tabel przestawnych. Pomoc dostępna w czasie wykonywania jest niezależna od pomocy dostępnej w menu Pomoc przeglądarki.

Dostępne w czasie wykonywania tematy pomocy dotyczące listy tabeli przestawnej zawierają ogólne informacje na temat ich używania w przeglądarce. Nie są to tematy pomocy, które można przeczytać aktualnie, dotyczące projektowania list tabel przestawnych. Inne składniki Microsoft Office Web Components, takie jak arkusz kalkulacyjny, również posiadają oddzielną pomoc dostępną w przeglądarce.

Aby zobaczyć, jaka pomoc jest dostępna w przeglądarce, należy utworzyć listę tabeli przestawnej na stronie sieci Web, otworzyć tę stronę w przeglądarce Internet Explorer, kliknąć listę tabeli przestawnej, a następnie kliknąć przycisk Pomoc [image] na pasku narzędzi listy. W oknie pomocy pojawi się spis treści i opcja wyszukiwania tematów. Asystent pakietu Office nie jest dostępny w przeglądarce, aby odpowiadać na pytania.

Użytkownicy nieposiadający składników Office Web Components lub programu Internet Explorer w wersji 4.01 bądź nowszej nie mają dostępu do pomocy w czasie wykonywania.


Skróty klawiaturowe

Aby uzyskać informacje na temat uaktywniania i dezaktywacji listy tabeli przestawnej za pomocą klawiatury, zobacz Pomoc używanego programu do projektowania.

Klawisze służące do zaznaczania elementów listy tabeli przestawnej

Klawisz TAB
Przenosi zaznaczenie z lewej strony na prawą, a następnie w dół.
ENTER
Przenosi zaznaczenie z góry na dół, a następnie w prawo.
SHIFT+TAB
Zaznacza komórkę po lewej stronie. Jeśli komórka bieżąca jest pierwszą komórką z lewej strony, to kombinacja klawiszy SHIFT+TAB zaznacza ostatnią komórkę w poprzednim wierszu.
SHIFT+ENTER
Zaznacza komórkę powyżej komórki bieżącej. Jeśli komórka bieżąca jest pierwszą komórką od góry, to kombinacja klawiszy SHIFT+ENTER zaznacza ostatnią komórkę w poprzedniej kolumnie.
CTRL+TAB
Zaznacza komórki szczegółów dla następnego elementu w obszarze kolumny.
CTRL+ENTER
Zaznacza komórki szczegółów dla następnego elementu w obszarze wiersza.
SHIFT+CTRL+TAB
Zaznacza komórki szczegółów dla poprzedniego elementu w obszarze kolumny.
SHIFT+CTRL+ENTER
Zaznacza komórki szczegółów dla poprzedniego elementu w obszarze wiersza.
Klawisze strzałek
Przenoszą zaznaczenie w kierunku wskazanym przez strzałkę. Jeśli zaznaczone jest pole wiersza lub kolumny, to należy nacisnąć STRZAŁKĘ W DÓŁ, aby przejść do pierwszego elementu danych w polu, a następnie nacisnąć klawisz strzałki, aby przejść do następnego lub poprzedniego elementu albo wrócić do pola. Jeśli zaznaczone jest pole szczegółów lub element danych, to należy nacisnąć STRZAŁKĘ W DÓŁ lub STRZAŁKĘ W PRAWO, aby przejść do pierwszej komórki w obszarze szczegółów lub w obszarze danych.
SHIFT+klawisz strzałki
Rozszerza lub redukuje zaznaczenie w kierunku wskazanym przez strzałkę.
CTRL+ klawisz strzałki
Przenosi zaznaczenie do ostatniej komórki w kierunku wskazanym przez strzałkę.
SHIFT+ALT+klawisz strzałki
Przenosi zaznaczony element w kierunku wskazanym przez strzałkę.
HOME
Zaznacza pierwszą komórkę z lewej strony bieżącego wiersza.
END
Zaznacza pierwszą komórkę z prawej strony bieżącego wiersza.
CTRL+HOME
Zaznacza pierwszą komórkę z lewej strony pierwszego wiersza.
CTRL+END
Zaznacza ostatnią komórkę ostatniego wiersza.
SHIFT+CTRL+HOME
Rozszerza zaznaczenie do pierwszej komórki z lewej strony pierwszego wiersza.
SHIFT+CTRL+END
Rozszerza zaznaczenie do ostatniej komórki ostatniego wiersza.
CTRL+SPACJA
Zaznacza pole dla aktualnie wybranego elementu danych, sumy lub szczegółów.
SHIFT+SPACJA
Zaznacza cały wiersz zawierający aktualnie zaznaczoną komórkę.
CTRL+A
Zaznacza całą listę tabeli przestawnej.
PAGE DOWN
Wyświetla następny ekran. Ekran to wszystkie dane aktualnie wyświetlone na liście tabeli przestawnej.
PAGE UP
Wyświetla poprzedni ekran.
SHIFT+PAGE DOWN
Rozszerza zaznaczenie o jeden ekran w dół. Ekran to wszystkie dane aktualnie wyświetlone na liście tabeli przestawnej.
SHIFT+PAGE UP
Redukuje zaznaczenie o jeden ekran.

Klawisze służące do wydawania poleceń

SHIFT+F10
Wyświetla menu skrótów dla zaznaczonego elementu listy tabeli przestawnej. Za pomocą menu skrótów można wykonywać polecenia na liście tabeli przestawnej.
Podkreślona litera
Wykonuje polecenie menu skrótów.
ESC
Zamyka menu skrótów bez wykonania polecenia.
CTRL+7
Wyświetla lub ukrywa pasek narzędzi listy tabeli przestawnej.
ALT+ENTER
Wyświetla okno dialogowe Polecenia i opcje.
ALT+F4
Zamyka okno dialogowe Polecenia i opcje.
F9
Odświeża listę tabeli przestawnej na podstawie danych źródłowych.
ESC
Anuluje operację odświeżania będącą w toku.
CTRL+C
Kopiuje zaznaczone dane z listy tabeli przestawnej do Schowka.
CTRL+V
Wkleja zawartość Schowka.
CTRL+X
Przenosi zaznaczone dane do Schowka.
CTRL+E
Eksportuje listę tabeli przestawnej do programu Microsoft Excel.

Klawisze służące do wyświetlania, ukrywania, filtrowania i sortowania danych

CTRL+8
Wyświetla lub ukrywa wskaźniki rozwijania (pola Pole plus i Pole minus) obok elementów.
CTRL+ZNAK PLUS
Rozwija aktualnie zaznaczony element.
CTRL+ZNAK MINUS
Ukrywa aktualnie zaznaczony element.
ALT+STRZAŁKA W DÓŁ
Otwiera listę aktualnie zaznaczonego pola.
Klawisz TAB
Przechodzi kolejno do ostatnio wybranego elementu, przycisku OK i przycisku Anuluj na liście rozwijanej danego pola.
Klawisze strzałek
Przechodzą do następnego elementu na liście rozwijanej danego pola.
SPACJA
Zaznacza lub czyści pola wyboru dla bieżącego elementu na liście rozwijanej pola.
CTRL+>
Wyświetla szczegóły dla bieżącego elementu lub zaznaczenia, jeśli są one dostępne.
CTRL+<
Ukrywa szczegóły dla bieżącego elementu lub zaznaczenia.
ENTER
Zamyka listę rozwijaną pola i powoduje zastosowanie wszystkich dokonanych zmian.
ESC
Zamyka listę rozwijaną pola bez zastosowania zmian.
CTRL+T
Włącza lub wyłącza Autofiltr.
CTRL+SHIFT+A
Sortuje dane w zaznaczonym polu lub sumie w kolejności rosnącej (A – Z 0 – 9).
CTRL+SHIFT+Z
Sortuje dane w zaznaczonym polu lub sumie w kolejności malejącej (Z – A 9 – 0).
ALT+SHIFT+STRZAŁKA W GÓRĘ lub ALT+SHIFT+STRZAŁKA W LEWO
Przenosi zaznaczony człon do góry lub w lewo.
ALT+SHIFT+STRZAŁKA W DÓŁ lub ALT+SHIFT+STRZAŁKA W PRAWO
Przenosi zaznaczony człon w dół lub w prawo.

Dodawanie pól i sum oraz zmiana układ listy tabeli przestawnej

Klawisze służące do pracy z listą pól

CTRL+L
Wyświetla listę pól lub uaktywnia ją, jeżeli jest już wyświetlona.
Klawisze strzałek
Przechodzą do następnego elementu na liście pól.
SHIFT+STRZAŁKA W GÓRĘ
Przechodzi do poprzedniego elementu i dołącza go do zaznaczenia.
SHIFT+STRZAŁKA W DÓŁ
Przechodzi do następnego elementu i dołącza go do zaznaczenia.
CTRL+STRZAŁKA W GÓRĘ
Przechodzi do poprzedniego elementu bez dołączania go do zaznaczenia.
CTRL+STRZAŁKA W DÓŁ
Przechodzi do następnego elementu bez dołączania go do zaznaczenia.
CTRL+SPACJA
Usuwa element z zaznaczenia, jeśli element, który ma fokus, jest dołączony do zaznaczenia i vice versa
ZNAK PLUS (klawiatura numeryczna)
Rozwija bieżący element na liście pól w celu wyświetlenia jego zawartości albo rozwija sumy, aby wyświetlić dostępne pola sum.
ZNAK MINUS (klawiatura numeryczna)
Zwija bieżący element na liście pól w celu ukrycia jego zawartości albo zwija sumy, aby ukryć dostępne pola sum.
Klawisz TAB
Przechodzi kolejno do ostatnio zaznaczonego elementu, przycisku Dodaj do i listy obok przycisku Dodaj do na liście pól.
ALT+STRZAŁKA W DÓŁ
Otwiera listę rozwijaną obok przycisku Dodaj do na liście pól. Należy użyć klawiszy strzałek, aby przejść do następnego elementu listy i nacisnąć klawisz ENTER, aby zaznaczyć ten element.
ENTER
Dodaje pole wyróżnione na liście pól do obszaru listy tabeli przestawnej wyświetlonego na liście Dodaj do.
ALT+F4
Zamyka listę pól.

Klawisze służące do dodawania pól i sum

CTRL+SHIFT+S
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Suma.
CTRL+SHIFT+C
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Ile.Liczb.
CTRL+SHIFT+M
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Min.
CTRL+SHIFT+X
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Max.
CTRL+SHIFT+E
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Średnia.
CTRL+SHIFT+D
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Odchylenie standardowe.
CTRL+SHIFT+T
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Odchylenie standardowe populacji.
CTRL+SHIFT+V
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Wariancja.
CTRL+SHIFT+R
Dodaje nowe pole sumy dla pola zaznaczonego na liście tabeli przestawnej, korzystając z funkcji podsumowania Wariancja populacji.
CTRL+SHIFT+B
Włącza lub wyłącza sumy częściowe i sumy końcowe dla pola zaznaczonego na liście tabeli przestawnej.
CTRL+F
Dodaje pole obliczeniowe szczegółów.

Klawisze służące do zmiany układu

CTRL+1
Przenosi pole zaznaczone na liście tabeli przestawnej do obszaru wiersza.
CTRL+2
Przenosi pole zaznaczone na liście tabeli przestawnej do obszaru kolumny.
CTRL+3
Przenosi pole zaznaczone na liście tabeli przestawnej do obszaru filtru.
CTRL+4
Przenosi pole zaznaczone na liście tabeli przestawnej do obszaru szczegółów.
CTRL+STRZAŁKA W LEWO
Przenosi pole wiersza lub kolumny zaznaczone na liście tabeli przestawnej na wyższy poziom.
CTRL+STRZAŁKA W PRAWO
Przenosi pole wiersza lub kolumny zaznaczone na liście tabeli przestawnej na niższy poziom.

Klawisze służące do formatowania listy tabeli przestawnej

Aby użyć następujących skrótów, należy najpierw zaznaczyć pole szczegółów lub komórkę danych dla pola sumy.

Pierwsze siedem skrótów klawiaturowych umożliwia zmianę formatu liczby zastosowanego do zaznaczonego elementu.

CTRL+SHIFT+~ (tylda)
Stosuje ogólny format liczby do wartości w zaznaczonym polu sumy lub szczegółów.
CTRL+SHIFT+$
Stosuje format waluty, z dwoma miejscami dziesiętnymi i liczbami ujemnymi w nawiasach, do wartości w wybranym polu sumy lub szczegółów.
CTRL+SHIFT+%
Stosuje format procentowy bez miejsc dziesiętnych do wartości w zaznaczonym polu sumy lub szczegółów.
CTRL+SHIFT+^
Stosuje format wykładniczy z dwoma miejscami dziesiętnymi do wartości w zaznaczonym polu sumy lub szczegółów.
CTRL+SHIFT+#
Stosuje format daty z dniem, miesiącem i rokiem do wartości w zaznaczonym polu sumy lub szczegółów.
CTRL+SHIFT+@
Stosuje format czasu z godziną, minutą i symbolami AM lub PM do wartości w zaznaczonym polu sumy lub szczegółów.
CTRL+SHIFT+!
Stosuje format numeryczny z dwoma miejscami dziesiętnymi, separatorem tysięcy i znakiem minus dla wartości ujemnych do wartości w wybranym polu sumy lub szczegółów.
CTRL+B
Pogrubia tekst w zaznaczonym elemencie listy tabeli przestawnej.
CTRL+U
Podkreśla tekst w zaznaczonym elemencie listy tabeli przestawnej.
CTRL+I
Zmienia format tekstu na kursywę w zaznaczonym elemencie listy tabeli przestawnej.

Klawisze służące do obsługi hiperłączy

Aby używać poniższych skrótów, należy najpierw zaznaczyć komórkę lub element hiperłącza.

ENTER
Podąża za wskazaniem hiperłącza.
SHIFT+ENTER
Otwiera łącze w nowym oknie.

Klawisze służące do dodawania, edycji lub usuwania danych

F2
Wprowadza tryb edycji.
Klawisz TAB
Akceptuje zmiany wprowadzone podczas edycji, przenosi fokus w prawo, a następnie w dół.
ENTER
Akceptuje zmiany wprowadzone podczas edycji, przenosi fokus w dół, a następnie w prawo.
SHIFT+TAB
Akceptuje zmiany wprowadzone podczas edycji, przenosi fokus w lewo, a następnie w górę.
SHIFT+ENTER
Akceptuje zmiany wprowadzone podczas edycji, przenosi fokus w górę, a następnie w lewo.
ESC
Odrzuca zmiany wprowadzone podczas edycji.
DELETE
Usuwa zaznaczenie.

Klawisze służące do pracy z Pomocą

Klawisze służące do pracy w oknie Pomocy

F6
Przełącza między okienkiem nawigacji i okienkiem tematu.
ALT+O
Wyświetla menu Opcje w celu uzyskania dostępu do dowolnego polecenia na pasku narzędzi Pomoc.
ALT+SPACJA
Wyświetla menu Sterowanie.
ALT+F4
Zamyka okno Pomocy.

Klawisze służące do pracy w okienku nawigacji

CTRL+TAB
Przechodzi do innej karty.
ENTER
Otwiera lub zamyka zaznaczoną książkę albo otwiera zaznaczony temat Pomocy.
STRZAŁKA W DÓŁ
Zaznacza następną książkę lub temat Pomocy.
STRZAŁKA W GÓRĘ
Zaznacza poprzednią książkę lub temat Pomocy.
SHIFT+F10
Wyświetla menu skrótów.

Klawisze służące do pracy w okienku tematu

ALT+STRZAŁKA W PRAWO
Przechodzi do przodu do wcześniej przeglądanego tematu Pomocy.
ALT+STRZAŁKA W LEWO
Przechodzi wstecz do wcześniej przeglądanego tematu Pomocy.
Klawisz TAB
Zaznacza następny tekst ukryty, hiperłącze albo łącze Pokaż wszystko lub Ukryj wszystko na początku tematu.
SHIFT+TAB
Zaznacza poprzedni tekst ukryty lub hiperłącze.
ENTER
Wykonuje akcję zaznaczonego łącza Pokaż wszystko, Ukryj wszystko, tekstu ukrytego lub hiperłącza.
STRZAŁKA W GÓRĘ albo STRZAŁKA W DÓŁ
Przewija w kierunku początku albo końca tematu Pomocy.
PAGE UP albo PAGE DOWN
Przewija w kierunku początku albo końca tematu Pomocy w większych przyrostach.
HOME albo END
Przechodzi do początku albo końca tematu Pomocy.
CTRL+P
Drukuje bieżący temat Pomocy.
CTRL+A
Zaznacza cały temat Pomocy.
CTRL+C
Kopiuje zaznaczenie do Schowka.
SHIFT+F10
Wyświetla menu skrótów.


Pasek narzędzi, lista pól i okno dialogowe Polecenia i opcje — informacje

Pasek narzędzi listy tabeli przestawnej

Pasek narzędzi listy tabeli przestawnej znajduje się na górze listy i dostarcza zestaw poleceń, który można używać na etapie projektowania listy do pracy z zawartymi w niej danymi.

Pasek narzędzi listy tabeli przestawnej

W przeglądarce użytkownicy również mogą korzystać z paska narzędzi podczas pracy z listą tabeli przestawnej. Należy umieścić kursor na chwilę na dowolnym przycisku paska narzędzi, aby wyświetlić nazwę skojarzonego z nim polecenia.

Jeżeli użytkownicy nie powinni mieć dostępu do paska narzędzi w przeglądarce, to można go ukryć. Aby mieć pewność, że użytkownicy nie będą mogli wyświetlić go ponownie, należy ograniczyć dostęp do okna dialogowego Polecenia i opcje, ukryć menu skrótów za pomocą odpowiedniego skryptu oraz ukryć pasek tytułu.

Lista pól listy tabeli przestawnej

Za pomocą listy pól można wyświetlić pola i zestawy pól dostępne w danych źródłowych oraz dodawać pola do obszarów wierszy, kolumn, filtrów, danych i szczegółów na liście tabeli przestawnej. Można przewijać zawartość listy i klikać wskaźniki przewijania (pola Pole plus i Pole minus) obok poszczególnych zestawów pól, aby pokazać lub ukryć pola. Pola, które nie są pogrubione na liście pól, są dostępne, ale nie zostały jeszcze wyświetlone na liście tabeli przestawnej. Pola pogrubione są już wyświetlone.

Lista pól w widoku lub na liście tabeli przestawnej

Okno dialogowe Polecenia i opcje

Za pomocą tego okna dialogowego można wykonywać różne zadania, takie jak filtrowanie danych, formatowanie tekstu i pokazywanie lub ukrywanie elementów. Karty wyświetlane w tym oknie dialogowym zmieniają się w zależności od aktualnie wybranej części listy tabeli przestawnej. Wskazanie na stronie sieci Web formantu innego niż lista tabeli przestawnej lub inny składnik Microsoft Office Web Component spowoduje, że okno zostanie ukryte aż do ponownego uaktywnienia odpowiedniego komponentu.

Okno dialogowe Polecenia i opcje zawiera pewne polecenia, które nie są dostępne na pasku narzędzi i w menu skrótów. Niektóre właściwości i polecenia są dostępne w oknie dialogowym Polecenia i opcje zarówno podczas projektowania listy tabeli przestawnej, jak i podczas jej wyświetlania w przeglądarce. Inne są dostępne tylko podczas pracy w programie do projektowania. Jeśli osoba projektująca listę nie chce, aby użytkownicy mieli dostęp do poleceń i ustawień właściwości w oknie dialogowym Polecenia i opcje, to może ograniczyć do niego dostęp w przeglądarce.


Pokazywanie i ukrywanie paska narzędzi

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Prawym przyciskiem myszy kliknij listę tabeli przestawnej, a następnie kliknij polecenie Polecenia i opcje.
  3. Kliknij kartę Zachowanie.
  4. Zaznacz lub wyczyść pole wyboru Pasek narzędzi.

Uwaga Wyświetlenie paska narzędzi w programie do projektowania powoduje jego udostępnienie w przeglądarce. Aby mieć pewność, że użytkownicy nie wyświetlą ponownie paska narzędzi, należy ograniczyć dostęp do okna dialogowego Polecenia i opcje, ponieważ zawiera ono polecenie umożliwiające ponowne wyświetlenie paska narzędzi. Należy także ukryć pasek tytułu, aby ograniczyć dostęp do menu skrótów zawierającego polecenie wyświetlające pasek narzędzi. Ukrycie paska tytułu nie uniemożliwia dostępu do niektórych znajdujących się na nim poleceń. Polecenia te będą dostępne za pomocą menu skrótów związanych z polami, elementami danych i innymi zaznaczonymi elementami, chyba że zostaną ukryte przy użyciu skryptu.


Pokazywanie lub ukrywanie listy pól

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Kliknij przycisk Wyświetl listę pól [image] na pasku narzędzi.


Pokazywanie lub ukrywanie okna dialogowego Polecenia i opcje.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Jeśli pasek narzędzi jest wyświetlony, kliknij znajdujący się na nim przycisk Polecenia i opcje [image].
    • Jeśli pasek narzędzi jest ukryty, prawym przyciskiem myszy kliknij listę tabeli przestawnej, a następnie kliknij polecenie Polecenia i opcje.

Uwaga Jeśli okno dialogowe Polecenia i opcje jest wyświetlone w momencie zaznaczania różnych części listy tabeli przestawnej lub innego składnika Microsoft Office Web Components, to poszczególne sekcje i ich zawartość zmieniają się, aby odzwierciedlić aktualny wybór. Po zaznaczeniu części strony sieci Web innej niż składnik Office Web Component okno dialogowe zostanie ukryte.


Pokazywanie lub ukrywanie paska tytułu

Uwaga Nie można pokazać paska tytułu, jeśli lista tabeli przestawnej nie jest powiązana z żadnym źródłem danych.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.
  3. Zaznacz lub wyczyść pole wyboru Pasek tytułu.


Pokazywanie lub ukrywanie obszarów upuszczania

Jeżeli obszary upuszczania są ukryte, a lista tabeli przestawnej nie ma jeszcze żadnych pól w obszarze wiersza, kolumny, danych lub filtru, to nie można przeciągać pól do tych obszarów.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.

  3. Zaznacz lub wyczyść pole wyboru Obszary upuszczania.

Uwaga Nie można zobaczyć obszarów upuszczania, jeśli lista tabeli przestawnej nie jest powiązana z żadnym źródłem danych.


Aplikacje, których można używać do projektowania lub modyfikowania list tabel przestawnych

Lista tabeli przestawnej jest składnikiem tworzonym i projektowanym w jednym programie, programie do projektowania, w celu użycia w innym programie, programie czasu uruchomienia. Listy tabel przestawnych są przeznaczone głównie do użytku w przeglądarce sieci Web Microsoft Internet Explorer w wersji 4.01 lub nowszej.

W zależności od zawartości strony sieci Web oraz od zadań, jakie użytkownicy będą wykonywać na liście tabeli przestawnej, niektóre programy mogą okazać się lepiej dostosowane do konkretnych zadań projektowania niż inne. Można rozpocząć od utworzenia strony sieci Web i dodać do niej składniki, na przykład listy tabel przestawnych, używając jednego programu do projektowania, a następnie otworzyć tę stronę sieci Web w innym programie i kontynuować pracę.

Na przykład raport tabeli przestawnej, zaprojektowany w programie Microsoft Excel, można zapisać lub opublikować na liście tabeli przestawnej na stronie sieci Web za pomocą programu Excel. Aby dostosować tak powstałą listę tabeli przestawnej w celu zmiany ustawień domyślnych lub aby dodać inne formanty do strony sieci Web, można ją następnie otworzyć i zmodyfikować w programie Microsoft FrontPage.

Zapoznaj się z Pomocą w programie do projektowania, którego masz zamiar używać, aby dowiedzieć się, czy dany program obsługuje projektowanie list tabel przestawnych i aby poznać procedury umożliwiające tworzenie i modyfikowanie takich list.

Do tworzenia list tabel przestawnych można używać następujących programów do projektowania:

Program Microsoft Excel

Program Excel stanowi doskonałe środowisko do projektowania układu strony i dostosowywania danych źródłowych, które mają być dostępne na liście tabeli przestawnej. W programie Excel można uzyskać dostęp do danych zewnętrznych i utworzyć raport tabeli przestawnej programu Excel. Program Microsoft Excel daje możliwość zapisania lub opublikowania na stronie sieci Web raportu tabeli przestawnej w formie listy tabeli przestawnej. (Raport tabeli przestawnej to wersja listy tabeli przestawnej w programie Excel.) Dane źródłowe, określone w programie Excel, są automatycznie dołączane do listy tabeli przestawnej w czasie publikowania, podobnie jak większość funkcji raportu tabeli przestawnej.

Do formatowania listy tabeli przestawnej oraz do modyfikowania jej rozmiaru i wyglądu można użyć innego programu do projektowania. Jeśli którykolwiek z użytkowników projektowanej strony sieci Web ma program Internet Explorer w wersji 4.x, do modyfikowania list tabel przestawnych publikowanych za pomocą programu Excel należy użyć programu FrontPage. Listy tabel przestawnych opublikowane za pomocą programu Microsoft Excel w formie stron sieci Web są obsługiwane przez program Internet Explorer 4.x i jego nowsze wersje, a program FrontPage zapewnia tę obsługę. Strona sieci Web, opublikowana za pomocą programu Excel, a zmodyfikowana w programie Microsoft Access przy użyciu widoku projektu strony dostępu do danych może natomiast wymagać zainstalowania przez użytkowników programu Internet Explorer 5, a nie tylko programu Internet Explorer 4.x.

Program Microsoft FrontPage

Program FrontPage jest programem do projektowania zalecanym do tworzenia list tabel przestawnych przeznaczonych dla użytkowników przeglądarek Internet Explorer w wersji 4.x oraz do modyfikowania list tabel przestawnych zapisanych lub opublikowanych za pomocą programu Excel. W programie FrontPage można utworzyć listy tabel przestawnych na stronach sieci Web, zmodyfikować listy tabel przestawnych zaprojektowane w innych programach, a następnie użyć funkcji programu FrontPage do skonstruowania witryny sieci Web i zarządzania nią.

Program Microsoft Access

Program Access zawiera specjalne funkcje do tworzenia stron sieci Web, wyświetlających i operujących na danych z baz danych programów Microsoft Access i Microsoft SQL Server. Można na przykład użyć listy pól do zlokalizowania danych i przeciągnąć je na listę tabeli przestawnej. Można tworzyć łącza pomiędzy listami tabel przestawnych i innymi formantami, które przetwarzają i wyświetlają na stronie sieci Web dane z baz danych. Jeśli na stronie sieci Web znajdują się dane inne, niż wyświetlone na liście tabeli przestawnej lub za pomocą innego składnika Microsoft Office Web Component, wówczas użytkownicy tej strony sieci Web muszą mieć zainstalowaną przeglądarkę Internet Explorer w wersji 5 lub nowszej, aby móc wyświetlić stronę.

Program Microsoft Visual Basic

Kiedy potrzebne jest środowisko programowania bardziej zaawansowane niż środowiska skryptów w programach Excel, FrontPage i Access, można zaprojektować listy tabel przestawnych w programie Microsoft Visual Basic. Program umożliwia dostosowywanie listy tabeli przestawnej przez użytkowników. Użytkownicy mogą przeglądać listy i pracować z nimi interaktywnie, używając formularzy Visual Basic w zaprojektowanych przez autora programach. Formularz podczas wykonywania staje się środowiskiem (zamiast przeglądarki), a program może zautomatyzować wiele funkcji listy tabeli przestawnej.

Uwaga Microsoft Word nie jest odpowiednim programem do projektowania list tabel przestawnych.


Dane źródłowe listy tabeli przestawnej — informacje

Lista tabeli przestawnej to metoda przenoszenia danych z zewnętrznych źródeł na stronę sieci Web w celu ich wyświetlania i analizowania. Projektując listę tabeli przestawnej, należy wybrać odpowiednie dane źródłowe i udostępnić je w przeglądarce, a także ustanowić połączenie z danymi źródłowymi. Dzięki temu użytkownik może w przeglądarce odświeżać listę tabeli przestawnej i przeglądać zaktualizowane dane źródłowe.

Typy danych źródłowych

Listy tabel przestawnych mogą wyświetlać dane pochodzące z różnych źródeł. Najczęściej źródłami danych są relacyjne bazy danych, arkusze programu Microsoft Excel oraz bazy danych OLAP (On-Line Analytical Processing).

Relacyjne bazy danych

Lista tabeli przestawnej może wyświetlać i podsumowywać dane z zestawu rekordów umieszczonego w relacyjnej bazie danych, takiej jak Microsoft Access czy Microsoft SQL Server. Jeśli dane źródłowe pochodzą z relacyjnej bazy danych, to można na liście tabeli przestawnej tworzyć nowe pola sum, wyświetlać dane szczegółowe poszczególnych elementów w polach i przenosić pola do obszaru szczegółów.

Arkusze programu Microsoft Excel

Po utworzeniu raportu tabeli przestawnej w programie Microsoft Excel na podstawie danych znajdujących się w arkuszu programu Excel, a następnie zapisaniu tego raportu jako listy tabeli przestawnej na stronie sieci Web, dane z arkusza programu Excel staną się oddzielnym plikiem HTML zawartym w podfolderze danej strony sieci Web. Jeśli dane źródłowe pochodzą z arkusza programu Excel, to można na liście tabeli przestawnej tworzyć nowe pola sum, wyświetlać dane szczegółowe poszczególnych elementów w polach i przenosić pola do obszaru szczegółów.

Aby uzyskać informacje o publikowaniu raportów tabel przestawnych programu Excel na stronach sieci Web, zobacz Pomoc programu Excel.

Bazy danych OLAP

OLAP to metoda przetwarzania danych przez serwer, która pozwala organizować duże ilości danych w sposób przystępny i zrozumiały dla osób chcących analizować wyniki i trendy biznesowe. Dane OLAP są przechowywane w strukturach zwanych modułami i zorganizowane według poziomu szczegółowości wewnątrz modułu. Zestaw poziomów, na przykład informacji o kraju, regionie, mieście i miejscu, jest nazywany wymiarem i może być używany jako zestaw pól na liście tabeli przestawnej. Moduł OLAP może być bazą danych serwera, plikiem modułu wyodrębnionym z bazy danych serwera lub modułem skonstruowanym w pamięci z rekordów relacyjnej bazy danych — w zależności od używanego oprogramowania serwera i klienta OLAP.

W przypadku list tabel przestawnych opartych na danych źródłowych z baz danych OLAP, pola wymiarów (zwane również zestawami pól) mogą wyświetlać różne poziomy szczegółów. Jeżeli używane są dane źródłowe pochodzące z baz danych OLAP, nie można tworzyć własnych pól sum, przenosić pól do obszaru szczegółów, a także wyświetlać danych szczegółowych. Bazy danych OLAP dostarczają jednak własnych narzędzi do tworzenia podsumowań danych i wykonywania obliczeń. Ponieważ bazy OLAP dokonują wstępnych obliczeń podsumowujących zamiast zwracać duże ilości danych szczegółowych do listy tabeli przestawnej, umożliwiają one analizę dużo większej ilości danych, niż byłoby to możliwe przy korzystaniu z listy tabeli przestawnej.

Aby uzyskać informacje na temat tworzenia w module lub bazie danych OLAP pól podsumowań, które następnie można wyświetlać na liście tabeli przestawnej, należy skontaktować się z administratorem bazy danych OLAP lub przejrzeć pomoc narzędzi OLAP pakietu Microsoft Office (na przykład Kreatora modułów OLAP lub Kreatora modułów offline, które wchodzą w skład programu Microsoft Excel).

Połączenie z danymi źródłowymi

Jeżeli do projektowania stosowany jest widok Projekt strony dostępu do danych w programie Microsoft Access, to można korzystać z metod i poleceń programu Access w celu przygotowania danych i ustanowienia połączeń. Aby uzyskać informacje i procedury, zobacz Pomoc programu Access.

Konfigurowanie źródła danych

Aby w programie do projektowania korzystać z zewnętrznego źródła danych, należy skonfigurować źródło danych w systemie. Źródło danych to zestaw nazwanych, przechowywanych informacji, który łączy program do projektowania z zewnętrzną bazą danych oraz pobiera dane. Aby skonfigurować źródło danych, potrzebny jest sterownik odpowiedni dla danego typu danych źródłowych. Pakiet Microsoft Office zawiera zestaw sterowników dla najbardziej rozpowszechnionych typów baz danych. Program do projektowania może zawierać dodatkowe sterowniki, a wielu producentów baz danych dostarcza sterowniki zgodne z pakietem Microsoft Office.

Jeśli program do projektowania ma działać z bazami danych OLAP i relacyjnymi bazami danych, to należy skonfigurować źródła danych dla obu typów. Program do projektowania może zawierać narzędzia do konfigurowania źródeł danych, można także wprowadzić odpowiednie ustawienia za pomocą narzędzi systemu Microsoft Windows lub pakietu Office. Aby uzyskać więcej informacji na temat konfigurowania źródeł danych, zobacz program do projektowania i pomoc dotyczącą sterownika źródła danych.

Tworzenie kwerendy do pobierania danych

W przypadku danych źródłowych pochodzących z relacyjnej bazy danych, po skonfigurowaniu źródła danych należy utworzyć kwerendę albo napisać odpowiednią instrukcję lub procedurę SQL, aby zdefiniować i pobrać żądany zestaw rekordów. Aby uzyskać informacje na temat tych czynności, zobacz Pomoc programu do projektowania oraz zapoznaj się z dokumentacją bazy danych. Na przykład program Microsoft Access jest wyposażony w narzędzia pozwalające zarówno tworzyć kwerendy, jak i udostępniać zestawy rekordów na liście pól programu Access bez tworzenia kwerendy. Korzystając z takiej listy pól, można wybrać dane, które mają być użyte na liście tabeli przestawnej. W programie Microsoft Query (składnik pakietu Microsoft Office) również można tworzyć kwerendy dla danych z różnych obsługiwanych przez ten program baz danych.

Aby korzystać z danych OLAP, potrzebna jest baza danych serwera OLAP, plik modułu lub definicja modułu. Chcąc uzyskać dostęp do danych z modułu, nie trzeba ustawiać kwerendy; należy tylko skonfigurować sterownik i źródło danych. Aby uzyskać więcej informacji, zapoznaj się z dokumentacją otrzymaną od dostawcy OLAP lub zobacz Pomoc programu Microsoft Excel, Microsoft Query bądź Microsoft Access dotyczącą pracy z bazami danych OLAP.

Dodawanie danych do listy tabeli przestawnej

Podczas dodawania danych do pustej listy tabeli przestawnej należy ustawić połączenie pomiędzy listą tabeli przestawnej i źródłem danych. Dodając dane do listy tabeli przestawnej, umieszcza się w niej informacje konieczne do ponownego ustanowienia tego połączenia i pobrania danych w sytuacji, gdy użytkownik otworzy listę tabeli przestawnej w przeglądarce.

Program do projektowania może zawierać narzędzia pomocne w ustawianiu połączenia. Jeśli program do projektowania nie zawiera narzędzi służących do tworzenia połączeń ani odpowiedniej pomocy, to można skonstruować ciąg połączenia dla źródła danych za pomocą okna dialogowego Polecenia i opcje. Aby uzyskać informacje na temat składni ciągu połączenia, zobacz Pomoc stosowanego sterownika źródła danych oraz Pomoc dotyczącą list tabel przestawnych w używanym programie.

Jakie znaczenie dla użytkowników strony sieci Web mają sterowniki i źródła danych

Użytkownicy, którzy chcą interakcyjnie korzystać z listy tabeli przestawnej w przeglądarce, muszą przed przystąpieniem do jej przeglądania zainstalować sterownik ODBC lub sterownik źródła danych odpowiedni dla źródłowej bazy danych. Dotyczy to wszystkich typów danych źródłowych z wyjątkiem danych zawartych w arkuszu programu Excel. Jeśli jako źródło używana jest baza danych, której sterownik nie jest instalowany jako część pakietu Office, to należy się upewnić, że do tego sterownika będą mieli dostęp użytkownicy listy tabeli przestawnej.

W przeglądarce użytkownicy nie muszą jednak konfigurować źródła danych dla zewnętrznej bazy danych. Podczas dodawania danych do listy tabeli przestawnej w programie do projektowania, informacje na temat połączenia z bazą danych, których potrzebują przeglądarki, są włączane w skład listy tabeli przestawnej i zapisywane jako część strony sieci Web. Konieczność wprowadzania identyfikatora i hasła podczas łączenia się z zewnętrzną bazą danych zależy od ustawień źródła danych skonfigurowanych podczas projektowania listy tabeli przestawnej.

Odświeżanie listy tabeli przestawnej w przypadku zmiany danych źródłowych

Po ustanowieniu połączenia z bazą danych można odświeżyć listę tabeli przestawnej, jeśli istnieje potrzeba odzwierciedlenia zmian i aktualizacji danych źródłowych.

Odświeżanie, gdy dane źródłowe pochodzą z relacyjnej bazy danych

W przypadku danych źródłowych pochodzących z relacyjnych baz danych odświeżenie wymaga źródłowej bazy danych — oznacza to pobranie zarówno zmienionych, jak i wszelkich nowych danych, które spełniają ustanowione kryteria. Jeżeli kwerenda, instrukcja SELECT lub przechowywana procedura ma wybierać z bazy danych inny zestaw danych lub pól, to należy zapoznać się z informacjami dotyczącymi dokonywania zmian zawartymi w dokumentacji bazy danych lub programu używanego do tworzenia kwerendy.

Odświeżanie, gdy dane źródłowe pochodzą z arkusza programu Microsoft Excel

Jeżeli planowana jest publikacja raportu tabeli przestawnej za pomocą programu Microsoft Excel, to należy najpierw zapisać kopię skoroszytu w programie Excel, a następnie opublikować raport tabeli przestawnej jako listę tabeli przestawnej na stronie sieci Web. Chcąc odświeżyć listę tabeli przestawnej opublikowaną za pomocą programu Excel i zaktualizować ją o nowe lub zmienione dane z pierwotnego zeszytu lub chcąc wybrać inny zestaw danych programu Excel na listę tabeli przestawnej, użytkownik może zmienić pierwotny raport tabeli przestawnej programu Excel, a następnie ponownie opublikować go jako listę tabeli przestawnej. Aby uzyskać instrukcje, zobacz Pomoc programu Microsoft Excel.

Odświeżanie, gdy dane źródłowe pochodzą z bazy danych OLAP

W przypadku danych źródłowych OLAP nowe dane są pobierane z serwera lub pliku modułu za każdym razem, gdy na liście tabeli przestawnej zostanie dokonana zmiana, która ma wpływ na to, jakie dane są wyświetlone. Na przykład dodanie nowego pola w obszarze wierszy spowoduje pobranie sumarycznych wartości dla nowych elementów zbioru danych, które są aktualnie wyświetlone. Jeżeli użytkownik pracuje z plikiem modułu OLAP, to może zapoznać się z dokumentacją programu, którego użyto do utworzenia pliku, aby znaleźć informacje na temat aktualizowania pliku w sytuacji, gdy zmieniają się informacje zapisane w pierwotnej bazie danych serwera.

Odświeżanie danych w przeglądarce

W przeglądarce dane są pobierane, kiedy użytkownik po raz pierwszy wyświetli listę tabeli przestawnej. Gdy użytkownik przejdzie na inną stronę sieci Web, a następnie wróci na stronę z listą tabeli przestawnej, zmiany, których dokonał na liście, będą zachowane, ale strona nie zostanie ponownie załadowana z serwera sieci Web i dane na liście tabeli przestawnej pozostaną nieodświeżone. Użytkownik może odświeżyć listę tabeli przestawnej, aby zobaczyć aktualne dane, może również anulować odświeżanie w toku.


Dodawanie danych do listy tabeli przestawnej

Program do projektowania może zapewniać prostszy sposób dodawania danych do listy tabeli przestawnej. Poniższą procedurę należy zastosować, gdy program do projektowania nie zawiera procedury służącej do dodawania danych.

Przed dodaniem danych do listy tabeli przestawnej należy zainstalować sterownik ODBC lub sterownik źródła danych (oprogramowanie obsługi OLE DB lub OLAP) i skonfigurować źródło danych, aby połączyć je z bazą danych. Aby uzyskać więcej informacji, zobacz Pomoc programu do projektowania.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij listę tabeli przestawnej lub, jeśli dane zostały już do niej dodane, kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Źródło danych.
  4. W obszarze Pobieranie danych przy użyciu wykonaj jedną z następujących czynności:

    Użyj formantu źródła danych

    • Jeśli na danej stronie sieci Web dostępny jest formant źródła danych lub obiekt źródła danych korzystający z instrukcji IDataSource, to na liście Formant danych źródłowych ustaw odpowiednią wartość.

    Określ informacje dotyczące połączenia

    1. Jeśli na danej stronie sieci Web nie ma formantu lub obiektu źródła danych albo jeśli trzeba połączyć listę z innymi danymi źródłowymi, wprowadź ciąg połączenia w polu Połączenie lub kliknij przycisk Edytuj, aby przejrzeć bądź wprowadzić informacje o źródle danych.

      W zależności od używanego programu do projektowania, kliknięcie przycisku Edytuj wyświetla okno dialogowe Wybierz źródło danych lub Właściwości łącza danych.

    2. Jeśli pojawi się okno dialogowe Wybierz źródło danych, wykonaj jedną z następujących czynności:
      1. W polu Szukaj w zlokalizuj żądane źródło danych, a następnie kliknij je dwukrotnie na liście.
      2. Jeśli odpowiednie źródło danych jest niedostępne, kliknij przycisk Nowe źródło, a następnie wykonaj instrukcje Kreatora łączenia danych, aby utworzyć nowy plik połączenia.
    3. Jeśli pojawi się okno dialogowe Właściwości łącza danych, to wprowadź informacje o połączeniu ze źródłem danych na karcie Połączenie. Aby uzyskać pomoc dotyczącą poszczególnych opcji, kliknij przycisk Pomoc w dolnej części okna dialogowego.
  5. W obszarze Używanie danych z wykonaj jedną z następujących czynności:
    • Aby użyć danych z określonego elementu wewnątrz bazy danych, takiego jak istniejąca tabela lub kwerenda, kliknij opcję Element danych, tabela, widok lub nazwa modułu, a następnie wybierz żądany element z listy.
    • Aby użyć kwerendy lub polecenia — takiego jak instrukcja SQL — do wybrania danych, kliknij polecenie Tekst polecenia lub SQL, a następnie wpisz kwerendę lub polecenie w polu. Aby uzyskać informacje na temat kwerend lub składni poleceń, zapoznaj się z dokumentacją bazy danych.
  6. Kliknij przycisk Wyświetl listę pól [image] na pasku narzędzi, a następnie przeciągnij pola do odpowiednich obszarów na liście tabeli przestawnej.

Uwaga Użytkownicy nie mogą zmieniać w przeglądarce ustawień połączenia dla listy tabeli przestawnej.


Elementy listy tabeli przestawnej

Lista tabeli przestawnej z wyświetlonymi elementami

1 Pole filtru

2 Pola wierszy

3 Pola kolumn

4 Strzałka rozwijania pola

5 Pole danych

6 Wskaźniki rozwijania

Pola

Każde pole odpowiada kolumnie danych i może zawierać podsumowanie informacji z wielu wierszy. Typy pól to: pola wierszy, pola kolumn, pola danych, pola szczegółów i pola filtrów.

Element

Unikatowy składnik danych w polu. Elementy danych w polach wierszy i kolumn są wyświetlane kolejno w kolumnach lub w wierszach. W komórce znajdującej się na przecięciu wiersza i kolumny wyświetlane są podsumowane dane dla elementów znajdujących się u góry kolumny i po lewej stronie wiersza. Jeżeli można wyświetlić niższy poziom elementów, to obok danego elementu widoczny jest wskaźnik rozwijania Pole plus. Obok elementów znajdujących się na najniższym poziomie nie ma wskaźników rozwijania. Wskaźniki rozwijania (pola Pole plus i Pole minus) umieszczone po prawej stronie elementu wskazują, że w jego przypadku dostępne są dane szczegółowe.

Pole wiersza

Pole w obszarze wiersza. Na powyższej liście tabeli przestawnej pola Produkt i Sprzedany przez są polami wierszy. Elementy w polach wierszy są wyświetlane wzdłuż lewego brzegu listy tabeli przestawnej. Wewnętrzne pola wierszy, takie jak Sprzedany przez, znajdują się najbliżej obszaru danych; zewnętrzne pola wierszy, takie jak Produkt, znajdują się na lewo od wewnętrznych pól wierszy.

Pole kolumny

Pole w obszarze kolumny. Elementy w polach kolumn są wyświetlane wzdłuż górnego brzegu listy tabeli przestawnej, ponad polami danych. Na powyższej liście tabeli przestawnej pole Rok jest polem kolumny z dwoma elementami: 1996 i 1997. Wewnętrzne pola kolumn są położone najbliżej obszaru danych, a zewnętrzne pola kolumn znajdują się powyżej wewnętrznych pól kolumn.

Pole filtru

Pole w obszarze filtru, którego można użyć do filtrowania całej listy tabeli przestawnej w celu wyświetlenia podsumowanych danych dla określonych elementów. Na powyższej liście tabeli przestawnej pole Region jest polem filtru, którego można użyć w celu wyświetlenia danych odnoszących się do wszystkich lub tylko do wybranych regionów. Pola filtrów spełniają takie same funkcje, jak pola stron w raportach tabel przestawnych programu Microsoft Excel.

Pole danych

Pole zawierające wartości podsumowań z danych źródłowych. Na powyższej liście tabeli przestawnej pole Sprzedaż jest polem danych, które zawiera podsumowane kwoty sprzedaży — każda wartość w polu danych jest sumą wpisów z pola Sprzedaż lub kolumną w danych źródłowych.

W polu danych zwykle sumowane są dane liczbowe, takie jak wielkości statystyczne czy kwoty sprzedaży, za pomocą funkcji podsumowania Suma. Na powyższej liście tabeli przestawnej komórka zawierająca liczbę 30 984 pokazuje całkowitą wielkość sprzedaży produktów mlecznych, osiągniętą przez Davolio w 1996 r. W komórce tej sumowane są kwoty sprzedaży ze wszystkich rekordów danych źródłowych, które w polu produktu mają zapis Produkty mleczne, w polu sprzedawcy mają zapis Davolio, a w polu roku zapis 1996.

Danymi może być również tekst, który jest domyślnie podsumowywany funkcją Ile.Liczb, dającą w wyniku liczbę elementów — na przykład pole danych zawierające typ sprzedawanego produktu może być wykorzystane do policzenia liczby transakcji sprzedaży produktów mlecznych przypisano sprzedawcy o nazwisku Davolio w 1996 r. Lista tabeli przestawnej umożliwia także podsumowanie danych za pomocą funkcji podsumowania Min i Max dających odpowiednio najmniejszą i największą wartość.

Obszar danych

Część listy tabeli przestawnej zawierająca pola danych.

Pole szczegółów

Pole wyświetlające wszystkie wiersze lub rekordy danych źródłowych.

Obszar szczegółów

Część listy tabeli przestawnej zawierająca pola szczegółów.

Strzałka rozwijania pola

Strzałka Strzałka pola po prawej stronie każdego pola. Należy kliknąć tę strzałkę, aby wyświetlić listę, na której można zaznaczyć elementy przeznaczone do wyświetlenia i ukrycia.

Na listach tabel przestawnych opartych na danych źródłowych OLAP można zaznaczać elementy na różnych poziomach w polu wymiaru. Pola daty i godziny oraz pola z grupami niestandardowymi zapewniają różne poziomy w danych źródłowych wszystkich typów. Na przykład po kliknięciu strzałki obok pola Rok mogłaby być wyświetlona następująca lista:

Lista rozwijana dla pola wymiaru OLAP

W przedstawionym przykładzie wyczyszczone pole wyboru obok liczby 1998 oznacza, że rok 1998 jest ukryty. Zacieniowane pole wyboru obok liczby 1999 oznacza, że rok 1999 jest aktualnie zaznaczony do wyświetlenia, ale niektóre elementy w obszarze 1999 nie są wybrane do wyświetlenia. Wewnątrz 1999 ukryty jest I kwartał. Zaznaczone pole wyboru obok liczby 2000 oznacza, że rok 2000 jest zaznaczony do wyświetlenia. Wybranie przycisku Wszystko spowoduje wyświetlenie wszystkich elementów na wszystkich poziomach.


Zaznaczanie elementów listy tabeli przestawnej

Zaznaczanie całej listy tabeli przestawnej

  • Kliknij pasek tytułu.

Uwaga Nie można wyświetlić paska tytułu, jeśli lista tabeli przestawnej nie jest powiązana z żadnym źródłem danych.

Zaznaczanie jednej lub większej liczby komórek danych

  • Aby zaznaczyć pojedynczą komórkę, kliknij ją. Aby zaznaczyć grupę komórek, kliknij i przeciągnij wskaźnik myszy, aż wszystkie żądane komórki będą zaznaczone.

Zaznaczanie pola wiersza, kolumny lub filtru

  • Kliknij etykietę pola.

Uwaga Zaznaczenie pola wiersza lub kolumny powoduje zaznaczenie wszystkich elementów danych znajdujących się w tym polu.

Zaznaczanie pola szczegółów

  • Kliknij etykietę pola. Jeśli dane szczegółowe są wyświetlane w przypadku kilku elementów i etykieta pola pojawia się wielokrotnie, to kliknięcie jednego wystąpienia powoduje zaznaczenie wszystkich wystąpień etykiety danego pola.

Zaznaczanie pola sum

  • Kliknij dowolną etykietę pola dla pola sum.

Zaznaczanie jednego lub większej liczby elementów

  • Aby zaznaczyć pojedynczy element, kliknij jego etykietę.
  • Aby dodać więcej elementów do zaznaczenia, naciśnij i przytrzymaj wciśnięty klawisz CTRL podczas klikania kolejnych etykiet elementów.
  • Aby zaznaczyć cały zakres elementów, kliknij etykietę pierwszego elementu, naciśnij klawisz SHIFT, a następnie kliknij etykietę ostatniego elementu.

Uwaga Zaznaczenie elementu powoduje zaznaczenie wszystkich związanych z nim danych.

Zaznaczanie sumy częściowej lub sumy końcowej

  • Kliknij sumę częściową lub sumę końcową.

Uwaga Zaznaczenie sumy częściowej lub sumy końcowej powoduje zaznaczenie wszystkich danych tej sumy.

Zaznaczanie paska tytułu lub obszaru upuszczania

  1. Kliknij pasek tytułu.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Podpisy.

  3. Na liście Wybierz podpis zaznacz odpowiedni element.

Zaznaczanie niestandardowej właściwości pola wiersza lub kolumny

  1. Kliknij pole wiersza lub kolumny albo jeden z jego elementów.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Właściwości elementu.
  3. Na liście Właściwości elementu zaznacz odpowiednią właściwość.

    Uwaga Jeśli wybrane pole nie ma żadnych właściwości niestandardowych, to lista Właściwości elementu będzie pusta.

    Można określić ustawienia związane z podpisem, formatem liczby i położeniem wybranej właściwości. Wybrane formaty zostaną zastosowane tylko do wskazanej właściwości.

  4. Aby określić ustawienia czcionek i stylu dla danej właściwości, wybierz pozycję Podpis właściwości lub Wartość właściwości z listy Format.

Uwaga Ustawienia czcionki i stylu tekstu zastosowane do danej właściwości niestandardowej mają wpływ na wszystkie właściwości niestandardowe na liście tabeli przestawnej, ale tylko wtedy, gdy są one wyświetlone w raporcie. Jeśli dana właściwość niestandardowa jest wyświetlana w postaci etykietki ekranowej, to formatowanie jest ignorowane.


Wyświetlanie informacji o polu lub elemencie

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Aby uzyskać informacje o polu, kliknij jego etykietę.
    • Aby uzyskać informacje o elemencie danych w polu, kliknij element.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Podpisy.


Tworzenie listy tabeli przestawnej

Kolejne kroki umożliwiające utworzenie listy tabeli przestawnej są uzależnione od programu używanego do projektowania strony sieci Web. Na przykład w programie Microsoft Access dane można automatycznie dodawać do listy tabeli przestawnej. Aby uzyskać więcej informacji, zobacz pomoc używanego programu do projektowania. Jeśli pomoc tego programu nie zawiera procedury służącej do tworzenia formantów, takich jak listy tabel przestawnych, należy wykonać następujące kroki:

  1. W programie do projektowania otwórz lub utwórz stronę sieci Web, na której ma pojawić się lista tabeli przestawnej.
  2. Używając procedury programu do projektowania służącej do dodawania formantów do strony sieci Web, zaznacz składnik Tabela przestawna i określ położenie oraz początkowy rozmiar listy tabeli przestawnej na stronie sieci Web.
  3. Dodaj dane źródłowe do listy tabeli przestawnej.

    Jak?

    Program do projektowania może zapewniać prostszy sposób dodawania danych do listy tabeli przestawnej. Poniższą procedurę należy zastosować, gdy program do projektowania nie zawiera procedury służącej do dodawania danych.

    Przed dodaniem danych do listy tabeli przestawnej należy zainstalować sterownik ODBC lub sterownik źródła danych (oprogramowanie obsługi OLE DB lub OLAP) i skonfigurować źródło danych, aby połączyć je z bazą danych. Aby uzyskać więcej informacji, zobacz Pomoc programu do projektowania.

    1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
    2. Kliknij listę tabeli przestawnej lub, jeśli dane zostały już do niej dodane, kliknij pasek tytułu listy tabeli przestawnej.
    3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Źródło danych.
    4. W obszarze Pobieranie danych przy użyciu wykonaj jedną z następujących czynności:

      Użyj formantu źródła danych

      • Jeśli na danej stronie sieci Web dostępny jest formant źródła danych lub obiekt źródła danych korzystający z instrukcji IDataSource, to na liście Formant danych źródłowych ustaw odpowiednią wartość.

      Określ informacje dotyczące połączenia

      1. Jeśli na danej stronie sieci Web nie ma formantu lub obiektu źródła danych albo jeśli trzeba połączyć listę z innymi danymi źródłowymi, wprowadź ciąg połączenia w polu Połączenie lub kliknij przycisk Edytuj, aby przejrzeć bądź wprowadzić informacje o źródle danych.

        W zależności od używanego programu do projektowania, kliknięcie przycisku Edytuj wyświetla okno dialogowe Wybierz źródło danych lub Właściwości łącza danych.

      2. Jeśli pojawi się okno dialogowe Wybierz źródło danych, wykonaj jedną z następujących czynności:
        1. W polu Szukaj w zlokalizuj żądane źródło danych, a następnie kliknij je dwukrotnie na liście.
        2. Jeśli odpowiednie źródło danych jest niedostępne, kliknij przycisk Nowe źródło, a następnie wykonaj instrukcje Kreatora łączenia danych, aby utworzyć nowy plik połączenia.
      3. Jeśli pojawi się okno dialogowe Właściwości łącza danych, to wprowadź informacje o połączeniu ze źródłem danych na karcie Połączenie. Aby uzyskać pomoc dotyczącą poszczególnych opcji, kliknij przycisk Pomoc w dolnej części okna dialogowego.
    5. W obszarze Używanie danych z wykonaj jedną z następujących czynności:
      • Aby użyć danych z określonego elementu wewnątrz bazy danych, takiego jak istniejąca tabela lub kwerenda, kliknij opcję Element danych, tabela, widok lub nazwa modułu, a następnie wybierz żądany element z listy.
      • Aby użyć kwerendy lub polecenia — takiego jak instrukcja SQL — do wybrania danych, kliknij polecenie Tekst polecenia lub SQL, a następnie wpisz kwerendę lub polecenie w polu. Aby uzyskać informacje na temat kwerend lub składni poleceń, zapoznaj się z dokumentacją bazy danych.
    6. Kliknij przycisk Wyświetl listę pól [image] na pasku narzędzi, a następnie przeciągnij pola do odpowiednich obszarów na liście tabeli przestawnej.

    Uwaga Użytkownicy nie mogą zmieniać w przeglądarce ustawień połączenia dla listy tabeli przestawnej.


Zapisywanie zmian na liście tabeli przestawnej

Aby zapisać zmiany, należy użyć polecenia programu do projektowania, które służy do zapisywania pliku zawierającego listę tabeli przestawnej. Aby uzyskać informacje o zapisywaniu zmian, zobacz Pomoc programu do projektowania.

Uwaga Użytkownicy nie mogą zapisywać zmian w przeglądarce, ale mogą eksportować lub kopiować listę tabeli przestawnej.


Drukowanie listy tabeli przestawnej

Aby wydrukować listę tabeli przestawnej, należy użyć polecenia drukowania w używanym programie do projektowania. Otrzymane wyniki zależą od możliwości drukowania stosowanego programu. Aby uzyskać więcej informacji, zobacz Pomoc używanego programu do projektowania.

Uwagi

  • Jeśli lista tabeli przestawnej jest szersza lub dłuższa niż strona wydruku, to fragmenty, które nie mieszczą się na stronie, nie zostaną wydrukowane. Aby uzyskać większą kontrolę nad sposobem drukowania danych, łącznie z możliwością drukowania długich list i wstawiania podziałów stron, można wyeksportować listę tabeli przestawnej do programu Microsoft Excel, klikając przycisk Eksportuj do programu Excel Eksportuj do programu Excel na pasku narzędzi. Aby uzyskać informacje dotyczące drukowania w programie Microsoft Excel, zobacz Pomoc programu Microsoft Excel.

  • W programie Microsoft FrontPage lista tabeli przestawnej może być wydrukowana niepoprawnie. Jeśli ten program jest używany jako program do projektowania, to należy kliknąć polecenie Podgląd w przeglądarce w menu Plik, a następnie wydrukować stronę sieci Web zawierającą listę tabeli przestawnej w programie Microsoft Internet Explorer.


Usuwanie listy tabeli przestawnej ze strony sieci Web

  1. W programie do projektowania zaznacz listę tabeli przestawnej. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Naciśnij klawisz DELETE.

Uwaga W przeglądarce nie można usunąć listy tabeli przestawnej ze strony sieci Web.


Tworzenie wykresu na podstawie listy tabeli przestawnej — informacje

Tworzenie wykresu opartego na liście tabeli przestawnej polega na wykreślaniu na nim danych wyświetlonych na liście. Zmiana sposobu wyświetlania danych na liście tabeli przestawnej lub na wykresie powoduje, że wykres lub lista tabeli przestawnej są dynamicznie aktualizowane, aby odzwierciedlić wprowadzone zmiany. Na przykład jeśli dodano pole do obszaru wiersza lub kolumny, to wykres będzie zaktualizowany, aby odzwierciedlić nowe pole w postaci danych kategorii lub serii. Podczas filtrowania danych na wykresie filtrowane są również dane znajdujące się na liście tabeli przestawnej.

Przygotowanie listy tabeli przestawnej

Przed utworzeniem wykresu należy się upewnić, że wszystkie dane, które mają być widoczne na wykresie, zostały przeniesione do obszarów wierszy i kolumn na liście tabeli przestawnej. Domyślnie dane umieszczone w polach wierszy są wyświetlane na wykresie jako dane serii, a dane z pól kolumn jako dane kategorii. Chcąc wyświetlić dane na wykresie, należy także dodać do listy tabeli przestawnej co najmniej jedno pole sumy. Dodanie więcej niż jednego pola sumy spowoduje, że na wykresie będą użyte dane z pola znajdującego się najbardziej po lewej.

Tworzenie wykresu

Aby utworzyć wykres, należy użyć procedury dostępnej w programie do projektowania, za pomocą której dodaje się sterownik do strony sieci Web. W procedurze można wybrać odpowiedni typ wykresu oraz zmienić dane serii, aby wykorzystać dane z pól kolumn zamiast z pól wierszy.

Na poniższym przykładzie przedstawiono wykres oparty na liście tabeli przestawnej. Pole o nazwie Suma sprzedaży zawiera całkowitą wielkość sprzedaży produktów każdego typu dla poszczególnych sprzedawców. Niebieska strzałka na etykiecie pola Sprzedawca oznacza, że dla pola tego ustawiono filtr, aby wyświetlać dane dotyczące tylko czterech sprzedawców.

Wykres utworzony na podstawie listy tabeli przestawnej

1 Pole kolumny Typ z listy tabeli przestawnej jest pokazywane na wykresie jako dane kategorii (Napoje, Produkty mleczne itd.).

2 Pole wiersza Sprzedawca jest pokazywane na wykresie jako dane serii.

3 Nazwy serii są wyświetlane w legendzie (Kowalski, Davolio itd.).

Używanie wykresu

Podczas dodawania lub przenoszenia pól na liście tabeli przestawnej wykres jest aktualizowany w celu odzwierciedlenia zmian.

Zaktualizowany wykres ze zmianami wprowadzonymi na liście tabeli przestawnej

W poprzednim przykładzie pole Sprzedawca przeniesiono do obszaru kolumn, a pole Typ — do obszaru wierszy listy tabeli przestawnej. Do obszaru kolumn dodano pole Region, a następnie tak ustawiono filtr, aby były wyświetlane tylko informacje o regionach Wschód i Północ. Wykres został zaktualizowany: dane z pola Typ są wyświetlone w legendzie jako seria, a dane z pól Sprzedawca i Region znalazły się w kategoriach.

Można sortować, filtrować i przenosić pola w obrębie wykresu.


Tworzenie wykresu na podstawie listy tabeli przestawnej

Kolejne kroki tworzenia wykresu na podstawie listy tabeli przestawnej zależą od programu do projektowania używanego do tworzenia strony sieci Web. Aby uzyskać więcej informacji, zobacz Pomoc stosowanego programu. Jeśli pomoc programu do projektowania nie zawiera procedury służącej do tworzenia formantów, takich jak wykresy, to można wykonać następujące kroki:

  1. W programie do projektowania otwórz lub utwórz stronę sieci Web, na której ma się pojawić wykres.
  2. Jeśli na stronie sieci Web nie ma jeszcze listy tabeli przestawnej, to ją utwórz.

  3. Dodaj potrzebne pola do obszarów wierszy i kolumn na liście tabeli przestawnej.

    Uwaga Dane w polach wierszy i kolumn będą używane jako serie i kategorie na wykresie.

  4. Dodaj wykres do strony sieci Web, korzystając z Pomocy programu do projektowania.
  5. Kliknij w środku wykresu.

    Pojawi się okno dialogowe Polecenia i opcje [image] wykresu.

  6. Wybierz opcję Dane z następującego elementu strony sieci Web, a następnie kliknij pozycję odpowiadającą żądanej liście tabeli przestawnej.


Korzystanie z listy tabeli przestawnej w przeglądarce — informacje

Korzystając z programu do projektowania, można utworzyć listę tabeli przestawnej, która będzie dostępna w przeglądarce sieci Web lub w innym środowisku.

Uwaga Przed utworzeniem listy tabeli przestawnej, która miałaby być używana w innym programie niż przeglądarka sieci Web, na przykład w formularzu programu Microsoft Visual Basic będącym częścią niestandardowego rozwiązania, należy zapoznać się z pomocą programu do projektowania, aby sprawdzić, w jaki sposób przyszli użytkownicy mogą uzyskać dostęp do listy tabeli przestawnej i interakcyjnie z nią pracować.

Wymagania związane z używaniem listy tabeli przestawnej w przeglądarce

Możliwość korzystania z listy tabeli przestawnej w przeglądarce jest uzależniona od zainstalowania składników Microsoft Office Web Components. Aby spełnić ten warunek, można zainstalować pakiet Microsoft Office XP lub — jeśli firma wykupiła licencję na używanie pakietu Office XP — pobrać odpowiednie składniki ze swojej firmowej sieci intranet. Użytkownicy muszą także mieć przeglądarkę sieci Web, która w pełni obsługuje listy tabel przestawnych.

Aby w pełni korzystać z możliwości list tabel przestawnych, użytkownicy potrzebują przeglądarki Microsoft Internet Explorer w wersji 4.01 lub nowszej. Użytkownicy innych przeglądarek nie mogą przeglądać list tabel przestawnych lub interakcyjnie z nimi współpracować.

Interfejs przeglądarki dla list tabel przestawnych

W przeglądarce użytkownicy mogą uaktywnić listę tabeli przestawnej i interakcyjnie z nią współpracować, używając tego samego paska narzędzi i okna dialogowego Polecenia i opcje, z których korzysta się podczas projektowania układu danych. Użytkownicy nie mają jednak dostępu w przeglądarce do niektórych opcji dostępnych w programie do projektowania.

W przeglądarce można ponadto wyświetlić tę samą listę pól, której używa się w programie do projektowania. Lista pól dostępna jest z paska narzędzi na liście tabeli przestawnej i zawiera wszystkie udostępnione pola z danych źródłowych.

Korzystanie z Pomocy w przeglądarce

W przeglądarce użytkownik ma dostęp do dwóch typów pomocy: do systemu pomocy samej przeglądarki oraz do zawartości dodatkowej pomocy automatycznie dołączonej do listy tabeli przestawnej. Ta ostatnia pomoc wyjaśnia, jak używać poleceń i funkcji dostępnych na liście tabeli przestawnej w przeglądarce. Aby wyświetlić tę pomoc, należy otworzyć w przeglądarce stronę sieci Web zawierającą listę tabeli przestawnej i kliknąć przycisk Pomoc [image] na pasku narzędzi listy tabeli przestawnej. Można również dołączyć własną niestandardową pomoc do listy tabeli przestawnej w przeglądarce.

Ograniczanie użycia listy tabeli przestawnej w przeglądarce

Aby uprościć opcje dostępne dla użytkowników, można wprowadzić ograniczenia, które będą stosowane podczas wyświetlania listy tabeli przestawnej w przeglądarce sieci Web. Można na przykład zapobiec wyświetlaniu danych szczegółowych. Można także wprowadzić ograniczenia, aby upewnić się, że użytkownicy nie zmodyfikują niektórych aspektów rozmieszczenia danych w programie do projektowania. Na przykład można uniemożliwić przenoszenie pól wierszy i kolumn.

Mając na uwadze potrzeby i umiejętności przyszłych użytkowników, można wykonać analizę danych w programie do projektowania, a następnie opublikować jej wyniki. Dla mniej doświadczonych użytkowników można opublikować gotowe podsumowania jako osobne listy tabel przestawnych na stronie sieci Web. W przypadku użytkowników zaawansowanych można udostępnić dane na liście tabeli przestawnej i pozostawić im ich analizę.


Ograniczanie użycia listy tabeli przestawnej w przeglądarce — informacje

Niektóre funkcje listy tabeli przestawnej są dostępne tylko podczas pracy z programem do projektowania. Z innych można korzystać zarówno na etapie projektowania listy, jak i jej używania w przeglądarce. Osoba projektująca listę może jednak ograniczyć dostępność pewnych funkcji, odpowiednio modyfikując ustawienia właściwości.

Bez względu na to, jakie funkcje udostępniono użytkownikom, możliwość ich zastosowania zależy od uruchomionej przeglądarki. Aby w pełni wykorzystać możliwości list tabel przestawnych, użytkownicy potrzebują przeglądarki Microsoft Internet Explorer w wersji 4.01 lub nowszej.

Funkcje niedostępne w przeglądarce

W przeglądarce nie można zmienić informacji dotyczących źródłowej bazy danych, pól bazy danych oraz danych źródłowych.

Osoba projektująca listę tabeli przestawnej określa użytą źródłową bazę danych i podzbiór danych udostępniony jako dane źródłowe na liście tabeli przestawnej.

Użytkownicy mogą wyświetlić w przeglądarce jedynie te dane, które zostały udostępnione; jeśli dostęp do bazy danych wymaga podania hasła, to użytkownicy muszą je wprowadzić, aby wyświetlić dane. Użytkownicy mogą odświeżyć listę tabeli przestawnej w przeglądarce, aby odzwierciedlić zmiany wprowadzone w danych źródłowych, ale nie mogą uzyskać szerszego dostępu do źródłowej bazy danych lub zmieniać przechowywanych w niej danych.

Funkcje dostępne zwykle w przeglądarce

Jeśli dana przeglądarka w pełni obsługuje listy tabel przestawnych, to użytkownik może zmieniać listy tabel przestawnych prawie tak samo, jak za pomocą programu do projektowania.

Zachowując wszystkie ograniczenia ustawione podczas projektowania listy tabeli przestawnej, użytkownik może dodawać lub usuwać pola z listy pól, zmieniać układ danych oraz sortować, filtrować i grupować je. Użytkownicy mogą analizować dane i tworzyć podsumowania, tak jak osoba pracująca w programie do projektowania.

Ograniczenia, które można ustawić

Aby zapobiec wprowadzaniu zmian do listy tabeli przestawnej przez użytkowników lub zabezpieczyć wybraną część danych źródłowych, która ma być niedostępna, można wprowadzić ograniczenia dotyczące następujących czynności:

  • dostępu do okna dialogowego Polecenia i opcje
  • zmiany układu
  • grupowania elementów
  • filtrowania danych
  • sortowania danych w niestandardowej kolejności
  • przeglądania danych szczegółowych
  • dodawania, edycji lub usuwania danych szczegółowych


Ograniczanie użycia listy tabeli przestawnej w przeglądarce

Zmiana ustawienia uniemożliwiająca użytkownikowi wykonywanie określonych zadań, powoduje, że osoba pracująca w programie do projektowania również nie może wykonać danej czynności, chyba że ponownie zmieni odpowiednie ustawienie.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi.

  3. Kliknij pasek tytułu listy tabeli przestawnej.

  4. W oknie dialogowym Polecenia i opcje kliknij kartę Ochrona.

  5. Wykonaj jedną z następujących czynności:

    Zapobiegnij dodawaniu, zmianie lub usuwaniu filtrów

    • Wyczyść pole wyboru Filtrowanie.

    Zapobiegnij grupowaniu lub zmianie układu

    • Wyczyść pole wyboru Grupowanie i zmienianie układu.

    Zapobiegnij sortowaniu danych w niestandardowej kolejności

    • Wyczyść pole wyboru Niestandardowa kolejność elementów.

    Zapobiegnij wyświetlaniu danych szczegółowych

    • Wyczyść pole wyboru Wyświetlanie danych szczegółowych.

    Zapobiegnij edycji danych szczegółowych

    • Wyczyść pole wyboru Edytowanie danych szczegółowych.

    Zapobiegnij dodawaniu wierszy szczegółów

    • Wyczyść pole wyboru Wstawianie nowych wierszy szczegółów.

    Zapobiegnij usuwania wierszy szczegółów

    • Wyczyść pole wyboru Usuwanie wierszy szczegółów.

    Zablokuj dostęp do okna dialogowego Polecenia i opcje

    • Wyczyść pole wyboru Wyświetlanie okna Polecenia i opcje w trybie uruchamiania.

Uwagi

  • Nawet jeśli pole wyboru Wyświetl okno Polecenia i opcje w trybie uruchamiania zostanie wyczyszczone, to przycisk Polecenia i opcje [image] będzie ciągle dostępny na pasku narzędzi podczas projektowania listy tabeli przestawnej.
  • Powyższe ograniczenia nie skutkują w programie Microsoft Excel. Użytkownicy, którzy eksportują listę tabeli przestawnej do programu Excel z przeglądarki, mogą następnie używać funkcji tego programu do przeglądania wszystkich danych szczegółowych dostępnych w danych źródłowych. Aby ograniczyć dostęp użytkowników do danych szczegółowych w ten sposób, można zapobiec wykorzystaniu polecenia Eksportuj do programu Excel w przeglądarce — w tym celu należy wyłączyć pasek narzędzi, ograniczyć dostęp do okna dialogowego Polecenia i opcje oraz napisać kod ukrywający menu skrótów.


Zmienianie tytułu, podpisów i etykiet

Uwaga Wprowadzane zmiany nie wpływają na dane źródłowe.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi.
  3. Wykonaj co najmniej jedną z następujących czynności:

    Zmień tekst paska tytułu lub podpisu obszaru upuszczania

    1. Kliknij pasek tytułu listy tabeli przestawnej.
    2. Kliknij kartę Podpisy w oknie dialogowym Polecenia i opcje.
    3. Na liście Wybierz podpis zaznacz element, którego podpis chcesz zmienić.
    4. W polu tekstowym Podpis wpisz nowy tytuł lub podpis.

    Zmień podpis pola, zestawu pól lub pola grupy niestandardowej

    1. Wykonaj jedną z następujących czynności:
      • Aby zmienić podpis pola, kliknij to pole.
      • Aby zmienić podpis zestawu pól, kliknij pole należące do zestawu.
    2. Kliknij kartę Podpisy w oknie dialogowym Polecenia i opcje.
    3. Na liście Wybierz podpis zaznacz element, którego podpis chcesz zmienić.
    4. W polu tekstowym Podpis wpisz nowy tytuł lub podpis.

    Zmień podpis właściwości elementu

    1. Kliknij pole, do którego należy właściwość elementu.
    2. Kliknij kartę Właściwości elementu w oknie dialogowym Polecenia i opcje.
    3. Na liście Właściwości elementu kliknij właściwość, której podpis chcesz zmienić.
    4. W polu tekstowym Podpis wpisz nowy tytuł lub podpis.

    Zmień podpis elementu lub grupy niestandardowej

    1. Kliknij element lub grupę niestandardową, której podpis chcesz zmienić.
    2. Kliknij kartę Podpisy w oknie dialogowym Polecenia i opcje.
    3. W polu tekstowym Podpis wpisz nowy tytuł lub podpis.

Uwaga Aby zaznaczony element nie miał podpisu, należy wyczyścić pole tekstowe Podpis.


Dodawanie niestandardowych instrukcji do listy tabeli przestawnej — informacje

Zależnie od umiejętności użytkownika i rodzaju wykonywanej przez niego pracy, można uzupełnić bieżącą pomoc, dodając do listy tabeli przestawnej niestandardowe instrukcje. Nie można ich jednak bezpośrednio łączyć z pomocą online dostarczoną z listą tabeli przestawnej.

Można dostarczyć instrukcje, dołączając odpowiedni tekst z opisem listy tabeli przestawnej bezpośrednio do danej strony sieci Web lub dodając hiperłącze do oddzielnej strony sieci Web zawierającej instrukcje.

Informacje o sposobach przeprowadzania tej czynności w przypadku różnych rodzajów stron sieci Web można znaleźć w pomocy programu do projektowania stron.


Dodawanie i usuwanie pól — informacje

Dodając dane do listy tabeli przestawnej, należy określić bazę danych, z której będą pobierane dane oraz podzbiór danych, który będzie udostępniony jako dane źródłowe listy tabeli przestawnej. Z danych źródłowych można wybrać pola, które na początku będą wyświetlane na liście tabeli przestawnej.

Wyświetlanie pól dostępnych dla listy tabeli przestawnej

Korzystając z listy pól, można wyświetlić listę pól i zestawów pól dostępnych w danych źródłowych oraz dodać pola do obszarów wierszy, kolumn, filtru, danych i szczegółów na liście tabeli przestawnej. Pola, które na liście pól nie są pogrubione, są dostępne, ale nie zostały jeszcze wyświetlone na liście tabeli przestawnej. Pogrubione pola już są wyświetlone. Można przewijać zawartości listy i klikać wskaźniki rozwijania (symbole Pole plus lub Pole minus) obok poszczególnych zestawów pól, aby pokazać lub ukryć określone pola na liście pól.

Jeśli lista tabeli przestawnej oparta jest na danych źródłowych z bazy danych OLAP, na przykład utworzonej za pomocą programu Microsoft SQL Server OLAP Services, to można zauważyć, że nie da się przenieść pól do obszaru szczegółów. Można także zauważyć, że niektóre pola da się przenieść jedynie do obszarów wierszy, kolumn lub filtrów. Inne pola, wpisane w obszarze Sumy, mogą być użyte wyłącznie jako pola danych. Pola należące do jednego zestawu pól nie mogą być wyświetlone w dwóch różnych obszarach upuszczania.

Dodawanie pól do obszaru szczegółów

Aby wyświetlić wszystkie dostępne dane szczegółowe i zobaczyć, które dane są dostępne do podsumowywania, należy użyć pól szczegółów. Po dodaniu pól do obszaru szczegółów zostaną wyświetlone wszystkie odpowiadające im rekordy z danych źródłowych. Nazwy pól zamieniają się w etykietki kolumn, a kolejne rekordy są wyświetlane w wierszach pod etykietami kolumn.

Przykład pól szczegółów

1 Pola szczegółów

2 Dane szczegółowe

Jeśli lista tabeli przestawnej nie jest oparta na danych źródłowych z bazy danych OLAP, to można dodać pole obliczeniowe szczegółów, które umożliwia obliczenie wartości szczegółów za pomocą odpowiedniego wyrażenia.

Dodawanie pól do obszaru wiersza lub kolumny

Pola wierszy i kolumn służą do podsumowywania i porównywania danych. Pola te wyświetlają unikatowe elementy danych pola w kolejnych wierszach lub w poprzek kolumn. Komórka znajdująca się na przecięciu wiersza i kolumny podsumowuje dane dla elementu.

Przykład pól wierszy i kolumn

1 Pole kolumny

2 Element pola kolumny

3 Pole wiersza

4 Elementy pola wiersza

Dodawanie pól do obszaru danych

Pola danych zawierają wartości do podsumowania na liście tabeli przestawnej. Po dodaniu pola do obszaru danych wartości z pola są podsumowywane dla elementów pola wiersza i kolumny.

Przykład pola danych

1 Pole danych

2 Podsumowane dane

Dodawanie pól do obszaru filtru

Pole filtru jest podobne do pola strony w raporcie tabeli przestawnej programu Microsoft Excel. Pól filtrów można używać do ograniczania widoku do określonej części dostępnych danych. Po wybraniu elementu w polu filtru dane będą wyświetlane i obliczane wyłącznie dla tego elementu. Na przykład dodanie pola filtru Region spowoduje, że na liście tabeli przestawnej będą wyświetlane i obliczane dane dla wskazanych regionów.

Przykład pola filtru

1 Pole filtru

2 Element pola filtru

3 Podsumowanie dla wybranego regionu

Dodawanie pola sum

Można utworzyć nowe pola danych, dodając pola sum do listy tabeli przestawnej. Pola sum zapewniają podsumowanie danych używanych jako pola danych. Na przykład jeśli dane źródłowe zawierają pole Sprzedaż, które pokazuje kwotę, za jaką dokonano każdej sprzedaży, to można dodać pole sumy o nazwie Suma sprzedaży, aby obliczać całkowitą sumę sprzedaży lub pole sumy o nazwie Ile sprzedano, aby obliczać, ile jednostek produktu zostało sprzedanych.

Można także dodać obliczeniowe pole sumy, które umożliwia obliczenie sumy wartości na podstawie określonego wyrażenia.

Usuwanie pól

Aby wyeliminować dane, których nie należy wyświetlać ani podsumowywać, można usunąć określone pola z układu listy tabeli przestawnej. Usunięcie pola nie usuwa go z dostępnych danych źródłowych. Usunięte pole przestaje być wyświetlane na liście tabeli przestawnej, można go jednak przeglądać na liście pól.

Przenoszenie pól

Po dodaniu pola do listy tabeli przestawnej można przenosić je do innych obszarów. Podczas przenoszenia pola zmienia się układ listy tabeli przestawnej oraz zmieniają się wyświetlane dane i obliczane podsumowania.

Wpływ dodawania i usuwania pól na filtrowanie

Po usunięciu pola ustawienia filtrowania zostają zachowane. Jeśli pole zostanie usunięte, a następnie ponownie dodane do układu, to identyczne elementy będą ukryte.

Przeglądanie informacji o polach

Można przeglądać informacje o polach na liście tabeli przestawnej, włącznie z informacją o polu w źródłowej bazie danych, z której są pobierane dane oraz typem danych, jakie dane pole pobiera ze źródłowej bazy danych.

Ograniczanie użycia listy tabeli przestawnej w przeglądarce

Funkcje dodawania pól i tworzenia podsumowań są także dostępne w przeglądarce, o ile nie ograniczono dostępu. Aby uniemożliwić użytkownikom zmianę pól, które ustawiono jako pola wierszy i kolumn, można zapobiec dodawaniu i przenoszeniu pól wierszy i kolumn w przeglądarce. Można także ograniczyć dostęp do szczegółów, aby użytkownicy nie mogli przenosić pól do obszaru szczegółów oraz ograniczyć dostęp do filtrowania, aby użytkownicy nie mogli przenosić pól do obszaru filtru.


Dodawanie i usuwanie pola

Dodawanie pola

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj co najmniej jedną z następujących czynności:

    Dodaj pole do obszaru wiersza, kolumny, danych, filtru lub szczegółów

    1. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Wyświetl listę pól [image].
    2. Użyj pasków przewijania i pól Pole plus i Pole minus, aby znaleźć pole, które chcesz dodać do listy tabeli przestawnej.
    3. Kliknij pole, a następnie zaznacz obszar, do którego chcesz dodać pole, w prawym dolnym rogu listy pól.
    4. Kliknij przycisk Dodaj do.

    Uwagi

    • Jeśli przycisk Dodaj do jest niedostępny po wybraniu pozycji Obszar wiersza, Obszar kolumny, Obszar danych lub Obszar filtru, to może oznaczać, że wybranego pola nie można użyć jako pola wiersza, kolumny, danych lub filtru. Jeśli lista tabeli przestawnej jest oparta na danych źródłowych pochodzących z bazy danych OLAP, to jako pól wierszy, kolumn, danych lub filtrów nie można użyć pól wyświetlonych na liście w obszarze sum.

    • Jeśli przycisk Dodaj do jest niedostępny po wybraniu opcji Dane szczegółowe, to może oznaczać, że dane szczegółowe mogą być niedostępne z danych źródłowych. Na przykład jeśli lista tabeli przestawnej jest oparta na danych źródłowych pochodzących z bazy danych OLAP, to często dostępne są tylko dane podsumowane, a nie dane szczegółowe.

    Dodaj pola sum

    Można dodać pola sum do obszaru danych, ale nie do obszaru wiersza, kolumny, szczegółów lub filtru.

    1. Kliknij pole zawierające wartości, które chcesz podsumować.
    2. Na pasku narzędzi kliknij przycisk Autosumowanie [image], a następnie kliknij żądaną funkcję podsumowania.

    Uwaga Przycisk Autosumowanie jest niedostępny, gdy dane źródłowe listy tabeli przestawnej nie pozwalają na dodawanie pól sum — na przykład gdy dane źródłowe pochodzą z bazy danych OLAP.

    Dodaj obliczeniowe pola sum lub szczegółów

    Można dodać pole sum lub szczegółów, które oblicza dane na podstawie określonego wyrażenia.

    1. Na pasku narzędzi kliknij przycisk Pola i sumy obliczeniowe [image].

    2. W wyświetlonym menu wykonaj jedną z następujących czynności:

      • Aby utworzyć pole sumy, kliknij polecenie Utwórz sumę obliczeniową.

      • Aby utworzyć pole szczegółów, kliknij polecenie Utwórz pole obliczeniowe szczegółów.

    3. Na karcie Obliczanie w oknie dialogowym Polecenia i opcje wpisz żądane wyrażenie, a następnie kliknij przycisk Zmień.

      Porada

      Aby dodać odwołanie do pola, zaznacz odpowiednią pozycję w polu Wstaw odwołanie do, a następnie kliknij przycisk Wstaw odwołanie do.

    Uwaga Aby edytować wyrażenie użyte w polu obliczeniowym, należy zaznaczyć pole, edytować wyrażenie i kliknąć przycisk Zmień na karcie Obliczanie w oknie dialogowym Polecenia i opcje. Wartości pola zostaną automatycznie obliczone ponownie za pomocą nowego wyrażenia.

Uwagi

  • Można ograniczyć możliwości użytkownika w zakresie dodawania pól w przeglądarce. Można również wprowadzić ograniczenia dotyczące filtrowania danych.
  • Domyślnie pola danych podsumowujące dane liczbowe używają funkcji podsumowania Suma. Pola podsumowujące inne typy danych używają funkcji podsumowania Ile.Liczb.

Usuwanie pola

Po usunięciu pola z układu listy tabeli przestawnej, dane z tego pola nie są już wyświetlane; pole jest jednak nadal dostępne do przeglądania na liście pól.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij etykietę pola, które chcesz usunąć z listy tabeli przestawnej.
  3. Przeciągnij pole poza listę tabeli przestawnej, aby wskaźnik zmienił kształt na Wskaźnik z czerwonym X.

Uwagi

  • Można usuwać pola sum i pola obliczeniowe szczegółów zarówno z listy tabeli przestawnej, jak i listy pól — należy w tym celu kliknąć prawym przyciskiem myszy odpowiednie pole, a następnie kliknąć polecenie Usuń w menu skrótów.

  • Można ograniczyć możliwości użytkowników w zakresie usuwania pól w przeglądarce.


Dostosowywanie układu listy tabeli przestawnej — informacje

Można zmienić sposób podsumowywania danych na liście tabeli przestawnej poprzez dostosowanie jej układu. Różne układy pozwalają obliczać i porównywać podsumowane wartości dla różnych elementów danych lub wyświetlać podsumowania dla podzbiorów danych. Po udostępnieniu listy tabeli przestawnej użytkownicy mogą wprowadzać dalsze zmiany układu początkowego w swoich przeglądarkach.

Używanie obszarów upuszczania

Można zmieniać układ, przenosząc pola do wstępnie zdefiniowanych obszarów upuszczania na liście tabeli przestawnej.

Przykład obszarów upuszczania

1 Obszary upuszczania

2 Obszar szczegółów

Po przeniesieniu pól do obszarów upuszczania, co powoduje zasłonięcie podpisów obszarów upuszczania, można nadal przeciągać do nich dodatkowe pola. Można także dodawać pola do innych obszarów upuszczania za pomocą przycisku Dodaj do na liście pól.

Przenoszenie pól do obszarów wierszy i kolumn

Po przeniesieniu pola do obszaru wierszy unikatowe elementy danych tego pola będą wyświetlane w wierszach listy tabeli przestawnej. Przeniesienie pola do obszaru kolumn spowoduje wyświetlenie unikatowych elementów danych w poprzek kolumn.

Przenoszenie pól do obszaru szczegółów

Aby zobaczyć wszystkie rekordy szczegółów danych źródłowych dla listy tabeli przestawnej, można przenieść pola do obszaru szczegółów. Jeżeli użytkownik nie chce ponownie rozmieszczać pól ani zmieniać podsumowanych danych, to może wyświetlić szczegóły obok podsumowanych danych.

Przenoszenie pól do obszaru danych

Pola danych zawierają wartości do podsumowania na liście tabeli przestawnej. Po przeniesieniu pola do obszaru danych wartości z pola są podsumowywane dla elementów pól wierszy i kolumn.

Przenoszenie pól do obszaru filtru

Pole filtru jest podobne do pola strony w raporcie tabeli przestawnej programu Microsoft Excel. Pola filtru umożliwiają ograniczenie widoku do pewnej części dostępnych danych. Na przykład po przeniesieniu pola Produkt do obszaru filtru na liście tabeli przestawnej można wyświetlić podsumowanie dla jednego produktu na raz.

Przenoszenie pól wierszy i kolumn na wyższy lub niższy poziom

Gdy lista tabeli przestawnej ma wiele pól wierszy i kolumn, to pola znajdujące się najbliżej podsumowywanych danych nazywane są polami wewnętrznymi. Pozostałe pola to pola zewnętrzne.

Przykład wewnętrznych i zewnętrznych pól wierszy

1 Zewnętrzne pole wierszy

2 Wewnętrzne pole wierszy

3 Elementy pola zewnętrznego

4 Elementy pola wewnętrznego powtarzają się dla każdego elementu w polu zewnętrznym.

Dodawanie i usuwanie pól

Układ listy tabeli przestawnej nie musi zawierać wszystkich pól dostępnych w danych źródłowych. Jeśli dostępnych jest więcej danych, to można dodać pola do układu listy tabeli przestawnej. Na przykład jeśli lista tabeli przestawnej podsumowuje dochód ze sprzedaży, a dane źródłowe zawierają także wielkość sprzedaży, to można dodać pole wielkości jako pole danych, aby podsumowywać zarówno dochód ze sprzedaży, jak i ilość sprzedanego produktu. Można także usunąć z układu listy tabeli przestawnej pola, które nie mają być widoczne.

Ograniczenia w dodawaniu i przenoszeniu pól

Podczas pracy z listą tabeli przestawnej opartą na danych źródłowych z bazy danych OLAP, na przykład utworzonej w programie Microsoft SQL Server OLAP Services, można zauważyć, że pola nie dają się przenieść do obszaru szczegółów. Można także zauważyć, że niektóre pola da się przenieść jedynie do obszaru wierszy, kolumn i filtrów oraz że pola z obszaru danych nie mogą być przenoszone do innych obszarów.

Ograniczanie użycia listy tabeli przestawnej w przeglądarce

Można ograniczyć zmiany układu listy tabeli przestawnej, jakich będzie mógł dokonać użytkownik, uniemożliwiając dodawanie i przenoszenie pól w przeglądarce.


Przenoszenie pola lub kolumny

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wyświetl obszary upuszczania listy tabeli przestawnej.

    Jak?

    Jeżeli obszary upuszczania są ukryte, a lista tabeli przestawnej nie ma jeszcze żadnych pól w obszarze wiersza, kolumny, danych lub filtru, to nie można przeciągać pól do tych obszarów.

    1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
    2. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.

    3. Zaznacz lub wyczyść pole wyboru Obszary upuszczania.

    Uwaga Nie można zobaczyć obszarów upuszczania, jeśli lista tabeli przestawnej nie jest powiązana z żadnym źródłem danych.

  3. Wykonaj co najmniej jedną z następujących czynności:

    Przenieś pole do obszaru wiersza lub kolumny

    1. Wskaż etykietę pola, które chcesz przenieść, aby wskaźnik zmienił kształt na Wskaźnik o kształcie strzałki z czterema grotami.
    2. Wykonaj jedną z następujących czynności:

      • Aby pole stało się polem wiersza, kliknij i przeciągnij etykietę pola do obszaru wiersza znajdującego się po lewej stronie listy tabeli przestawnej, tak aby wskaźnik zmienił kształt na Wskaźnik z wyróżnionym obszarem wiersza.

      • Aby pole stało się polem kolumny, kliknij i przeciągnij etykietę pola do obszaru kolumny znajdującego się u góry listy tabeli przestawnej, tak aby wskaźnik zmienił kształt na Wskaźnik z wyróżnionym obszarem kolumny.

    Przenieś pole do obszaru szczegółów

    Jeśli listę tabeli przestawnej utworzono na podstawie danych źródłowych pochodzących z bazy danych OLAP, to nie można przenosić pól do obszaru szczegółów.

    1. Wskaż etykietę pola, które chcesz przenieść, tak aby wskaźnik zmienił kształt na Wskaźnik o kształcie strzałki z czterema grotami.

    2. Kliknij i przeciągnij pole do obszaru szczegółów znajdującego się w dolnej części listy tabeli przestawnej po prawej stronie, tak aby wskaźnik zmienił kształt na Wskaźnik z wyróżnionym obszarem szczegółów.

    Przenieś pole do obszaru danych

    Pola można przenosić z obszarów wierszy, kolumn lub filtrów do obszaru danych jedynie wówczas, gdy lista tabeli przestawnej opiera się na danych z innego źródła niż baza danych OLAP.

    1. Wskaż etykietę pola, które chcesz przenieść, tak aby wskaźnik zmienił kształt na Wskaźnik o kształcie strzałki z czterema grotami.
    2. Kliknij i przeciągnij pole do obszaru danych znajdującego się w prawym dolnym rogu listy tabeli przestawnej, tak aby wskaźnik zmienił kształt na Wskaźnik o kształcie znaku sigma.

    Uwaga Sposób sumowania pola przeciąganego do obszaru danych zależy od typu danych w polu. Pola zawierające dane liczbowe są sumowane za pomocą funkcji podsumowania Suma. Pola zawierające inne typy danych są sumowane za pomocą funkcji podsumowania Ile.Liczb.

    Przenieś pole do obszaru filtru

    1. Wskaż etykietę pola, które chcesz przenieść, tak aby wskaźnik zmienił kształt na Wskaźnik o kształcie strzałki z czterema grotami.
    2. Kliknij i przeciągnij pole do obszaru filtru u góry listy tabeli przestawnej, tak aby wskaźnik zmienił kształt na Wskaźnik z wyróżnionym obszarem filtru.

    Przenieś pole wiersza lub kolumny na wyższy lub niższy poziom (zmiana kolejności kolumnową pól)

    1. Wskaż etykietę pola, które chcesz przenieść, tak aby wskaźnik zmienił kształt na Wskaźnik o kształcie strzałki z czterema grotami.
    2. Wykonaj jedną z następujących czynności:

      • Aby przenieść pole na wyższy poziom, kliknij i przeciągnij jego etykietę w lewo i upuść w odpowiednim miejscu.

      • Aby przenieść pole na niższy poziom, kliknij i przeciągnij jego etykietę w prawo i upuść w odpowiednim miejscu.

Uwaga Aby uniemożliwić przenoszenie pól przez użytkowników, należy zmienić odpowiednie ustawienie na karcie Ochrona w oknie dialogowym Polecenia i opcje. Aby wyświetlić kartę Ochrona, należy kliknąć pasek tytułu listy tabeli przestawnej.


Ustawianie rozmiaru listy tabeli przestawnej i jej elementów

Ustawianie rozmiaru listy tabeli przestawnej

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.
  3. Wykonaj jedną z następujących czynności:

    Zmień wysokość i szerokość formantu

    1. Wyczyść pole wyboru Automatycznie dopasuj formant.
    2. Umieść wskaźnik myszy na jednym z uchwytów zaznaczenia listy tabeli przestawnej, a następnie przeciągnij wskaźnik w wybranym kierunku.

    Automatycznie zmień rozmiar formantu na stronie sieci Web, aby dopasować zawartość

    1. Zaznacz pole wyboru Automatycznie dopasuj formant.
    2. Aby rozmiar listy tabeli przestawnej nie był większy od pewnej określonej wartości, wpisz wartość w pikselach w polu Maksymalna wysokość w pikselach i/lub w polu Maksymalna szerokość w pikselach.

Uwaga Jeśli na liście tabeli przestawnej znajdzie się więcej danych, niż pomieści określony rozmiar, to będą wyświetlone paski przewijania.

Zmienianie szerokości kolumny w obszarze wiersza, kolumny, szczegółów i danych

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wskaż prawą granicę etykiety pola aż wskaźnik zmieni kształt na Wskaźnik z prostopadłą strzałką o dwóch grotach.
  3. Wykonaj jedną z następujących czynności:

    • Aby zwiększyć lub zmniejszyć szerokość, przeciągnij granicę do momentu osiągnięcia przez kolumnę odpowiedniej szerokości.

    • Aby dopasować szerokość kolumny do zawartości, kliknij dwukrotnie granicę kolumny.

Uwaga Nie można dostosowywać wysokości wierszy na liście tabeli przestawnej.


Obliczanie sum — informacje

W listach tabel przestawnych używa się dwóch różnych typów sum do wyświetlania wartości podsumowań. Pierwszy typ, pole sumy, umożliwia wyświetlenie wartości podsumowań dla listy tabeli przestawnej. Jeśli lista tabeli przestawnej zawiera pole sumy, to można również wyświetlać drugi typ, sumy częściowe i sumy końcowe, dla pól wierszy i kolumn.

Pola sum

Pola sum to pola danych, które są zawarte w danych źródłowych lub zostały utworzone przez użytkownika, aby podsumowywać dane z innych pól danych źródłowych. Na przykład jeśli w danych źródłowych znajduje się pole Sprzedaż, zawierające rekordy pojedynczych transakcji, to można utworzyć pole sumy o nazwie Suma sprzedaży, które będzie dodawać kwoty dla każdej kategorii na liście tabeli przestawnej lub pole Ile sprzedano służące do zliczania, ile produktów sprzedano w każdej kategorii. Można również utworzyć pole sumy korzystające z określonego wyrażenia.

Na liście pól pola sum są wyświetlane na górze, pod nagłówkiem Sumy. Na liście tabeli przestawnej jako pola sum można uwzględnić pola Suma sprzedaży i Jednostki.

Lista pól z polami sum

Dodawanie pola sum

W przypadku list tabel przestawnych opartych na danych źródłowych z baz danych OLAP, wartości pola sumy są wstępnie obliczane na serwerze bazy danych, który dostarcza danych źródłowych. W rezultacie niedostępne są polecenia służące do dodawania pól sum, przenoszenia pól sum do obszaru szczegółów i zmiany funkcji podsumowania używanej do obliczania wartości w polach sum.

Jeśli dostępne na liście pola sum nie zawierają odpowiednich podsumowań, a dane źródłowe na nie zezwalają, to można dodać nowe pola sum do listy tabeli przestawnej. Najczęściej pola sum są dodawane do obszaru danych. Na przykład na następującej liście tabeli przestawnej pole sumy Suma sprzedaży zostało dodane do obszaru danych, aby wyświetlić podsumowanie dla każdego sportu i kwartału.

Lista tabeli przestawnej z polem sum

1 Pole sum Suma sprzedaży

W polu sumy używana jest funkcja podsumowania, taka jak Suma lub Ile.Liczb. W zależności od typu danych źródłowych można także użyć więcej niż jednej funkcji podsumowania, aby podsumować dane z tego samego pola, dodając więcej pól sum, z których każde będzie używało innej funkcji podsumowania.

Można również dodać obliczeniowe pole sumy używające określonego wyrażenia. Na przykład aby zobaczyć wartości sprzedaży w bieżącym roku, należy utworzyć pole sumy zawierające następujące wyrażenie:

Suma (YTD(), [Miary].[Sprzedaż])

Poniższa lista tabeli przestawnej przedstawia wartości sprzedaży w bieżącym roku.

Lista tabeli przestawnej z obliczeniowym polem sumy

Zmienianie orientacji pól sum

Można zmienić orientację pól sum na liście tabeli przestawnej. Wyświetlanie pól w orientacji wierszowej oznacza, że wyświetlane są one w pierwszej kolumnie na prawo od pól wierszy. Wyświetlanie pól w orientacji kolumnowej oznacza, że wyświetlane są one w pierwszym wierszu poniżej pól kolumn.

Pokazywanie wartości sum jako procentów

Można także pokazać wartości sum jako procent sumy wierszy, kolumn lub sumy końcowej albo w postaci sumy elementu nadrzędnego na osi wierszy lub kolumn.

Lista tabeli przestawnej przedstawiająca wartości sum jako procent

1 Wartości użyte do wyświetlenia wartości sum jako procentu sumy wierszy.

2 Wartości użyte do wyświetlenia wartości sum jako procentu sumy kolumn.

3 Wartości użyte do wyświetlenia wartości sum jako procentu sumy elementu nadrzędnego na osi wierszy.

4 Wartości użyte do wyświetlenia wartości sum jako procentu sumy końcowej.

Sumy częściowe i sumy końcowe

Sumy częściowe można wyświetlać dla dowolnego pola wiersza lub kolumny na liście tabeli przestawnej, jeśli zawiera ona przynajmniej jedno pole sumy oraz więcej niż jedno pole wiersza lub więcej niż jedno pole kolumny. Jeśli w przypadku pola wybrano wyświetlanie sum częściowych, to sumy końcowe są również wyświetlane. Sumy częściowe i końcowe są wyświetlane dla każdego pola sumy na liście tabeli przestawnej, w miejscu gdzie przecina ono wybrane pole wiersza lub kolumny.

W poniższym przykładzie sumy częściowe i sumy końcowe są wyświetlone dla obu pól wierszy przy użyciu wartości z pola sumy o nazwie Suma sprzedaży.

Suma częściowa i końcowa listy tabeli przestawnej

1 Suma końcowa

2 Suma częściowa

Jeśli pole, dla którego są wyświetlane sumy częściowe lub sumy końcowe, zostanie przeniesione poza obszar wiersza lub kolumny, to sumy częściowe lub końcowe zostaną ukryte, ale ustawienie jest zachowywane. Sumy częściowe lub sumy końcowe są wyświetlane ponownie, gdy pole zostanie przeniesione z powrotem do obszaru wiersza lub kolumny.

Gdy sumy częściowe i sumy końcowe dla danego pola są ukryte, pozostają one ukryte niezależnie od tego, gdzie pole zostanie przeniesione, nawet jeśli pole zostanie usunięte z listy tabeli przestawnej, a później dodane ponownie.

Zależnie od danych źródłowych i typu danych używanych na liście tabeli przestawnej, w razie potrzeby można uwzględnić lub pominąć w sumach częściowych i sumach końcowych wartości elementów danych ukrytych na skutek filtrowania. Można określić, że w przypadku wszystkich sum częściowych i sum końcowych mają być dołączane lub wykluczane dane ukryte.


Funkcje podsumowania dostępne na liście tabeli przestawnej

W poniższej tabeli przedstawiono funkcje podsumowania dostępne za pomocą polecenia Autosumowanie [image], które umożliwiają tworzenie pól sum.

Funkcja | Opis
Suma | Oblicza sumę wartości.
Ile.Liczb | Oblicza liczbę wartości. Puste wartości, takie jak ciągi o długości zerowej (ciągi, które nie zawierają znaków), są uwzględniane w zliczaniu, ale wartości zerowe (wartości wskazujące brakujące lub nieznane dane) nie są zliczane.
Min | Zwraca najmniejszą wartość w podsumowywanym polu.
Max | Zwraca największą wartość w podsumowywanym polu.
Średnia | Zwraca średnią wartości w podsumowywanym polu.
Odchylenie standardowe | Zwraca odchylenie standardowe wartości w podsumowywanym polu, przy założeniu, że wartości są próbką z większej populacji.
Odchylenie standardowe populacji | Zwraca odchylenie standardowe wartości w podsumowywanym polu, przy założeniu, że wartości to cała populacja.
Wariancja | Zwraca wariancję wartości w podsumowywanym polu, przy założeniu, że wartości są próbką z większej populacji.
Wariancja populacji | Zwraca wariancję wartości w podsumowywanym polu, przy założeniu, że wartości to cała populacja.

Uwaga Funkcje podsumowania dostępne w danym polu zależą od typu zawartych w nim danych. Na przykład jeżeli pole zawiera tekst, to nie można użyć funkcji Suma, Min lub Max, ale można zastosować funkcję Ile.Liczb.


Pokazywanie lub ukrywanie sum dla pola

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pole wiersza lub kolumny, dla którego chcesz pokazać lub ukryć sumy częściowe i sumy końcowe.
  3. Aby pokazać sumy, tak kliknij przycisk Suma częściowa [image] na pasku narzędzi listy tabeli przestawnej, aby został wciśnięty. Aby ukryć sumy, kliknij przycisk ponownie.

Uwagi

  • Sumy częściowe i sumy końcowe nie są wyświetlane w przypadku pól znajdujących się w obszarze szczegółów (obszar, w którym można wyświetlać pojedyncze rekordy).
  • Po wybraniu wyświetlania wartości sum częściowych i sum końcowych będą wyświetlane dla każdego pola sumy na liście tabeli przestawnej. Nie można wykluczyć pojedynczych pól sum.
  • Obliczając sumy częściowe i końcowe, można włączyć lub wykluczyć elementy danych ukryte w wyniku filtrowania.


Dostosowywanie pola sumy

Zmienianie orientacji pól sum

Poniższa procedura wpływa na pola sum na liście tabeli przestawnej. Nie ma ona wpływu na sumy częściowe i sumy końcowe.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Raport.
  4. W obszarze Wyświetl sumy jako wybierz jedną z następujących opcji:
    • Nagłówki kolumn — aby wyświetlić pola sum w pierwszym wierszu pod polami kolumn lub w górnym wierszu, jeśli nie ma pól kolumn.
    • Nagłówki wierszy — aby wyświetlić pola sum w pierwszej kolumnie na prawo od pól wierszy lub w pierwszej kolumnie po lewej stronie, jeśli nie ma pól wierszy.

Pokazywanie sum w postaci procentów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Prawym przyciskiem myszy kliknij pole sumy zawierające wartości, które mają być wyświetlone w postaci procentowej, wskaż polecenie Pokaż jako, a następnie kliknij jedną z następujących opcji:
    • Procent sumy wiersza — aby wyświetlić wartości jako procent wartości całkowitej każdego wiersza.
    • Procent sumy kolumny — aby wyświetlić wartości jako procent wartości całkowitej każdej kolumny.
    • Procent elementu wiersza nadrzędnego — aby wyświetlić wartości jako procent wartości całkowitej elementu nadrzędnego dla danego elementu na osi wierszy.
    • Procent elementu kolumny nadrzędnej — aby wyświetlić wartości jako procent wartości całkowitej elementu nadrzędnego dla danego elementu na osi kolumn.
    • Procent sumy końcowej — aby wyświetlić wartości jako procent sumy końcowej danej listy tabeli przestawnej.


Dołączanie lub wykluczanie ukrytych danych podczas obliczania sum

Poniższa procedura wpływa na wszystkie sumy częściowe i sumy końcowe na liście tabeli przestawnej.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Raport.
  4. W obszarze Oblicz sum na podstawie wykonaj jedną z następujących czynności:
    • Aby dołączyć dane ukryte, wybierz opcję Wszystkie elementy (w tym elementy ukryte).

    • Aby wykluczyć dane ukryte, wybierz opcję Tylko elementy widoczne.

Uwagi

  • To ustawienie wpływa na dane ukryte poprzez filtrowanie pól wierszy i kolumn; dane ukryte na skutek zastosowania pól filtru są zawsze wykluczane z sum.

  • Po dołączeniu danych ukrytych obok podpisów sum częściowych i sum końcowych pojawiają się gwiazdki (*) oznaczające, że wartości całkowite obejmują zarówno elementy wyświetlone, jak i ukryte.


Edycja pola obliczeniowego

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz pole obliczeniowe, którego wyrażenie chcesz edytować.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Obliczanie.
  4. Edytuj wyrażenie, a następnie kliknij przycisk Zmień.

    Wartości danych zostaną automatycznie obliczone ponownie z zastosowaniem nowego wyrażenia.

Porada

Aby dodać odwołanie do pola, wybierz żądane pole z listy rozwijanej Wstaw odwołanie do, a następnie kliknąć przycisk Wstaw odwołanie do.


Hiperłącza — informacje

Hiperłącze to element umożliwiający przejście od jednego obiektu do innego. Obiektem docelowym jest zwykle inna strona sieci Web, ale może to być również obraz, adres e-mail, plik (na przykład plik multimedialny lub dokument pakietu Microsoft Office) albo program. Samo hiperłącze można wyświetlić w postaci tekstu lub obrazu.

Korzystając z hiperłączy, można wykonać następujące czynności:

  • Nawigować do określonego pliku lub strony sieci Web w sieci, w intranecie lub w Internecie

  • Wysłać wiadomość e-mail

  • Rozpocząć transfer plików, na przykład proces pobierania pliku lub proces FTP

Wskazanie tekstu lub obrazu zawierającego hiperłącze powoduje, że wskaźnik przybiera kształt dłoni Wskaźnik w kształcie dłoni, co oznacza, że wskazany element można kliknąć. Po kliknięciu hiperłącza element docelowy zostaje wyświetlony, otwarty lub uruchomiony, zależnie od jego typu. Przykładowo hiperłącze do pliku dźwiękowego umożliwia otwarcie pliku w odtwarzaczu multimedialnym, a kliknięcie hiperłącza do strony sieci Web powoduje wyświetlenie tej strony w przeglądarce.

Części adresu hiperłącza

Adres hiperłącza może składać się maksymalnie z czterech części oddzielonych znakami numeru (#):

Część | Opis
wyświetlany_tekst | Tekst widoczny w komórce, gdy dane wyświetlane są jako hiperłącza. Na przykład można wyświetlić tutaj opisową nazwę witryny sieci World Wide Web albo obiektu określonego za pomocą elementów adres i podadres. To pole jest opcjonalne.
adres | Względna lub bezwzględna ścieżka do dokumentu docelowego. Ścieżka bezwzględna zawiera pełny adres URL lub UNC dla danego dokumentu. Jeśli ta część nie zostanie określona, za adres uznaje się wartość podaną w polu wyświetlany_tekst.
podadres | Położenie w pliku lub na stronie. Można na przykład wskazać na określony akapit w dokumencie docelowym.
etykietka_ekranowa | Tekst wyświetlany po umieszczeniu wskaźnika na hiperłączu. To pole jest opcjonalne.

Pokazywanie danych w postaci hiperłączy

Zmiana ustawień właściwości pola umożliwia wyświetlenie danych w polu wiersza, kolumny i szczegółów w postaci hiperłączy. Klikając odpowiednie hiperłącza, użytkownicy mogą łatwo nawigować do innych stron i obiektów sieci Web.

Grupowanie pól zawierających hiperłącza

Wynik grupowania pól z hiperłączami zależy od tego, w jaki sposób zdefiniowano odpowiadające im pola danych źródłowych. Jeśli pole danych źródłowych zdefiniowano jako pole CLOB (Character Large Object), to pogrupowanie hiperłączy spowoduje wyświetlenie dwóch członów grupy — jednego dla wartości pustych, a drugiego dla wartości niepustych. Jeśli pole danych źródłowych zostanie zdefiniowane skalarnie, na przykład jako zmienną znakową, to odpowiednie wartości zostaną pogrupowane w zależności od poszczególnych wartości hiperłączy. Unikatowość elementów opiera się w takim przypadku na częściach hiperłącza wyświetlany_tekst i adres.


Pokazywanie danych w postaci hiperłączy

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pole wiersza, kolumny lub szczegółów, które zawiera hiperłącza.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  4. Zaznacz pole wyboru Wyświetl jako hiperłącze.


Pokazywanie lub ukrywanie etykietek ekranowych

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Raport.
  4. Zaznacz lub wyczyść pole wyboru Etykietki ekranowe.

Uwaga Ukrycie etykietek ekranowych spowoduje, że nie będą widoczne właściwości elementów wyświetlane jako etykietki ekranowe. Właściwości wyświetlane w raporcie pozostaną widoczne.


Wyświetlanie szczegółów i elementów — informacje

Można tak skonfigurować listę tabeli przestawnej, aby wyświetlała różną liczbę poziomów elementów i szczegółów dostępnych w danych źródłowych. Można wyświetlić wszystkie dostępne szczegóły i poziomy elementów, tylko podsumowania na najwyższym poziomie lub dowolny poziom szczegółów zawierający się między tymi dwoma; można także wyświetlić wybrane szczegóły dla elementów danych, które należy wyróżnić. Jeżeli dostęp nie został ograniczony, to użytkownicy mogą zmieniać listę tabeli przestawnej w przeglądarce, tak aby wyświetlała różne poziomy i różną liczbę szczegółów.

Wyświetlanie danych szczegółowych

Po prawej stronie elementów znajdujących się na najniższym poziomie w obszarze wierszy wyświetlane są symbole Pole plus i Pole minus. Poniżej podpisów odpowiadających elementom znajdującym się na najniższym poziomie w obszarze kolumn wyświetlane są symbole Pole plus i Pole minus. Można pokazać lub ukryć szczegóły dotyczące określonego elementu, klikając symbol Pole plus lub Pole minus.

Elementy na najniższym poziomie

Można wyświetlić dane szczegółowe tylko wtedy, gdy są one dostępne w danych źródłowych. Na przykład bazy danych OLAP często zapewniają tylko dane dotyczące podsumowania bez danych szczegółowych.

Automatyczne pokazywanie lub ukrywanie wszystkich szczegółów

Domyślnie dane szczegółowe nie są na początku wyświetlane w przeglądarce, kiedy użytkownik dodaje pola do listy tabeli przestawnej. W zależności od preferencji można jednak automatycznie wyświetlać dane szczegółowe dla wszystkich elementów.

Ograniczanie dostępu do danych szczegółowych w przeglądarce

Można określić odpowiednią ilość szczegółów dostępnych do wyświetlania, a następnie uniemożliwić użytkownikom wyświetlanie dodatkowych szczegółów w przeglądarce.

Wyświetlanie elementów niższego poziomu

Jeśli w obszarze wierszy lub kolumn znajduje się więcej niż jedno pole, to po lewej stronie elementów wyższego poziomu wyświetlane są wskaźniki rozwijania (symbole Pole plus lub Pole minus). Po kliknięciu wskaźnika rozwijania pokazują się lub ukrywają elementy znajdujące się na kolejnym, niższym poziomie. Jeśli pole znajdujące się najniżej na liście tabeli przestawnej nie jest najniższe w hierarchii elementów, to kliknięcie odpowiadającego mu wskaźnika rozwijania spowoduje automatyczne dodanie kolejnego, niższego poziomu elementów na liście.

Można wyświetlić dane niższego poziomu dla całego pola lub element po elemencie, rozwijając tylko żądane elementy. Elementy na najniższym poziomie nie mają wskaźników rozwijania. Na przykład jeśli w obszarze wierszy znajdują się pola Kraj i Miasto, to przy elementach w polu Kraj wskaźniki rozwijania zostaną wyświetlone w następujący sposób:

Przykład wskaźników rozwijania

1 Wskaźniki rozwijania

Automatyczne pokazywanie lub ukrywanie wszystkich elementów

Domyślnie można rozwijać bądź zwijać wszystkie poziomy elementów na liście tabeli przestawnej. Po załadowaniu listy użytkownik może rozwijać lub zwijać wybrane elementy.

Ukrywanie wskaźników rozwijania

Po odpowiednim rozwinięciu wybranych poziomów można ukryć wszystkie wskaźniki rozwijania na liście tabeli przestawnej. Użytkownicy mogą zmienić to ustawienie w przeglądarce. Aby użytkownicy nie mogli decydować o tym, czy wskaźniki rozwijania są wyświetlane, należy ograniczyć dostęp do okna dialogowego Polecenia i opcje w przeglądarce.

Pokazywanie lub ukrywanie elementów bez danych

Domyślnie na liście tabeli przestawnej nie wyświetlane są elementy, dla których nie ma wartości w danych źródłowych. Na przykład jeśli pokazywana jest wielkość sprzedaży dla każdego miesiąca, a w kwietniu niczego nie sprzedano, to pole Miesiąc nie będzie zawierało elementu Kwiecień. Chcąc dołączyć elementy dla wszystkich dwunastu miesięcy, z pustymi komórkami dla miesięcy bez sprzedaży, można zmienić odpowiednie ustawienie w oknie dialogowym Polecenia i opcje, aby wyświetlić elementy niezawierające danych.


Pokazywanie lub ukrywanie wskaźników rozwijania obok elementów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.
  4. Zaznacz lub wyczyść pole wyboru Rozwiń wskaźnik.

Uwagi

  • Ustawienie to nie wpływa na pola [image] i [image] wyświetlane po prawej stronie elementów najniższego poziomu.
  • Elementy na najniższym poziomie obszaru wiersza lub kolumny nie mają wskaźników rozwijania po lewej stronie.
  • Aby użytkownicy nie mogli decydować, czy wskaźniki rozwijania będą wyświetlane, można ograniczyć dostęp do okna dialogowego Polecenia i opcje w przeglądarce.


Pokazywanie lub ukrywanie danych szczegółowych dla elementu lub pola

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:

    • Aby pokazać lub ukryć dane szczegółowe dla danej komórki lub elementu na najniższym poziomie, zaznacz element lub komórkę.

    • Aby pokazać lub ukryć dane szczegółowe dla pola wiersza lub kolumny, zaznacz odpowiednie pole wiersza lub kolumny.
  3. Kliknij przycisk Pokaż szczegóły [image] lub Ukryj szczegóły [image] na pasku narzędzi.

Uwagi

  • Aby pokazać lub ukryć elementy niższego poziomu, należy zaznaczyć odpowiednie pole wiersza lub kolumny albo wybrany element, a następnie kliknąć przycisk Rozwiń [image] lub Zwiń [image] na pasku narzędzi.
  • Jeśli użytkownicy nie mają wyświetlać danych szczegółowych, to można ograniczyć dostęp do szczegółów w przeglądarce.


Pokazywanie lub ukrywanie elementów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Aby pokazać lub ukryć elementy niższego poziomu przyporządkowane do określonego elementu na osi wierszy lub kolumn, kliknij wskaźnik rozwijania (pole Pole plus lub Pole minus) obok danego elementu.
    • Aby pokazać lub ukryć elementy niższego poziomu dla wszystkich elementów w polu wiersza lub kolumny, kliknij etykietę pola, a następnie kliknij przycisk Rozwiń Pole plus lub Zwiń Pole minus na pasku narzędzi.

Uwagi

  • Jeśli pole Pole plus lub Pole minus nie jest widoczne obok danego elementu, to należy zaznaczyć pole wyboru Wskaźnik rozwijania na karcie Zachowanie w oknie dialogowym Polecenia i opcje. Jeśli po zaznaczeniu tego pola wyboru wskaźnik rozwijania nie pojawi się obok elementu, to może oznaczać, że dany element znajduje się na najniższym poziomie dostępnym w danych źródłowych.

  • Aby pokazać lub ukryć szczegóły, należy zaznaczyć element lub pole, a następnie kliknij przycisk Pokaż szczegóły Pole plus lub Ukryj szczegóły Pole plus na pasku narzędzi.


Pokazywanie lub ukrywanie elementów niezawierających żadnych danych

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Raport.
  4. Zaznacz lub wyczyść pola wyboru Puste wiersze i Puste kolumny.


Automatyczne pokazywanie wszystkich danych szczegółowych

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.
  4. Na liście Domyślnie rozwiń szczegóły wybierz pozycję Zawsze.

Uwagi

  • Aby ukryć dane szczegółowe dla wszystkich elementów, należy wybrać pozycję Nigdy z listy Domyślnie rozwiń szczegóły. Ustawienie pozycji Automatycznie na liście Domyślnie rozwiń szczegóły spowoduje, że dane ze źródeł tabelarycznych zostaną domyślnie rozwinięte, ale dane z baz danych OLAP będą ukryte.
  • Aby automatycznie pokazać wszystkie elementy na liście tabeli przestawnej, na karcie Zachowanie, na liście Domyślnie rozwiń elementy należy ustawić pozycję Zawsze.
  • W przypadku list tabel przestawnych opartych na danych źródłowych z baz danych OLAP, dane szczegółowe są zwykle niedostępne do wyświetlania. Jeśli dane szczegółowe są niedostępne, to zmiana ustawienia listy Domyślnie rozwiń szczegóły nie da żadnego efektu.


Automatyczne pokazywanie wszystkich elementów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zachowanie.
  4. Na liście Domyślnie rozwiń elementy wybierz pozycję Zawsze.

Uwagi

  • Aby ukryć wszystkie elementy, należy wybrać pozycję Nigdy na liście Domyślnie rozwiń elementy. Wybranie pozycji Automatycznie na liście Domyślnie rozwiń elementy spowoduje, że domyślnie będą rozwinięte pola ze źródeł tabelarycznych, a ukryte pola z baz danych OLAP.

  • Aby automatycznie pokazywać wszystkie szczegóły listy tabeli przestawnej, należy wybrać pozycję Zawsze z listy Domyślnie rozwiń elementy na karcie Zachowanie.


Dodawanie, edycja i usuwanie danych szczegółowych

Jeśli nie można dodawać, edytować lub usuwać danych na liście tabeli przestawnej, to może oznaczać, że:

  • Na karcie Ochrona w oknie dialogowym Polecenia i opcje ustawiono takie właściwości, które zapobiegają dodawaniu, edycji lub usuwaniu danych.
  • Pole, które użytkownik próbuje edytować, jest polem tylko do odczytu i nie obsługuje edycji.
  • Tabela nie ma klucza podstawowego.

Dodawanie danych

  1. Kliknij komórkę w pustym wierszu oznaczonym gwiazdką (*).
  2. Wpisz dane, które mają się znaleźć w pierwszym polu, a następnie naciśnij klawisz TAB, aby przejść do następnego pola.
  3. Wykonaj jedną z następujących czynności:
    • Naciśnij klawisz ENTER, aby zapisać rekord i przejść do następnego rekordu.
    • Naciśnij klawisz ESC, aby pozostawić rekord bez zapisywania go.

Edycja danych

  1. Kliknij komórkę, którą chcesz edytować.
  2. Wpisz nową wartość.
  3. Wykonaj jedną z następujących czynności:
    • Naciśnij klawisz ENTER, aby zapisać rekord i przejść do następnego rekordu.
    • Naciśnij klawisz ESC, aby pozostawić rekord bez zapisywania go.

Usuwanie danych

  • Wykonaj jedną z następujących czynności:
    • Aby usunąć zawartość komórki, kliknij ją i naciśnij klawisz DELETE.
    • Aby usunąć rekord, kliknij komórkę z lewej strony rekordu, a następnie naciśnij klawisz DELETE.
    • Aby usunąć większą liczbę rekordów, kliknij komórkę z lewej strony rekordu, przeciągnij wskaźnik myszy do ostatniej komórki ostatniego rekordu, a następnie naciśnij klawisz DELETE.

Uwagi

  • Wprowadzając dane w polu, do którego zastosowano format liczby, nie trzeba uwzględniać formatowania. Po opuszczeniu komórki jej zawartość zostanie sformatowana automatycznie.
  • Na liście tabeli przestawnej można bezpośrednio edytować jedynie komórki szczegółów. Aby zmienić podpis lub tytuł, należy użyć okna dialogowego Polecenia i opcje.


Właściwości elementów — informacje

Aby wyświetlić dodatkowe informacje na temat poszczególnych elementów, należy wyświetlić niestandardowe właściwości danego pola wiersza lub kolumny. Na przykład jeśli administrator bazy danych udostępnił dwie właściwości niestandardowe związane z polem Sklep — Kierownik i Numer telefonu, to można wybrać wyświetlanie każdego elementu pola Sklep na liście tabeli przestawnej lub jako etykietki ekranowej.

Na poniższej ilustracji przedstawiono wygląd raportu Pracownicy z uwzględnieniem właściwości niestandardowych Wykształcenie i Roczny dochód.

Lista tabeli przestawnej z właściwościami niestandardowymi

Użytkownicy listy tabeli przestawnej nie mogą tworzyć właściwości niestandardowych. Mogą jednak wyświetlać i ukrywać właściwości oraz określać, czy mają one być wyświetlane w raporcie, czy jako etykietki ekranowe.

Na poniższej ilustracji przedstawiono właściwość Wykształcenie wyświetloną w raporcie i właściwość Roczny dochód wyświetloną jako etykietka ekranowa.

Lista tabeli przestawnej z właściwościami niestandardowymi

Użytkownicy listy tabeli przestawnej mogą również formatować podpisy i wartości właściwości oraz określać kolejność ich wyświetlania w raporcie lub w formie etykietek ekranowych.

Źródła danych inne niż OLAP nie obsługują właściwości niestandardowych.


Pokazywanie lub ukrywanie właściwości elementów

Można pokazać właściwości elementów pól wierszy i kolumn zarówno w raporcie, jak i w postaci etykietek ekranowych.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pole, którego właściwości niestandardowe chcesz pokazać lub ukryć.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Właściwości elementu.
  4. Na liście Właściwości elementu wybierz właściwość, której ustawienia chcesz zmienić.
  5. Na liście Wyświetl w zaznacz jedną z następujących pozycji:
    • Raport — aby pokazać podpis i wartość właściwości obok nazwy elementu.
    • Etykietka ekranowa — aby pokazać podpis i wartość właściwości jako część etykietki ekranowej poszczególnych elementów.
    • Wszystko — aby pokazać podpis i wartość właściwości zarówno w raporcie, jak i w postaci etykietki ekranowej.
    • Brak — aby ukryć podpis i wartość właściwości.
  6. Powtórz krok 4 i 5 dla każdej właściwości niestandardowej w zaznaczonym polu.

Uwagi

  • Wybierając pokazywanie właściwości w postaci etykietek ekranowych, należy się upewnić, że pole wyboru Etykietki ekranowe na karcie Raport w oknie dialogowym Polecenia i opcje jest zaznaczone.
  • Można zmienić kolejność wyświetlania właściwości niestandardowych w raporcie lub w postaci etykietki ekranowej.
  • Można sformatować podpis i wartość właściwości niestandardowej. Formatowanie nie zostanie uwzględnione, jeśli właściwość będzie wyświetlana jako etykietka ekranowa.
  • Źródła danych inne niż OLAP nie obsługują właściwości niestandardowych.


Określanie kolejności wyświetlania właściwości elementów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pole, dla którego chcesz określić kolejność właściwości elementów.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Właściwości elementu.

    Kolejność właściwości pokazana w polu Właściwości elementu przedstawia kolejność ich wyświetlania w raporcie lub w postaci etykietek ekranowych.

  4. Zaznacz właściwość, którą chcesz wyświetlić na początku, a następnie klikaj przycisk W górę [image], aż pojawi się ona jako pierwszy element na liście.
  5. Uporządkuj pozostałe właściwości, klikając przycisk W górę [image] lub W dół [image].

Uwaga Jeśli po określeniu kolejności do listy zostaną dodane nowe właściwości, to będą one wyświetlane na końcu listy do momentu ponownego ustawienia kolejności.


Formatowanie listy tabeli przestawnej i jej elementów — informacje

Formatowanie elementów

Można formatować pola wierszy, kolumn, sum i szczegółów, pasek tytułu oraz podpisy obszaru upuszczania, a także właściwości niestandardowe pól wierszy lub kolumn. Opcje formatowania obejmują:

  • Ustawianie formatu tekstu Można ustawić czcionkę, rozmiar czcionki i kolor tekstu oraz pogrubienie, pochylenie bądź podkreślenie tekstu. Wprowadzone przez użytkowników zmiany ustawień przeglądarki w zakresie czcionek i kolorów nie mają żadnego wpływu na listy tabel przestawnych.

  • Wyrównywanie tekstu w komórce Można wyświetlić wartości komórek w taki sposób, aby były wyrównane do lewej, do prawej lub wyśrodkowane w poziomie. Nie można zmieniać wyrównania wartości w pionie.

  • Ustawianie kolorów tła Można zmienić kolor tła komórek. Wprowadzone przez użytkowników zmiany ustawień przeglądarki w zakresie kolorów nie mają żadnego wpływu na listy tabel przestawnych.

  • Zmiana formatu liczby Istnieje możliwość zmiany formatu wyświetlania liczb, dat i czasu na jeden z kilku wstępnie zdefiniowanych formatów liczb. W języku Microsoft Visual Basic lub w skrypcie można przypisać do danych niestandardowe formaty liczb.

    Można, na przykład, wyświetlić liczbę jako wartość walutową lub jako procent, a datę w formacie długim, z dniem i miesiącem zapisanym pełnym wyrazem lub w formacie skróconym. Zmiany formatu liczby nie wpływają na rzeczywiste wartości, a wyłącznie na sposób ich wyświetlania. Sposób wyświetlania zastosowanych przez użytkownika formatów liczb w przeglądarce zależy od ustawień regionalnych w Panelu sterowania systemu Microsoft Windows.

Formaty zastosowane do jednego elementu mogą mieć wpływ na elementy podobne. Na przykład zmiana koloru tekstu wybranego elementu spowoduje sformatowanie wszystkich elementów w tym samym polu za pomocą nowego koloru tekstu.

Formatowanie całej listy tabeli przestawnej

Za pomocą jednej operacji nie można ustawić formatowania całej listy tabeli przestawnej. Każdy element listy tabeli przestawnej należy sformatować oddzielnie.

Dostosowanie wyglądu każdego elementu listy tabeli przestawnej może wymagać tymczasowej zmiany układu, aby sformatować elementy, które nie znajdą się w początkowej prezentacji danych. Na przykład aby ustanowić formaty dla pola w obszarze szczegółów, podczas gdy początkowy układ nie zawiera tego pola, należy je przenieść do obszaru szczegółów, sformatować, a następnie przenieść z powrotem w poprzednie miejsce. Gdy użytkownicy przenoszą pola do różnych obszarów listy tabeli przestawnej w przeglądarce, pola i zawarte w nich dane przyjmują format ustanowiony dla pól i danych w tych obszarach.


Formatowanie listy tabeli przestawnej i jej elementów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz element, który chcesz sformatować.

    Jak?

    Zaznaczanie całej listy tabeli przestawnej

    • Kliknij pasek tytułu.

    Uwaga Nie można wyświetlić paska tytułu, jeśli lista tabeli przestawnej nie jest powiązana z żadnym źródłem danych.

    Zaznaczanie jednej lub większej liczby komórek danych

    • Aby zaznaczyć pojedynczą komórkę, kliknij ją. Aby zaznaczyć grupę komórek, kliknij i przeciągnij wskaźnik myszy, aż wszystkie żądane komórki będą zaznaczone.

    Zaznaczanie pola wiersza, kolumny lub filtru

    • Kliknij etykietę pola.

    Uwaga Zaznaczenie pola wiersza lub kolumny powoduje zaznaczenie wszystkich elementów danych znajdujących się w tym polu.

    Zaznaczanie pola szczegółów

    • Kliknij etykietę pola. Jeśli dane szczegółowe są wyświetlane w przypadku kilku elementów i etykieta pola pojawia się wielokrotnie, to kliknięcie jednego wystąpienia powoduje zaznaczenie wszystkich wystąpień etykiety danego pola.

    Zaznaczanie pola sum

    • Kliknij dowolną etykietę pola dla pola sum.

    Zaznaczanie jednego lub większej liczby elementów

    • Aby zaznaczyć pojedynczy element, kliknij jego etykietę.
    • Aby dodać więcej elementów do zaznaczenia, naciśnij i przytrzymaj wciśnięty klawisz CTRL podczas klikania kolejnych etykiet elementów.
    • Aby zaznaczyć cały zakres elementów, kliknij etykietę pierwszego elementu, naciśnij klawisz SHIFT, a następnie kliknij etykietę ostatniego elementu.

    Uwaga Zaznaczenie elementu powoduje zaznaczenie wszystkich związanych z nim danych.

    Zaznaczanie sumy częściowej lub sumy końcowej

    • Kliknij sumę częściową lub sumę końcową.

    Uwaga Zaznaczenie sumy częściowej lub sumy końcowej powoduje zaznaczenie wszystkich danych tej sumy.

    Zaznaczanie paska tytułu lub obszaru upuszczania

    1. Kliknij pasek tytułu.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Podpisy.

    3. Na liście Wybierz podpis zaznacz odpowiedni element.

    Zaznaczanie niestandardowej właściwości pola wiersza lub kolumny

    1. Kliknij pole wiersza lub kolumny albo jeden z jego elementów.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Właściwości elementu.
    3. Na liście Właściwości elementu zaznacz odpowiednią właściwość.

      Uwaga Jeśli wybrane pole nie ma żadnych właściwości niestandardowych, to lista Właściwości elementu będzie pusta.

      Można określić ustawienia związane z podpisem, formatem liczby i położeniem wybranej właściwości. Wybrane formaty zostaną zastosowane tylko do wskazanej właściwości.

    4. Aby określić ustawienia czcionek i stylu dla danej właściwości, wybierz pozycję Podpis właściwości lub Wartość właściwości z listy Format.

    Uwaga Ustawienia czcionki i stylu tekstu zastosowane do danej właściwości niestandardowej mają wpływ na wszystkie właściwości niestandardowe na liście tabeli przestawnej, ale tylko wtedy, gdy są one wyświetlone w raporcie. Jeśli dana właściwość niestandardowa jest wyświetlana w postaci etykietki ekranowej, to formatowanie jest ignorowane.

    Zaznaczanie całej listy tabeli przestawnej

    • Kliknij pasek tytułu.

    Uwaga Nie można wyświetlić paska tytułu, jeśli lista tabeli przestawnej nie jest powiązana z żadnym źródłem danych.

    Zaznaczanie jednej lub większej liczby komórek danych

    • Aby zaznaczyć pojedynczą komórkę, kliknij ją. Aby zaznaczyć grupę komórek, kliknij i przeciągnij wskaźnik myszy, aż wszystkie żądane komórki będą zaznaczone.

    Zaznaczanie pola wiersza, kolumny lub filtru

    • Kliknij etykietę pola.

    Uwaga Zaznaczenie pola wiersza lub kolumny powoduje zaznaczenie wszystkich elementów danych znajdujących się w tym polu.

    Zaznaczanie pola szczegółów

    • Kliknij etykietę pola. Jeśli dane szczegółowe są wyświetlane w przypadku kilku elementów i etykieta pola pojawia się wielokrotnie, to kliknięcie jednego wystąpienia powoduje zaznaczenie wszystkich wystąpień etykiety danego pola.

    Zaznaczanie pola sum

    • Kliknij dowolną etykietę pola dla pola sum.

    Zaznaczanie jednego lub większej liczby elementów

    • Aby zaznaczyć pojedynczy element, kliknij jego etykietę.
    • Aby dodać więcej elementów do zaznaczenia, naciśnij i przytrzymaj wciśnięty klawisz CTRL podczas klikania kolejnych etykiet elementów.
    • Aby zaznaczyć cały zakres elementów, kliknij etykietę pierwszego elementu, naciśnij klawisz SHIFT, a następnie kliknij etykietę ostatniego elementu.

    Uwaga Zaznaczenie elementu powoduje zaznaczenie wszystkich związanych z nim danych.

    Zaznaczanie sumy częściowej lub sumy końcowej

    • Kliknij sumę częściową lub sumę końcową.

    Uwaga Zaznaczenie sumy częściowej lub sumy końcowej powoduje zaznaczenie wszystkich danych tej sumy.

    Zaznaczanie paska tytułu lub obszaru upuszczania

    1. Kliknij pasek tytułu.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Podpisy.

    3. Na liście Wybierz podpis zaznacz odpowiedni element.

    Zaznaczanie niestandardowej właściwości pola wiersza lub kolumny

    1. Kliknij pole wiersza lub kolumny albo jeden z jego elementów.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Właściwości elementu.
    3. Na liście Właściwości elementu zaznacz odpowiednią właściwość.

      Uwaga Jeśli wybrane pole nie ma żadnych właściwości niestandardowych, to lista Właściwości elementu będzie pusta.

      Można określić ustawienia związane z podpisem, formatem liczby i położeniem wybranej właściwości. Wybrane formaty zostaną zastosowane tylko do wskazanej właściwości.

    4. Aby określić ustawienia czcionek i stylu dla danej właściwości, wybierz pozycję Podpis właściwości lub Wartość właściwości z listy Format.

    Uwaga Ustawienia czcionki i stylu tekstu zastosowane do danej właściwości niestandardowej mają wpływ na wszystkie właściwości niestandardowe na liście tabeli przestawnej, ale tylko wtedy, gdy są one wyświetlone w raporcie. Jeśli dana właściwość niestandardowa jest wyświetlana w postaci etykietki ekranowej, to formatowanie jest ignorowane.
  3. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi.
  4. Wykonaj jedną z następujących czynności:
    • Aby sformatować obszar upuszczania, kliknij kartę Podpisy.
    • Aby sformatować właściwość elementu dla wybranego pola wiersza lub kolumny, kliknij kartę Właściwości elementu.
    • Aby sformatować inne elementy listy tabeli przestawnej, kliknij kartę Format.
  5. Wykonaj co najmniej jedną z następujących czynności:

    Określanie ustawień czcionki i stylu

    • Aby tekst był pogrubiony, kliknij przycisk Pogrubienie [image].

    • Aby tekst był napisany kursywą, kliknij przycisk Kursywa [image].

    • Aby tekst był podkreślony, kliknij przycisk Podkreślenie [image].

    • Aby zmienić kolor tekstu, kliknij strzałkę obok pola Kolor czcionki [image], a następnie kliknij żądany kolor.

    • Aby zmienić czcionkę, kliknij inną czcionkę na liście czcionek.

    • Aby zmienić rozmiar czcionki, wybierz odpowiednią pozycję z listy znajdującej się obok listy czcionek.

    Uwaga Czcionki i rozmiar czcionek dostępne na listach zależą od czcionek zainstalowanych na komputerze użytkownika.

    Wyrównanie tekstu

    • Kliknij odpowiednie wyrównanie: Wyrównaj do lewej [image], Wyśrodkuj [image] lub Wyrównaj do prawej [image].

    Ustawianie koloru tła

    • Kliknij strzałkę obok pola Kolor wypełnienia [image], a następnie kliknij żądany kolor.

    Zmienianie formatu liczby zastosowanego do pola, sumy lub właściwości elementu w polu wiersza lub kolumny

    • Na liście Format liczby kliknij żądany format.

    Uwaga Format liczby zastosowany w przypadku danego pola nie wpływa na format innych pól wierszy, kolumn, filtrów lub sum. Format liczby zastosowany do właściwości elementu nie wpływa na inne właściwości elementów.

Uwagi

  • Nie można sformatować zawartości etykietki ekranowej. Formatowanie zastosowane do wybranej właściwości elementu będzie więc widoczne wyłącznie po jej wyświetleniu w raporcie.
  • Nie można sformatować całej listy tabeli przestawnej w jednej operacji.


Formatowanie zawartości listy tabeli przestawnej pod kątem czytania od strony prawej do lewej lub od lewej do prawej

Należy użyć formatu od prawej do lewej, jeśli lista tabeli przestawnej będzie przeglądana w językach odczytywanych od strony prawej do lewej. Wybranie takiego wyświetlania spowoduje, że elementy listy tabeli przestawnej będą wyświetlone w postaci lustrzanego obrazu domyślnego układu od lewej do prawej. Obszary upuszczania będą więc w prawej górnej części listy tabeli przestawnej, pola wierszy w kolumnach po prawej stronie, a elementy w kolumnach będą ustawione w kolejności od prawej do lewej.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pasek tytułu listy tabeli przestawnej.
  3. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi, a następnie kliknij kartę Zachowanie.
  4. Zaznacz lub wyczyść pole wyboru Wyświetl od prawej do lewej.


Formaty liczb dla list tabel przestawnych

Część zawartości tego tematu może nie dotyczyć niektórych języków.

W poniższej tabeli przedstawiono formaty liczb obsługiwane przez listy tabel przestawnych.

Format | Efekt
Ogólny | Wyświetla liczbę wyrównaną do prawej, bez separatora tysięcy, poprzedzoną znakiem minus w przypadku liczb ujemnych. Wyświetlane jest maksymalnie 11 cyfr lub 10 cyfr z przecinkiem dziesiętnym, z zaokrągleniem dodatkowych cyfr po prawej stronie przecinka dziesiętnego. Liczby, które mają więcej niż 11 cyfr po lewej stronie przecinka dziesiętnego są wyświetlane w formacie naukowym. Wyświetla tekst wyrównany do lewej strony.
Data ogólna | Wyświetla liczbę jako datę z opcjonalną godziną. Na przykład 8/31/99 05:54 AM. Ułamkowa część liczby jest interpretowana jako godzina. Jeżeli liczba nie ma części ułamkowej, to wyświetlana jest wyłącznie data. Jeżeli liczba ma wyłącznie część ułamkową, to wyświetlana jest tylko godzina.
Data długa | Wyświetla datę zgodnie z regionalnym ustawieniem systemu Windows dla długiego formatu daty. Na przykład czwartek, 25 stycznia 2001.
Data średnia | Wyświetla datę, używając skróconej nazwy miesiąca i łącznika (-) oddzielającego miesiąc, dzień i rok. Na przykład 25-sty-2001.
Data krótka | Wyświetla datę zgodnie z regionalnym ustawieniem systemu Windows dla krótkiego formatu daty. Na przykład 1/25/01.
Godzina długa | Wyświetla godzinę zgodnie z regionalnym ustawieniem systemu Windows dla długiego formatu godziny. Na przykład 8:45:36 PM.
Godzina średnia | Wyświetla godzinę w formacie 12-godzinnym ze znacznikiem AM lub PM z pominięciem sekund. Na przykład 8:45 PM.
Godzina krótka | Wyświetla godzinę w formacie 24-godzinnym, z pominięciem sekund. Na przykład 20:45.
Waluta | Wyświetla liczbę zgodnie z ustawieniami regionalnymi systemu Windows dla waluty. Na przykład, zgodnie z polskimi ustawieniami regionalnymi, 2 532,75 zł.
Waluta euro | Wyświetla liczbę jako walutę euro z separatorem tysięcy i dwoma miejscami po przecinku. Znak euro jest umieszczony przed lub za liczbą, zgodnie z ustawieniami regionalnymi dla waluty w Panelu sterowania systemu Windows. Na przykład zgodnie z polskimi ustawieniami regionalnymi będzie to 12,35 [image] .
Stały | Wyświetla liczbę z dwoma miejscami dziesiętnymi. Na przykład 68,30.
Standardowy | Wyświetla liczbę zgodnie z ustawieniami regionalnymi systemu Windows dotyczącymi liczb. Na przykład może to być spacja w charakterze separatora tysięcy i przecinek jako symbol dziesiętny 1 800,00.
Procentowy | Wyświetla liczbę pomnożoną przez 100, z dwoma miejscami dziesiętnymi i znakiem procentu. Na przykład wartość 0,8914 będzie wyświetlana jako 89,14%.
Naukowy | Wyświetla liczbę w notacji wykładniczej. Na przykład 1,25E+10.
Tak/Nie | Wyświetla wyraz Nie, jeżeli liczba wynosi 0 albo wyraz Tak, jeżeli ma inną wartość.
Prawda/Fałsz | Wyświetla wyraz Fałsz, jeżeli liczba ma wartość 0 albo wyraz Prawda, jeżeli ma inną wartość.
Wł/Wył | Wyświetla skrót Wył, jeżeli liczba ma wartość 0 albo skrót Wł, jeżeli ma inną wartość.

Uwagi

  • Ustawienia regionalne w Panelu sterowania systemu Windows określają sposób wyświetlania formatów liczb, waluty, daty i czasu zarówno w programie do projektowania, jak i w czasie wykonania w przeglądarce. Na przykład ustawienia te określają, czy lata są wyświetlane w postaci dwucyfrowej, czy czterocyfrowej. Informacje o formatach można znaleźć w Pomocy systemu Windows.

  • W języku Microsoft Visual Basic lub w skrypcie można przypisać do danych niestandardowe formaty liczb. Można także wpisać niestandardowe formaty dostępne w modelu obiektów listy tabeli przestawnej w polu Liczba.


Sortowanie danych — informacje

Można sortować dane podczas projektowania listy tabeli przestawnej lub wyświetlania jej w przeglądarce. Można także częściowo ograniczyć dostęp do sortowania w przeglądarce.

Sortowanie w kolejności rosnącej lub malejącej

Można posortować kolumnę sprzedaży w kolejności rosnącej lub kolumnę z nazwiskami pracowników w kolejności malejącej.

Można także posortować listę tabeli przestawnej oddzielnie dla każdej kolumny. Kolejność sortowania kolumn określa sposób zorganizowania danych.

Przykład danych sortowanych według dwóch kolumn

W powyższym przykładzie lista jest zorganizowana według sprzedawców. Kolumna Produkt była sortowana jako pierwsza, a więc produkty będą ustawione w kolejności alfabetycznej; kolumna Sprzedawca była sortowana jako druga.

Podczas sortowania wielu kolumn należy najpierw określić kolejność sortowania kolumn, a następnie postępować w odwrotnym porządku, sortując najbardziej zewnętrzną kolumnę na końcu. Na przykład sortując dwie kolumny, należy określić, która z nich jest kolumną zewnętrzną, a która wewnętrzną. Najpierw należy posortować kolumnę wewnętrzną, a następnie kolumnę zewnętrzną. Aby wymienić produkty w kolejności alfabetycznej dla każdego sprzedawcy, należy najpierw posortować wewnętrzną kolumnę Produkt, a później zewnętrzną kolumnę Sprzedawca.

Definiowanie niestandardowej kolejności sortowania

Jeśli sortowanie w kolejności rosnącej lub malejącej nie odpowiada wymaganiom, to można zdefiniować kolejność niestandardową dla pola wiersza lub kolumny. Na przykład można wyświetlić wartości w kolumnie Tytuł na podstawie starszeństwa tytułu. Jeśli w kolumnie znajdują się trzy wartości — Wiceprezes, Dyrektor naczelny i Kierownik — to sortowanie w kolejności rosnącej lub malejącej nie spowoduje wyświetlenia danych we właściwej kolejności. W takim przypadku może wystąpić potrzeba samodzielnego określenia kolejności elementów w kolumnie Tytuł.

Jeśli po określeniu kolejności niestandardowej do danego pola zostaną dodane nowe elementy, to będą one wyświetlane w dolnej części pola do momentu ponownego określenia właściwego rozmieszczenia.

Sortowanie niestandardowe jest zachowywane, ale nie wpływa na dane źródłowe.


Sortowanie danych na liście tabeli przestawnej

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:

    Sortuj w kolejności rosnącej lub malejącej

    Można sortować wyświetlane dane w kolejności naturalnej lub niestandardowej, rosnąco lub malejąco.

    1. Wykonaj jedną z następujących czynności:

      • Aby sortować dane w polu opartym na etykietach elementów, kliknij etykietę pola zawierającego dane, które chcesz sortować.

      • Aby sortować dane w polu opartym na wartościach podsumowanych w kolumnie, kliknij komórkę w kolumnie zawierającej wartości, które chcesz sortować.

      • Aby sortować dane w polu opartym na wartościach sum częściowych lub sum końcowych, kliknij wartość sumy częściowej lub sumy końcowej dla pola zawierającego dane, które chcesz sortować.

        Uwaga Kliknięcie wartości sumy końcowej w dolnym wierszu spowoduje, że zamiast wierszy zostaną posortowane kolumny.

    2. Na pasku narzędzi kliknij przycisk Sortuj rosnąco [image] lub Sortuj malejąco [image].

    Uwaga Aby posortować większą liczbę pól, należy rozpocząć od pola znajdującego się najgłębiej i przechodzić przez kolejne pola do tego, które znajduje się najbardziej na zewnątrz.

    Określ niestandardową kolejność sortowania

    1. Zaznacz element, który chcesz przenieść.
    2. Przeciągnij zaznaczony element i upuść go na element, nad którym chcesz go umieścić.
    3. Powtarzaj krok 1 i 2 do uzyskania odpowiedniej kolejności elementów.

    Uwaga Jeśli pole z sortowaniem niestandardowym ma pole nadrzędne, to w każdym członie tego pola człony niższego poziomu zostaną wyświetlone w kolejności niestandardowej.

Uwagi

  • Aby przełączyć sortowanie w kolejności rosnącej lub malejącej na sortowanie niestandardowe, należy kliknąć przycisk Sortuj rosnąco [image] lub Sortuj malejąco [image], aby nie był zaznaczony.
  • Kolejność sortowania liczby, tekstu i znaków specjalnych zależy od danych źródłowych i ustawień regionalnych w Panelu sterowania systemu Microsoft Windows. Jeśli użytkownicy mają inne ustawienia regionalne w przeglądarkach, to ich kolejność sortowania może być różna od zamierzonej.


Usuwanie kolejności sortowania

Usunięcie rosnącej lub malejącej kolejności sortowania powoduje, że dane zostaną wyświetlone w normalnej kolejności lub w kolejności niestandardowej, jeśli została ona określona.

  • Kliknij przycisk Sortuj rosnąco [image] lub Sortuj malejąco [image] na pasku narzędzi, tak aby nie był zaznaczony.


Grupowanie elementów — informacje

Dane można grupować podczas projektowania listy tabeli przestawnej lub oglądania jej za pomocą przeglądarki. Można jednak ograniczyć dostęp do grupowania w przeglądarce.

Elementy w polu wiersza lub kolumny można grupować na dwa sposoby.

Grupowanie przedziałami

Elementy można grupować, określając typ i rozmiar przedziału. Na przykład można zgrupować pole z wartościami dat w różnych miesiącach i określić przedział jako 2, aby utworzyć grupy, takie jak sty-lut, mar-kwi itd.

Rodzaj przedziału, który można określić dla danego pola, zależy od związanego z polem typu danych.

  • Pola numeryczne Można grupować je w przedziały będące dowolną liczbą całkowitą, na przykład 1, 2, 5, 100 itd. Można, na przykład, uporządkować elementy pola IDPracownika w grupach 1-100, 101-200 itd.
  • Pola daty i godziny Można je grupować w przedziały takie jak dni, tygodnie czy kwartały. Przykładowo można pogrupować wartości w polu DataDostawy według miesięcy, aby oddzielnie pokazać dane dotyczące zamówień zrealizowanych w styczniu, w lutym itd.
  • Pola tekstowe Można je grupować na podstawie określonej liczby n znaków początkowych poszczególnych elementów. Przykładowo można pogrupować wartości pola Nazwisko według pierwszej litery, uzyskując w ten sposób grupy takie jak A, B.

Istnieje możliwość określenia wartości początkowych i końcowych zakresu grupowania. Na przykład jeśli podczas grupowania pola DataDostawy na podstawie przedziału tygodniowego wartość początkową zakresu ustawiono na 01-lip-1999, to zostaną utworzone następujące grupy:

<01-lip-1999, 01-lip-1999, 08-lip-1999, ...

Daty poprzedzające 01-lip-1999 zostaną zebrane w jednej grupie zatytułowanej <01-lip-1999.

Jeśli użytkownik określi również wartość końcową jako 31-gru-1999, to utworzone zostaną następujące grupy:

<01-lip-1999, 01-lip-1999, 08-lip-1999, ... 31-gru-1999, >31-gru-1999

Daty przypadające na okres po 31-gru-1999 zostaną zebrane w jednej grupie zatytułowanej >31-gru-1999.

Grupowanie niestandardowe

Można dowolnie wybierać elementy z pola wiersza lub kolumny i łączyć je w grupy wyższego poziomu. Można, na przykład, wybrać wszystkie awanse przypadające na dany okres z pola Awanse i utworzyć z nich osobną grupę. Spowoduje to dodanie powyżej pola Awanse nowego pola wiersza Awanse 2, w którym znajdą się dwa człony — Grupa1 i Inne. Użytkownik może zmienić podpis Grupa1 na Stałe i Awanse 2 na Kategoria w oknie dialogowym Polecenia i opcje.

W grupie Inne znajdą się wszystkie elementy, których użytkownik nie włączył do niestandardowej grupy Stałe. Można następnie zaznaczyć wszystkie zwykłe awanse w grupie Inne i utworzyć nową grupę niestandardową o nazwie Zwykłe. Po przeprowadzeniu tej czynności pole Kategoria będzie się składało z trzech członów: Stałe, Zwykłe i Inne.

Na poniższej ilustracji przedstawiono wygląd tabeli przestawnej po zmianie podpisów niestandardowych pól i grup.

Lista lub widok tabeli przestawnej z grupami niestandardowymi

1 Pole grupy niestandardowej. Jego elementami są grupy niestandardowe. Wyświetlane jest jako pole nadrzędne w stosunku do pola, którego elementy zostały zgrupowane.

2 Grupy niestandardowe. Wyświetlane są jako elementy nadrzędne w stosunku do elementów wybranych wyraźnie przez użytkownika w celu utworzenia grupy.

3 Grupa Inne to element nadrzędny w stosunku do elementów, których nie przypisano do żadnej grupy niestandardowej.

Tworzenie i usuwanie grup niestandardowych i pól grup niestandardowych

  • W grupie niestandardowej nie można grupować elementów należących do różnych pól ani elementów należących do elementów nadrzędnych.

  • Po utworzeniu pierwszej grupy niestandardowej dla danego pola zostaje do niego automatycznie dodane pole grupy niestandardowej, będące dla niego polem nadrzędnym. Usunięcie ostatniej grupy niestandardowej dla danego pola powoduje z kolei automatyczne usunięcie pola grupy niestandardowej.

  • Usunięcie grupy, która nie jest ostatnią grupą niestandardową w danym polu, powoduje automatyczne przeniesienie jej elementów do grupy Inne.

  • Tworzone grupy są zachowywane, ale jedynie po stronie klienta. Innymi słowy, grupy utworzone przez użytkownika są dostępne na opracowywanych stronach sieci Web, ale nie stanowią części danych źródłowych.

Przenoszenie pola grupy niestandardowej do obszaru szczegółów

Po przeniesieniu zestawu pól zawierającego pola grup niestandardowych do obszaru szczegółów lub obszaru filtru, pola grup niestandardowych nie są widoczne. Można jednak wyświetlić hierarchię grup niestandardowych za pomocą listy rozwijanej w polu związanym, co pozwala na filtrowanie danych poprzez wybieranie odpowiednich grup niestandardowych lub poszczególnych wartości. Po przeniesieniu zestawu pól z powrotem do obszaru wierszy lub kolumn zostaną w nim wyświetlone pola grup niestandardowych.

Dodawanie i usuwanie zagnieżdżonych grup niestandardowych

Wybranie dwóch lub większej liczby grup niestandardowych umożliwia utworzenie grupowania wyższego poziomu. Można, na przykład, podzielić człony pola Kategoria na dwie grupy: awanse o wysokim priorytecie oraz awanse o niskim priorytecie.

Na poniższej ilustracji przedstawiono wygląd obszaru wierszy z uwzględnieniem zagnieżdżonych grup niestandardowych.

Lista lub widok tabeli przestawnej z zagnieżdżonymi grupami niestandardowymi

1 Pole grupy niestandardowej wyświetlone jako pole nadrzędne względem pola Kategoria.

Można również usuwać grupy niestandardowe niższego poziomu. Na poniższej ilustracji przedstawiono wygląd danych po usunięciu pola Kategoria.

Lista lub widok tabeli przestawnej z grupami niestandardowymi


Grupowanie lub rozgrupowywanie elementów

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:

    Zgrupuj elementy w przedziałach

    1. Zaznacz pole wiersza lub kolumny, którego elementy chcesz grupować.
    2. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi, a następnie kliknij kartę Filtrowanie i grupowanie.
    3. W polu Grupowanie elementów według ustaw wartość inną niż (Brak grupowania).
    4. Ustaw żądaną wartość w polu Przedział. Na przykład jeśli elementy są grupowane według znaków prefiksu, ustawienie w polu Przedział wartości 1 spowoduje pogrupowanie na elementy z A, B, C itd.
    5. Aby określić wartość początkową grupowania, zaznacz pole wyboru Zacznij od, a następnie wprowadź odpowiednią wartość w polu tekstowym.
    6. Aby określić wartość końcową grupowania, zaznacz pole wyboru Zakończ na, a następnie wprowadź odpowiednią wartość w polu tekstowym.

      Uwaga Wartość końcowa musi być większa niż wartość początkowa.

    Usuń grupowanie w przedziały

    1. Zaznacz pole wiersza lub kolumny, z którego chcesz usunąć grupowanie.
    2. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi, a następnie kliknij kartę Filtrowanie i grupowanie.
    3. W polu Grupowanie elementów według ustaw wartość (Brak grupowania).

    Utwórz grupy niestandardowe

    1. Kliknij etykietę pola nadrzędnego zawierającego elementy, które chcesz grupować, a następnie kliknij przycisk Rozwiń [image] na pasku narzędzi.
    2. Kliknij pierwszy element, który chcesz dołączyć do grupy.

      Aby zaznaczyć więcej elementów, przytrzymaj wciśnięty klawisz CTRL i kliknij każdy element.

    3. Prawym przyciskiem myszy kliknij zaznaczony element, a następnie wybierz polecenie Grupuj elementy.
    4. Powtórz krok 2 i 3, aby utworzyć więcej grup.

    Uwagi

    • Dodanie pierwszej grupy niestandardowej w danym polu powoduje dodanie pola grupy niestandardowej do zestawu pól. Pole to jest nadrzędne względem pola, którego elementy zostały pogrupowane.
    • Można zmienić podpis pola grupy niestandardowej i grup niestandardowych w oknie dialogowym Polecenia i opcje.

    Usuń grupowanie niestandardowe

    • Wykonaj jedną z następujących czynności:
      • Aby usunąć grupę niestandardową, prawym przyciskiem myszy kliknij podpis grupy, a następnie kliknij polecenie Rozgrupuj elementy.
      • Aby usunąć pole grupy niestandardowej, prawym przyciskiem myszy kliknij to pole, a następnie kliknij polecenie Usuń.

    Uwagi

    • Nie można kliknąć prawym przyciskiem myszy elementu Inne i rozgrupować go.
    • Jeśli grupa, która ma być usunięta, jest ostatnią grupą niestandardową w danym polu, to pole grupy niestandardowej zostanie usunięte razem z grupą. Jeśli usuwana grupa nie jest ostatnią grupą niestandardową, to jej człony zostaną przeniesione do grupy Inne.


Filtrowanie danych na liście tabeli przestawnej — informacje

Korzystając z funkcji filtrowania, można odnaleźć określone wartości danych lub wszystkie dane odpowiadające wybranej wartości. Dane można filtrować podczas projektowania listy tabeli przestawnej albo wyświetlania jej w przeglądarce. Można także ograniczyć dostęp do filtrowania w przeglądarce.

Techniki filtrowania

Filtrowanie pola (autofiltrowanie) Można filtrować pola w obszarach wierszy, kolumn i szczegółów. Aby filtrować pole, należy zaznaczyć co najmniej jeden element danych w tym polu, który ma być widoczny, i ukryć pozostałe elementy.

Lista lub widok tabeli przestawnej po zastosowaniu filtrowania

1 Na początku filtrowane jest pole Sport, aby wyświetlić wyłącznie sprzedaż związaną z golfem...

2 ...następnie filtrowane jest pole Kwartał, aby wyświetlić wartości sprzedaży związanej z golfem w trzecim kwartale.

3 Podczas filtrowania pola odpowiednia strzałka rozwijania Strzałka pola zmienia kolor z czarnego na niebieski, a przycisk Autofiltr [image] na pasku narzędzi zostaje wciśnięty.

Filtrowanie pól jest szczególnie pomocne, gdy istnieje duża ilość danych źródłowych, a należy się skupić na określonym temacie. Podczas filtrowania pola można wyświetlić dane dla pojedynczego elementu lub wybrać jedne elementy do wyświetlenia, a inne do ukrycia. Można filtrować więcej niż jedno pole jednocześnie, aby zawęzić obszar zainteresowania.

Filtrowanie na podstawie danych w jednej komórce (filtrowanie według wyborów) Można tak filtrować pole, aby wyświetlić wyłącznie dane odpowiadające wartości w zaznaczonej komórce. Filtrowanie według wyborów jest szczególnie użyteczne w przypadku pól znajdujących się w obszarze szczegółów, gdy użytkownik chce przejrzeć wszystkie wiersze zawierające pewną wartość.

Korzystanie z pola na osi filtru Można filtrować dane za pomocą pól filtrów. Po zaznaczeniu jednego lub większej liczby elementów w polu filtru wyświetlone i obliczone dane na całej liście tabeli przestawnej zmienią się odpowiednio do tego elementu. Można dodawać nowe pola filtrów lub przenosić istniejące pola do obszaru filtru.

Przykład pola filtru

1 Pole filtru

Filtrowanie warunkowe Można zastosować filtr do pola wiersza lub kolumny, aby pokazać określoną, najmniejszą lub największą, liczbę n elementów na podstawie sumy. Na przykład można zastosować filtrowanie, aby wyszukać trzy miasta, w których wygenerowano największą wartość sprzedaży lub pięć produktów, które przyniosły najmniejszy zysk. Zamiast podawać określoną liczbę n elementów, można zastosować filtrowanie do określonego procentu elementów. Na przykład można wyświetlić 25% najlepszych lub najgorszych sprzedawców na podstawie liczby zrealizowanych zamówień. Jeśli ogółem jest 40 sprzedawców, to po zastosowaniu filtru wyświetlą się dane dziesięciu osób.

Łączenie większej liczby filtrów

Filtry można łączyć. Każdy nowo zastosowany filtr jest dodawany do filtrów zastosowanych wcześniej. Zastosowanie filtrowania według wyborów powoduje jednak usunięcie filtru warunkowego zastosowanego wcześniej w przypadku danego pola.

Filtry warunkowe na liście tabeli przestawnej działają niezależnie od siebie. Wynik działania jednego filtru warunkowego nie wpływa na wynik działania innych.

Autofiltrowanie jest stosowane zawsze przed filtrem warunkowym, niezależnie od kolejności filtrowania ustalonej przez użytkownika. Na przykład jeśli użytkownik ustawił filtr warunkowy, aby pokazać dwa miasta przodujące pod względem wartości sprzedaży, a następnie zastosował autofiltrowanie do pola MiastoDostawy, aby objęło ono jedynie pięć miast, to na liście tabeli przestawnej zostaną pokazane najlepsze dwa miasta spośród pięciu wskazanych.

Usuwanie i ponowne stosowanie filtru

Wyłączenie autofiltrowania umożliwia wyświetlenie wszystkich danych dla wszystkich pól. Ustawienia filtrowania są zachowywane, więc po ponownym włączeniu autofiltrowania te same dane będą wyświetlone lub ukryte.

Ustawienia filtru są zachowywane po przeniesieniu pól w celu zmiany układu. Jeśli użytkownik usunie pole, a następnie doda je ponownie do układu, to te same elementy zostaną znów ukryte.

Aby nie zachowywać wyborów filtru, należy upewnić się przed rozpoczęciem zaznaczania elementów do filtrowania, że przycisk Autofiltr [image] nie jest zaznaczony. Jeżeli przycisk nie jest wciśnięty, to wskazanie nowych elementów do filtrowania automatycznie włączy filtrowanie i usunie wcześniejsze ustawienia filtru.

Identyfikowanie aktualnie zastosowanych filtrów

Jeśli elementy w polu są ukryte na skutek zastosowania autofiltru lub filtrowania według wyborów, to strzałka rozwijania Strzałka pola na etykiecie pola jest niebieska. Należy kliknąć niebieską strzałkę [image], aby zobaczyć aktualnie zastosowany filtr.

Jeśli elementy w polu są ukryte na skutek zastosowania filtrowania warunkowego, to po lewej stronie strzałki rozwijania Strzałka pola pojawia się ikona Ikona lejka. Więcej informacji na temat aktualnie zastosowanych filtrów można znaleźć w oknie dialogowym Polecenia i opcje.

Wpływ filtrowania na obliczenia

Sumy mogą obejmować tylko dane wyświetlone lub zarówno dane widoczne, jak i ukryte. Domyślnie dane ukryte są wykluczane w przypadku sumowania — z wyjątkiem list tabel przestawnych opartych na danych źródłowych pochodzących z baz danych OLAP i opublikowanych za pomocą programu Excel, które dołączają dane ukryte do sumy końcowej. Można zmienić ustawienia, aby dane ukryte były dołączane do sumy lub wykluczane z niej. Ustawienie wpływa jedynie na dane ukryte na skutek filtrowania pól wierszy i kolumn; dane ukryte za pomocą pól filtrów są zawsze wykluczane w przypadku obliczania sumy.

Wyszukiwanie określonych danych

Aby wyszukiwać dane zamiast je filtrować lub aby znajdować dane zgodne z wzorcem, należy wyeksportować listę tabeli przestawnej do programu Microsoft Excel. Aby uzyskać informacje o korzystaniu z polecenia Znajdź w programie Excel, zobacz Pomoc tego programu.

Ograniczanie filtrowania w przeglądarce

Aby uniemożliwić użytkownikom zmianę ustawień filtrowania, można wyłączyć filtrowanie w przeglądarce.


Filtrowanie pola na liście tabeli przestawnej

Filtrowanie pola w obszarze wiersza, kolumny, filtru lub szczegółów (autofiltrowanie)

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij strzałkę Strzałka pola pola zawierającego elementy danych, które chcesz filtrować.
  3. Zaznacz pola wyboru dla elementów, które chcesz wyświetlać, a wyczyść pola wyboru dla elementów, które chcesz ukryć.

Uwagi

  • Aby wyświetlić lub ukryć wszystkie dane dla pola, należy zaznaczyć lub wyczyścić pole wyboru Pokaż wszystko. Zacieniowane pole wyboru oznacza, że niektóre elementy niższego poziomu są ukryte. Aby zobaczyć, które elementy niższego poziomu są ukryte, należy kliknąć wskaźnik rozwijania Pole plus obok elementu z wycieniowanym polem wyboru.
  • Pole umieszczone w obszarze wiersza, kolumny lub szczegółów zawsze obsługuje funkcję zaznaczania wielokrotnego. Pole w obszarze filtru może obsługiwać albo zaznaczanie pojedyncze, albo zaznaczanie wielokrotne. Aby przełączyć zaznaczanie z wielokrotnego na pojedyncze, na karcie Filtrowanie i grupowanie w oknie dialogowym Polecenia i opcje należy wyczyścić pole wyboru Zezwalaj na zaznaczanie wielu elementów w obszarze filtru.

Wyświetlanie danych zgodnych z komórką listy tabeli przestawnej (filtrowanie według wyborów)

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij prawym przyciskiem myszy komórkę zawierającą wartość, którą chcesz wyświetlić, a następnie kliknij w menu skrótów polecenie Filtruj według wyborów.

Filtrowanie pola wiersza lub kolumny w celu wyszukania n największych lub najmniejszych wartości albo wartości procentowych (filtrowanie warunkowe)

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz pole zawierające wartości, które chcesz filtrować.
  3. Kliknij przycisk Polecenia i opcje Strzałka pola na pasku narzędzi, a następnie kliknij kartę Filtrowanie i grupowanie.
  4. W polu Wyświetl ustaw opcję Od góry lub Od dołu.
  5. W polu Elementy ustaw liczbę z listy lub wpisz odpowiednią wartość.
  6. Aby pokazać n elementów, wyczyść pole wyboru %. Aby pokazać n% elementów, zaznacz pole wyboru %.
  7. Ustaw wartość na liście Oparty na.

Uwagi

  • Jeśli elementy pola są ukryte za pomocą autofiltrowania lub filtrowania według wyborów, to strzałka Strzałka pola na etykiecie pola jest niebieska. Jeśli elementy są ukryte za pomocą filtrowania warunkowego, to z lewej strony strzałki filtrowanego pola wyświetlona jest ikona lejka Ikona lejka.
  • Sumy wyświetlone po zastosowaniu filtrowania są oparte jedynie na widocznych elementach. Można zmienić to ustawienie, aby uwzględniać także dane ukryte.


Usuwanie filtrów, aby wyświetlić wszystkie dane listy tabeli przestawnej

Jeśli elementy w polu są ukryte w wyniku zastosowania filtrowania pola lub filtrowania według wyborów, to strzałka Strzałka pola na etykiecie pola jest niebieska. Jeśli elementy są ukryte w wyniku zastosowania filtrowania związanego z najwyższymi lub najniższymi wartościami, to po lewej stronie strzałki filtrowanego pola wyświetlana jest ikona lejka Ikona lejka.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:

    Usuń wszystkie filtry

    • Kliknij przycisk Autofiltr [image] na pasku narzędzi, tak aby nie był zaznaczony.

    Uwaga Ponowne kliknięcie przycisku Autofiltr [image] w celu przywrócenia filtrowania spowoduje zastosowanie poprzednio ustawionych filtrów.

    Usuń z pola autofiltrowanie lub filtrowanie według wyborów

    1. Kliknij niebieską strzałkę Strzałka pola z filtrem pola, z którego chcesz usunąć filtr.
    2. Zaznacz pole wyboru Wszystko i kliknij przycisk OK.

    Usuń z pola filtrowanie warunkowe

    1. Zaznacz pole, z którego chcesz usunąć filtrowanie warunkowe.
    2. Kliknij przycisk Pokaż górne/dolne elementy [image] na pasku narzędzi, a następnie kliknij polecenie Pokaż wszystko.
Uwagi
  • Jeśli ustawienia filtrów nie mają być zachowywane, to przed rozpoczęciem zaznaczania elementów do filtrowania należy się upewnić, że przycisk Autofiltr nie jest wciśnięty [image]. Jeżeli przycisk nie jest wciśnięty, to zaznaczenie nowych elementów do filtrowania automatycznie spowoduje włączenie filtrowania i usunięcie wcześniejszych ustawień filtru.
  • Aby uniemożliwić użytkownikom usuwanie filtrów w przeglądarce, należy wyczyścić pole wyboru Filtr na karcie Ochrona w oknie dialogowym Polecenia i opcje.


Zezwalanie na wielokrotny wybór w obszarze filtru

Można określić, czy pole w obszarze filtru ma obsługiwać wybór pojedynczy, czy też wielokrotny. W trybie pojedynczego wyboru zaznaczenie jakiegoś elementu powoduje automatycznie wyczyszczenie poprzedniego zaznaczenia. Po zaznaczeniu jakiegoś elementu w trybie wielokrotnego wyboru zaznaczone wcześniej elementy pozostają wybrane.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz pole w obszarze filtru, którego ustawienia chcesz zmienić.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Filtrowanie i grupowanie.
  4. Zaznacz lub wyczyść pole wyboru Zezwalaj na zaznaczanie wielu elementów w obszarze filtru.

Uwagi

  • Domyślnie wybór wielokrotny jest włączony.
  • Ustawienie to dotyczy jedynie pola znajdującego się w obszarze filtru. Pole przeniesione do obszaru wierszy, kolumn lub szczegółów zawsze obsługuje wybór wielokrotny.


Odświeżanie listy tabeli przestawnej z użyciem zaktualizowanych danych źródłowych

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Odśwież [image].

Uwagi

  • Kostka logo Office Kostka logo Office przestaje się obracać, gdy operacja odświeżania jest zakończona. W czasie odświeżania listy tabeli przestawnej nie można interakcyjnie z nią pracować ani wprowadzać zmian.

  • Aby anulować operację odświeżania, należy nacisnąć klawisz ESC. Odświeżanie można anulować, gdy lista tabeli przestawnej jest obliczana — nie ma takiej możliwości podczas pobierania danych źródłowych.


Listy tabel przestawnych opublikowane za pomocą programu Microsoft Excel — informacje

Raport tabeli przestawnej programu Microsoft Excel ma pewne możliwości, które nie są zachowywane po zapisaniu lub opublikowaniu raportu w formie listy tabeli przestawnej. W związku z tym może zaistnieć potrzeba użycia innego programu do projektowania w celu wprowadzenia dodatkowych zmian po opublikowaniu.

Poniższa tabela zawiera podsumowanie informacji o funkcjach raportu tabeli przestawnej programu Excel, których działanie zmienia się po opublikowaniu raportu w postaci listy tabeli przestawnej.

Funkcja | Wynik na stronie sieci Web
Pola obliczeniowe | Formuły nie są zachowywane. Są zmieniane na pola sum używające domyślnej funkcji podsumowania dla pola (Suma, Ile.Liczb, Min lub Max).
Elementy obliczeniowe | Niezachowywane.
Funkcje podsumowania | Zachowywane są wyłącznie pola danych podsumowywane z użyciem funkcji Suma, Ile.Liczb, Min lub Max. Pola danych używające innych funkcji podsumowania są tracone.
Obliczenia niestandardowe | Niezachowywane. Pole danych używające obliczeń niestandardowych jest tracone.
Formatowanie znaków i komórek | Niezachowywane. Zmiany dotyczące czcionek, rozmiaru i koloru tekstu oraz tła komórek są tracone.
Niestandardowe sumy częściowe | Niezachowywane. Jeżeli użytkownik zmieni funkcję podsumowania w programie Excel, to sumy częściowe i sumy końcowe zostaną z powrotem zamienione na funkcję podsumowania pola sumy na liście tabeli przestawnej w sieci Web.
Formaty liczb | Częściowo zachowane. Formaty liczb stosowane w polach tabeli przestawnej w programie Excel są zachowywane, ale formaty liczb stosowane w przypadku pojedynczych komórek nie są zachowywane. Jeżeli użytkownik korzysta z niestandardowego formatu liczb lub z formatu, który nie jest obsługiwany przez listę tabeli przestawnej w sieci Web, to liczby mają ten sam format liczby, co raport tabeli przestawnej programu Excel. Jeżeli użytkownik zmieni format liczby dla pola na liście tabeli przestawnej, to nie będzie można przywrócić w polu niestandardowego formatu liczby.
Gwiazdki oznaczające sumy | Nawet jeśli użytkownik wyłączy gwiazdki oznaczające sumy w programie Excel, to będą one wyświetlane na liście tabeli przestawnej w sieci Web.
Ustawienia wydruku | Niezachowywane. Ustawienia programu Excel dotyczące powtarzania etykiet wierszy i kolumn tabeli przestawnej na każdej stronie oraz powtarzania etykiet elementów po każdym znaku podziału strony i wstawiania podziału strony między sekcjami są tracone.
Zgrupowane elementy w polach | Częściowo zachowane. Zgrupowane elementy w polach daty są zachowywane, ale wszystkie zaznaczone elementy i elementy numeryczne zgrupowane w programie Excel nie są zgrupowane na liście tabeli przestawnej w sieci Web, a pola grup z programu Excel nie są zachowywane.
Niestandardowy porządek sortowania | Niezachowywany. Zamiast tego dane są ustawiane w kolejności pobierania ze źródłowej bazy danych.
Formaty z wcięciami | Niezachowywane. Pola pozostają w tych samych położeniach, ale formatowanie znaków i komórek nie jest zachowywane. Puste wiersze pomiędzy grupami elementów są tracone.
Sumy częściowe wyświetlane na początku grup elementów | Niezachowywane. Sumy częściowe pojawiają się u dołu każdej grupy.
Autopokazywanie początkowych/końcowych elementów | Niezachowywane. Wyświetlane są wszystkie elementy.
Niestandardowe wartości błędów i puste wartości komórek | Niezachowywane. Błędy i puste komórki są wyświetlane jako puste komórki.
Pola stron w wierszach lub kolumnach | Niezachowywane. Pola strony stają się polami filtru, które są zawsze wyświetlane przy górnej krawędzi.
Ustawienia hasła | Dane w arkuszach i skoroszytach chronionych hasłem nie mogą być zapisywane ani publikowane jako strona sieci Web. Aby opublikować dane, które są chronione, trzeba użyć hasła pustego (lub nie używać żadnego hasła). Zapisanie hasła bazy danych z kwerendą w programie Excel powoduje, że użytkownicy muszą wprowadzić hasło przy otwieraniu strony sieci Web w przeglądarce.
Odświeżanie w tle, pobieranie danych indywidualnie dla każdego elementu w polu strony | Niezachowywane. Lista tabeli przestawnej w sieci Web jest zawsze odświeżana na pierwszym planie i wszystkie dane dla pól filtru są pobierane w jednej operacji.
Zmiany w danych źródłowych programu Excel | Niedostępne. Aby ponownie zdefiniować zakres danych źródłowych programu Excel lub zmienić kwerendę w celu wybrania innych danych zewnętrznych, należy wprowadzić zmianę w programie Excel i ponownie opublikować dane.
Źródła danych pliku modułu offline | Nie można ponownie połączyć się z oryginalną bazą danych na serwerze z opublikowanej listy tabeli przestawnej ani wprowadzać zmian w zawartości pliku modułu danych w trybie offline z listy tabeli przestawnej. Jeżeli użytkownik musi wykonać jedną z tych operacji, może to zrobić w programie Excel, a następnie ponownie opublikować dane na liście tabeli przestawnej.


Eksportowanie listy tabeli przestawnej do programu Excel lub innych aplikacji — informacje

Użytkownicy, którzy swobodnie posługują się raportami tabel przestawnych programu Microsoft Excel i chcą pracować z danymi w tym programie, mogą to zrobić na kilka sposobów. Otwarcie strony sieci Web zawierającej listę tabeli przestawnej bezpośrednio w programie Excel spowoduje jednak, że nie będzie można przeglądać lub modyfikować listy tabeli przestawnej.

Użytkownicy mają w przeglądarce te same możliwości eksportowania i kopiowania, co osoba pracująca w programie do projektowania.

Eksportowanie do interakcyjnego raportu tabeli przestawnej programu Excel

Aby przeglądać i modyfikować listę tabeli przestawnej zawartą na stronie sieci Web za pomocą programu Excel, można ją do niego wyeksportować. Raport tabeli przestawnej programu Excel będzie połączony z tymi samymi danymi źródłowymi, co pierwotna lista tabeli przestawnej, więc wszystkie pola i dane z pierwotnej listy będą dostępne w programie Excel i będzie można odświeżyć raport, jeśli zmienią się dane źródłowe.

Przygotowanie eksportowania do programu Excel Raporty tabel przestawnych programu Excel nie wyświetlają pól szczegółów. Po wyeksportowaniu do programu Excel pola szczegółów będą dostępne na pasku narzędzi Tabela przestawna, ale nie będą wyświetlane w raporcie. Jeśli raport ma odzwierciedlać wygląd listy tabeli przestawnej zawartej na stronie sieci Web, to przed eksportowaniem należy przenieść wszystkie pola poza obszar szczegółów albo ukryć dane szczegółowe dotyczące elementów i komórek, aby nie był wyświetlany żaden obszar szczegółów.

Po wyeksportowaniu Po wyeksportowaniu listy tabeli przestawnej do programu Excel można zauważyć w niej pewne zmiany. Zostały one spowodowane tym, że raporty tabel przestawnych w programie Excel nie obsługują niektórych funkcji list albo implementują je w inny sposób. Aby uzyskać informacje dotyczące różnic pomiędzy listami tabel przestawnych i raportami programu Excel, zobacz Pomoc programu Excel.

Kopiowanie danych do innego programu w celu wykorzystania nieinterakcyjnego

Kopiowanie do programów Microsoft Word lub Excel Aby pracować z dokładną kopią danych wyświetlanych na liście tabeli przestawnej, można skopiować i wkleić dane do programu Excel lub Word. Po skopiowaniu całej listy tabeli przestawnej do innego programu lub po skopiowaniu zaznaczonych części danych, tekst i wartości z listy tabeli przestawnej stają się częścią dokumentu programu Word lub skoroszytu programu Excel. Nie tworzy się połączenie pomiędzy danymi źródłowymi listy tabeli przestawnej i kopią w dokumencie czy skoroszycie, nie można zatem odświeżać ani aktualizować skopiowanych danych.

Kopiowanie do innych programów Można także skopiować dane wyświetlone na liście tabeli przestawnej do innych programów, takich jak Microsoft FrontPage czy Microsoft Access. W przypadku kopiowania danych do innego niż Word lub Excel programu, który nie obsługuje formatu HTML używanego przez listy tabel przestawnych, dane są kopiowane jako tekst niesformatowany.


Eksportowanie lub kopiowanie listy tabeli przestawnej do programu Excel lub innych aplikacji

Eksportowanie listy tabeli przestawnej do programu Excel

Używając poniższej procedury, można wyeksportować listę tabeli przestawnej z programu do projektowania do programu Excel, jako interakcyjny raport tabeli przestawnej. Połączenie pomiędzy raportem tabeli przestawnej w programie Excel i pierwotną źródłową bazą danych zostanie zachowane.

Aby uzyskać najlepsze wyniki, przed wyeksportowaniem listy tabeli przestawnej do programu Excel należy przenieść wszystkie pola z obszaru szczegółów lub ukryć szczegółowe dane dla elementów i komórek.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij listę tabeli przestawnej.
  3. Kliknij przycisk Eksportuj do programu Excel [image] na pasku narzędzi listy tabeli przestawnej, aby uruchomić program Excel lub przełączyć do niego i wyświetlić dane w raporcie tabeli przestawnej.

Uwaga Ponieważ raporty tabel przestawnych w programie Excel nie pozwalają na wyświetlenie pewnych układów i obliczeń z listy tabeli przestawnej, konkretny raport może wyglądać inaczej niż odpowiadająca mu lista tabeli przestawnej w programie do projektowania. Aby uzyskać informacje o pracy z raportami tabel przestawnych w programie Excel i dodawaniu do nich pól, zobacz Pomoc programu Excel.

Kopiowanie listy tabeli przestawnej do programu Excel lub Word

Poniższa procedura służy do kopiowania listy tabeli przestawnej lub jej części jako nieinterakcyjnej, sformatowanej tabeli do programu Microsoft Excel lub Microsoft Word.

  1. W oknie projektowania upewnij się, że lista tabeli przestawnej jest uaktywniona. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Aby skopiować całą listę tabeli przestawnej, kliknij pasek tytułu listy.
    • Aby skopiować część listy tabeli przestawnej, zaznacz elementy, które chcesz skopiować.
  3. Na pasku narzędzi listy tabeli przestawnej kliknij przycisk Kopiuj [image].
  4. Przełącz do programu Excel lub Word i kliknij w miejscu, w którym mają się pojawić dane z listy tabeli przestawnej.
  5. Kliknij przycisk Wklej [image].

Uwagi

  • Podczas kopiowania listy tabeli przestawnej lub jej części kopiowane są tylko wartości danych i formatowanie. Nie ustanawiane jest połączenie między kopią w programie Excel lub Word i pierwotną źródłową bazą danych.

  • Można skopiować część listy tabeli przestawnej jako tekst niesformatowany do innych programów, takich jak Microsoft Access.


Rozwiązywanie problemów z listami tabel przestawnych

Część zawartości tego tematu może nie dotyczyć niektórych języków.

Interakcyjne korzystanie z listy tabeli przestawnej

Użytkownicy nie mogą korzystać interakcyjnie z listy tabeli przestawnej

Użytkownicy, którzy mogą przeglądać listę tabeli przestawnej, ale nie mogą z niej korzystać w sposób interakcyjny, być może nie mają zainstalowanych składników Microsoft Office Web Components albo nie mają odpowiedniej licencji Microsoft Office XP. Należy się upewnić, że składniki są zainstalowane i użytkownik ma prawidłową licencję.

Przenoszenie pól

Nie mogę dodać lub przenieść wybranego pola

Być może pole już jest wyświetlone Jedno pole można wyświetlić wyłącznie w jednym obszarze.

Dane źródłowe mogą zawierać ograniczenia dotyczące używania pól Dane źródłowe z baz danych OLAP zawierają zestawy pól odpowiadające różnym poziomom szczegółów. Można ukrywać poziomy szczegółów wewnątrz jednego zestawu, ale nie można rozdzielać pól zestawu i wyświetlić ich w różnych obszarach.

Po zmianie układu dane pojawiają się dopiero po dłuższym czasie

Jeżeli obliczenie listy tabeli przestawnej zajmuje dużo czasu, to można wprowadzić jednocześnie wiele zmian układu, a następnie pobrać dane po zakończeniu wprowadzania zmian.

  1. Jeśli kostka logo Office obraca się Logo Office, naciśnij klawisz ESC, aby anulować obliczenia. Na liście tabeli przestawnej będą wówczas wyświetlone wyłącznie nazwy pól.

  2. Zmień układ, dodając i przenosząc tyle pól, ile trzeba.

  3. Aby pobrać i obliczyć dane dla nowego układu, kliknij przycisk Odśwież [image] na pasku narzędzi listy tabeli przestawnej.

Okno dialogowe Polecenia i opcje lub lista pól zniknęły

Kliknięcie na stronie sieci Web formantu innego niż składnik Microsoft Office Web Component lub zminimalizowanie i przywrócenie okna projektowania może spowodować ukrycie okna dialogowego Polecenia i opcje lub listy pól.

Chcąc ponownie wyświetlić okno lub listę pól, należy kliknąć listę tabeli przestawnej, aby ją ponownie uaktywnić.

Odświeżanie danych

Nie mogę odświeżyć danych na liście tabeli przestawnej przy użyciu danych źródłowych

Niektórych list tabel przestawnych nie można odświeżać Listy tabel przestawnych zapisywane lub publikowane za pomocą arkuszy programu Microsoft Excel oraz kwerend tekstowych i kwerend sieci Web programu Excel nie mogą być odświeżane za pomocą oryginalnych danych źródłowych w innych programach do projektowania lub w przeglądarce. W tych przypadkach należy odświeżyć oryginalny skoroszyt programu Excel i ponownie opublikować dane.

Baza danych źródłowych może być niedostępna Na przykład może nie być połączenia sieciowego albo wymagane są odpowiednie uprawnienia lub hasło dostępu, aby nawiązać połączenie z serwerem. Użytkownicy, którzy będą wyświetlać listę tabeli przestawnej w przeglądarce i tam z nią pracować, potrzebują tych samych praw dostępu i uprawnień, co osoba pracująca w programie do projektowania. Aby uzyskać pomoc, należy skontaktować się z administratorem sieci lub bazy danych.

Pakiet Office może nie obsługiwać bazy danych źródłowych Jeśli dane źródłowe pochodzą z bazy danych, która nie jest obsługiwana przez pakiet Office, to trzeba zainstalować uzyskane od sprzedawcy bazy danych oprogramowanie obsługujące bazę danych, zgodne z pakietem Office. Użytkownicy muszą zainstalować to samo oprogramowanie, aby odświeżać listę tabeli przestawnej w przeglądarce.

Źródłowa baza danych została zmieniona Niekiedy zmiany organizacji bazy danych lub serwera uniemożliwiają odświeżanie listy tabeli przestawnej. Na przykład jeśli dane źródłowe pochodzą z bazy danych OLAP, która została skonstruowana ponownie i wprowadzono do niej zmiany dotyczące dostępnych danych, to być może trzeba utworzyć nową listę tabeli przestawnej. Aby uzyskać więcej informacji, należy skontaktować się z administratorem bazy danych.

Nie można wykonać kwerendy dla listy tabeli przestawnej

Źródłowa baza danych może być niedostępna Jeżeli lista tabeli przestawnej opiera się na danych źródłowych pochodzących z bazy danych znajdującej się w sieci, to być może serwer bazy danych lub sieć jest niedostępna albo nie ma połączenia z siecią. Należy skontaktować się z administratorem sieci lub serwera, aby sprawdzić, czy serwer i sieć są dostępne.

Być może nie masz potrzebnych uprawnień Można nawiązać połączenie z bazą danych, ale brakuje odpowiednich uprawnień do uruchamiania kwerend dla listy tabeli przestawnej. Należy skontaktować się z administratorem bazy danych, aby uzyskać informacje o uprawnieniach.

Sprawdź filtrowanie na liście tabeli przestawnej Niekiedy lista tabeli przestawnej jest filtrowana, aby wyświetlać określone elementy, a zmiany w bazie danych źródłowych eliminują jeden z tych elementów, co sprawia, że kwerenda nie może działać. Jeśli ma to miejsce, można wyłączyć filtrowanie, aby wyświetlić wszystkie elementy, a następnie kliknąć przycisk Odśwież [image] na pasku narzędzi listy tabeli przestawnej, aby uruchomić kwerendę.

Filtrowanie danych

Nie mogę zastosować wybranego sposobu filtrowania danych

Nie można filtrować na podstawie części danych w komórce — jest to funkcja dostępna w przypadku formularzy i arkuszy danych programu Microsoft Access. Chcąc zastosować filtrowanie z uwzględnieniem części komórki, należy pracować z danymi źródłowymi w programie Access zamiast na liście tabeli przestawnej. Dzięki temu można przeglądać dane bezpośrednio w formularzu lub arkuszu programu Access, który obsługuje filtrowanie na podstawie części komórki. Po ustawieniu filtrowania danych w żądany sposób w programie Access, można użyć widoku Projekt strony dostępu do danych, aby utworzyć nową listę tabeli przestawnej lub zmienić istniejącą za pomocą filtrowanych danych źródłowych. Aby uzyskać więcej informacji na ten temat, zobacz Pomoc programu Access.

Wyświetlanie danych

Nie mogę połączyć się z danymi źródłowymi określonymi dla listy tabeli przestawnej.

Źródłowa baza danych może być niedostępna Na przykład nie ma połączenia sieciowego albo konieczne są odpowiednie uprawnienia dostępu bądź hasło, aby połączyć się z serwerem. Użytkownicy, którzy chcą wyświetlać listę tabeli przestawnej w przeglądarce i tam z nią pracować, potrzebują tych samych praw dostępu i uprawnień, co osoba pracująca w programie do projektowania. Aby uzyskać pomoc, należy skontaktować się z administratorem sieci lub bazy danych.

Pakiet Microsoft Office nie obsługuje źródłowej bazy danych Jeśli dane źródłowe pochodzą z bazy danych, która nie jest obsługiwana przez pakiet Microsoft Office, to trzeba zainstalować dostarczone przez sprzedawcę baz danych oprogramowanie obsługujące bazę danych, zgodne z pakietem Office. Użytkownicy muszą zainstalować to samo oprogramowanie, aby pracować z listą tabeli przestawnej w przeglądarce. Aby uzyskać informacje o potrzebnym oprogramowaniu, należy skontaktować się ze sprzedawcą bazy danych.

Połączenie nie zostało poprawnie skonfigurowane Aby połączyć się z danymi źródłowymi, należy najpierw skonfigurować źródło danych lub połączenie między źródłową bazą danych i programem do projektowania. Trzeba się upewnić, że źródło danych skonfigurowane w programie do projektowania działa i pozwala na dostęp do bazy danych. Informacje na ten temat można znaleźć w Pomocy programu do projektowania i w pomocy sterownika źródła danych lub ODBC. Podczas dodawania danych do listy tabeli przestawnej, należy się upewnić, że zostały dołączone wszystkie konieczne informacje o połączeniu.

Nie mogę wyświetlić elementów lub danych szczegółowych.

Być może wyłączono wskaźniki rozwijania Jeśli nie widać pól Pole plus położonych z lewej strony elementów danych w polach wierszy i kolumn, należy upewnić się, że wskaźniki rozwijania są włączone.

Elementy mogą być niedostępne Jeżeli element danych znajduje się na najniższym poziomie szczegółów dostępnym dla źródła danych, to obok elementu nie ma pola Pole plus, nawet wówczas gdy wskaźniki rozwijania są włączone.

Dane źródłowe mogą nie zawierać danych szczegółowych Niektóre typy źródeł danych, na przykład bazy danych OLAP, nie zapewniają dostępu do szczegółowych rekordów danych.

Pola są wyświetlone, ale brakuje wszystkich danych

Obliczanie listy tabeli przestawnej zostało anulowane lub zatrzymane przed zakończeniem. Aby wyświetlić dane, należy kliknąć przycisk Odśwież [image] na pasku narzędzi listy tabeli przestawnej.

Porada

Przed odświeżeniem danych można zmienić układ lub zastosować filtr do elementów w polach.

Po skopiowaniu listy tabeli przestawnej do programu Excel lub Word brakuje danych

Podczas kopiowania listy tabeli przestawnej do Schowka, a następnie wklejania jej do programu Microsoft Excel lub Microsoft Word, kopiowane są tylko widoczne wiersze i kolumny. Dane, które zostały ukryte lub odfiltrowane, nie będą skopiowane.

Przed skopiowaniem danych należy wyłączyć filtrowanie, aby pokazać wszystkie dane na liście tabeli przestawnej i wyświetlić dane szczegółowe, które należy skopiować.

Aby ominąć konieczność wcześniejszego wyświetlania wszystkich danych, można wyeksportować listę tabeli przestawnej zamiast ją kopiować. Podczas eksportowania kopii listy tabeli przestawnej do programu Excel automatycznie dołączane są wszystkie dane, z zastosowaniem tego samego filtrowania. W programie Excel można uzyskać taki sam dostęp do dodatkowych pól danych źródłowych, można także zmieniać sposób filtrowania. Z programu Excel można następnie kopiować dane do programu Word lub innych programów lub ponownie opublikować dane jako listę tabeli przestawnej. Aby uzyskać informacje na temat pracy z raportami tabel przestawnych w programie Excel i publikowania ich na stronie sieci Web, zobacz Pomoc programu Excel.

W komórce wyświetlają się znaki ##### zamiast liczby

Jeżeli liczba jest zbyt szeroka, aby zmieścić się w komórce, to zamiast niej na liście tabeli przestawnej wyświetlane są znaki numeru (#). Aby rozwiązać ten problem, można:

  • Poszerzyć kolumnę, aby dopasować ją do całej liczbę.

  • Zmniejszyć czcionkę, jeśli nie należy poszerzać kolumny.

  • Zmienić format liczby na taki, który zajmuje mniej miejsca.

Nie mogę dodawać, edytować lub usuwać danych na liście tabeli przestawnej

  • Właściwości na karcie Ochrona w oknie dialogowym Polecenia i opcje zostały tak ustawione, aby uniemożliwić dodawanie, edycję lub usuwanie danych.

  • Pole, które próbujesz edytować, jest polem tylko do odczytu i nie obsługuje edycji.

  • Jeśli lista tabeli przestawnej znajduje się na stronie dostępu do danych, która obsługuje transakcje, to lista tabeli przestawnej nie obsługuje dodawania, edycji ani usuwania.

Wykres oparty na liście tabeli przestawnej jest pusty lub nie zawiera danych

Dodaj pola sum Aby wykres wyświetlał dane z listy tabeli przestawnej, należy dodać przynajmniej jedno pole sumy do listy tabeli przestawnej.

Przenieś pola do obszarów wierszy i kolumn Pola wierszy i kolumn listy tabeli przestawnej służą jako kategorie i serie danych na wykresie. Jeśli, na przykład, wszystkie pola znajdują się w obszarze szczegółów listy tabeli przestawnej, to wykres nie ma kategorii i serii do wykreślenia. Należy przenieść przynajmniej jedno pole z obszaru szczegółów lub z listy pól do obszaru wiersza lub kolumny.

Obok pól sum na liście tabeli przestawnej pojawiają się gwiazdki

Gwiazdki (*) pojawiają się obok podpisów pól sum w następujących sytuacjach:

  • Jeśli ustawi się opcję dołączania wszystkich elementów do sum, to obok sum pojawią się gwiazdki, aby wskazać, że sumy obejmują również elementy ukryte.

  • W raportach tabel przestawnych programu Excel opierających się na danych źródłowych pochodzących z baz danych OLAP (On-Line Analytical Processing) obliczenia sum częściowych i sum końcowych zawsze obejmują wartości wszystkich, zarówno wyświetlonych, jak i ukrytych, elementów w polu. W programie Excel można wyłączyć opcję wyświetlania gwiazdek.

Na liście tabeli przestawnej, bez względu na to, czy została ona utworzona na podstawie danych źródłowych z bazy danych OLAP, można wykluczyć dane ukryte podczas filtrowania z sum częściowych i końcowych, ustawiając opcję dołączania tylko wyświetlanych danych. Wybranie tej opcji powoduje ukrycie gwiazdek.